]> git.pld-linux.org Git - packages/kealib.git/blob - kealib.spec
2467b3aa8a34eec4a53c264b7ed302c2e9c0a005
[packages/kealib.git] / kealib.spec
1 #
2 # Conditional build:
3 %bcond_with     gdal    # GDAL module [since 2.0 GDAL has builtin KEA support]
4 #
5 Summary:        KEALib - HDF5 based raster file format library
6 Summary(pl.UTF-8):      KEALib - biblioteka rastrowego formatu plików opartego na HDF5
7 Name:           kealib
8 Version:        1.4.14
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        https://github.com/ubarsc/kealib/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  494e9efc0c26f904c02c31fe2e668885
14 Patch0:         %{name}-config.patch
15 URL:            http://kealib.org/
16 BuildRequires:  cmake >= 2.6.0
17 %{?with_gdal:BuildRequires:     gdal-devel}
18 BuildRequires:  hdf5-c++-devel
19 BuildRequires:  libstdc++-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 LibKEA is a project to provide an implementation of the GDAL
24 specification within the the HDF5 file format. Specifically, the
25 format will support raster attribute tables (commonly not included
26 within other formats), image pyramids, GDAL meta-data, in-built
27 statistics while also providing large file handling with compression
28 used throughout the file. Being based on the HDF5 standard, it will
29 also provide a base from which other formats could be derived and will
30 be a good choice for long term data archiving. An independent software
31 library (libKEA) has been provided through which complete access to
32 the KEA image format is provided alongside a GDAL driver allowing KEA
33 images to be used through any GDAL supported software.
34
35 %description -l pl.UTF-8
36 LibKEA to projekt dostarczający implementację specyfikacji GDAL
37 wewnątrz formatu plików HDF5. W szczególności format obsługuje tablice
38 atrybutów rastrowych (zwykle nie zawartych w innych formatach),
39 piramidy obrazów, metadane GDAL i statystyki wbudowane, zapewniając
40 także obsługę dużych plików z kompresją. Dzięki oparciu na standardzie
41 HDF5, zapewnia także podstawę, z której mogą wywodzić się inne
42 formaty; jest także dobrym wyborem do długoterminowej archiwizacji
43 danych. Udostępniono niezależną bibliotekę (libKEA), dającą pełny
44 dostęp do formatu obrazów KEA, a także sterownik GDA pozwalający na
45 używanie obrazów KEA w programach obsługujących GDAL.
46
47 %package devel
48 Summary:        Header files for LibKEA library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LibKEA
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       hdf5-c++-devel
53 Requires:       libstdc++-devel
54
55 %description devel
56 Header files for LibKEA library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki LibKEA.
60
61 %package -n gdal-kea
62 Summary:        KEA plugin for GDAL library
63 Summary(pl.UTF-8):      Wtyczka KEA do biblioteki GDAL
64 Group:          Libraries
65 Requires:       %{name} = %{version}-%{release}
66 %if %{with gdal}
67 %requires_ge    gdal
68 %endif
69
70 %description -n gdal-kea
71 KEA plugin for GDAL library.
72
73 %description -n gdal-kea -l pl.UTF-8
74 Wtyczka KEA do biblioteki GDAL.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79
80 %build
81 %cmake . \
82 %if %{with gdal}
83         -DGDAL_INCLUDE_DIR=%{_includedir}/gdal \
84         -DGDAL_LIB_PATH=%{_libdir} \
85 %endif
86         -DHDF5_INCLUDE_DIR=%{_includedir} \
87         -DHDF5_LIB_PATH=%{_libdir}
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc README.md
105 %attr(755,root,root) %{_libdir}/libkea.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/libkea.so.1.4
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_bindir}/kea-config
111 %attr(755,root,root) %{_libdir}/libkea.so
112 %{_includedir}/libkea
113
114 %if %{with gdal}
115 %files -n gdal-kea
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/gdalplugins/gdal_KEA.so
118 %endif
This page took 0.072654 seconds and 2 git commands to generate.