]> git.pld-linux.org Git - packages/kdevelop.git/blob - kdevelop.spec
- updated gettext BR
[packages/kdevelop.git] / kdevelop.spec
1 # Conditional build:
2 %bcond_without  ada     # don't build with ada
3 #
4 %define         _state          stable
5 %define         _kdever         3.5.10
6 %define         _minbaseevr     9:%{_kdever}
7 %define         _minkdesdkevr   3:%{_kdever}
8
9 Summary:        KDE Integrated Development Environment
10 Summary(de.UTF-8):      KDevelop ist eine grafische Entwicklungsumgebung für KDE
11 Summary(pl.UTF-8):      Zintegrowane środowisko programisty dla KDE
12 Summary(pt_BR.UTF-8):   Ambiente Integrado de Desenvolvimento para o KDE
13 Summary(zh_CN.UTF-8):   KDE C/C++集成开发环境
14 Name:           kdevelop
15 Version:        3.5.4
16 Release:        1
17 Epoch:          7
18 License:        GPL
19 Group:          X11/Development/Tools
20 Source0:        ftp://ftp.kde.org/pub/kde/stable/%{_kdever}/src/%{name}-%{version}.tar.bz2
21 # Source0-md5:  06aa12a89b2c09968a92e1d8b575819c
22 Patch100:       %{name}-branch.diff
23 Patch0:         kde-common-PLD-nopython.patch
24 Patch1:         %{name}-am.patch
25 Patch2:         kde-ac260-lt.patch
26 Patch3:         %{name}-ncurses.patch
27 URL:            http://www.kdevelop.org/
28 # disabled, breaks with this new antlr
29 # BuildRequires:        antlr >= 2.7.3
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  db-devel
33 BuildRequires:  doxygen
34 BuildRequires:  flex
35 %{?with_ada:BuildRequires:gcc-ada}
36 BuildRequires:  gettext-tools
37 BuildRequires:  kdelibs-devel >= %{_minbaseevr}
38 BuildRequires:  kdesdk-libcvsservice-devel
39 BuildRequires:  libjpeg-devel
40 BuildRequires:  libpng-devel
41 BuildRequires:  libtool
42 BuildRequires:  openssl-devel >= 0.9.7d
43 BuildRequires:  pcre-devel
44 BuildRequires:  rpm-pythonprov
45 BuildRequires:  rpmbuild(macros) >= 1.129
46 BuildRequires:  subversion-devel >= 1.2.0-4
47 BuildRequires:  zlib-devel
48 BuildConflicts: star
49 Requires:       kdebase-core >= %{_minbaseevr}
50 Requires:       kdesdk-libcvsservice >= %{_minkdesdkevr}
51 Requires:       kdoc
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 The KDevelop Integrated Development Environment provides many features
56 that developers need as well as providing a unified interface to
57 programs like gdb, the C/C++ compiler, and make.
58
59 KDevelop manages or provides: all development tools needed for C++
60 programming like Compiler, Linker, automake and autoconf; KAppWizard,
61 which generates complete, ready-to-go sample applications;
62 Classgenerator, for creating new classes and integrating them into the
63 current project; File management for sources, headers, documentation
64 etc. to be included in the project; The creation of User-Handbooks
65 written with SGML and the automatic generation of HTML-output with the
66 KDE look and feel; Automatic HTML-based API-documentation for your
67 project's classes with cross-references to the used libraries;
68 Internationalization support for your application, allowing
69 translators to easily add their target language to a project;
70
71 KDevelop also includes WYSIWYG (What you see is what you get)-creation
72 of user interfaces with a built-in dialog editor; Debugging your
73 application by integrating KDbg; Editing of project-specific pixmaps
74 with KIconEdit; The inclusion of any other program you need for
75 development by adding it to the "Tools"-menu according to your
76 individual needs.
77
78 %description -l de.UTF-8
79 KDevelop ist eine grafische Entwicklungsumgebung für KDE.
80
81 Das KDevelop-Projekt wurde 1998 begonnen, um eine einfach zu
82 bedienende grafische (integrierte) Entwicklungsumgebung für C++ und C
83 auf Unix-basierten Betriebssystemen bereitzustellen. Seit damals ist
84 die KDevelop-IDE öffentlich unter der GPL erhältlich und unterstützt
85 u. a. Qt-, KDE-, GNOME-, C++- und C-Projekte.
86
87 %description -l pl.UTF-8
88 KDevelop to zintegrowane środowisko programistyczne dla KDE, dające
89 wiele możliwości przydatnych programistom oraz zunifikowany interfejs
90 do programów typu gdb, kompilator C/C++ oraz make.
91
92 KDevelop obsługuje lub zawiera: wszystkie narzędzia programistyczne
93 potrzebne do programowania w C++ jak kompilator, linker, automake,
94 autoconf; KAppWizard, generujący kompletne, gotowe do uruchomienia,
95 proste aplikacje; Classgenerator do tworzenia nowych klas i włączania
96 ich do projektu; zarządzanie plikami źródłowymi, nagłówkowymi,
97 dokumentacją itp.; tworzenie podręczników użytkownika pisanych w SGML
98 i automatyczne generowanie wyjścia HTML pasującego do KDE;
99 automatyczne tworzenie dokumentacji API w HTML do klas projektu z
100 odniesieniami do używanych bibliotek; wsparcie dla
101 internacjonalizacji, pozwalające tłumaczom łatwo dodawać pliki z
102 tłumaczeniami do projektu.
103
104 KDevelop ma także tworzenie interfejsów użytkownika przy użyciu
105 edytora dialogów WYSIWYG; odpluskwianie aplikacji poprzez integrację z
106 KDbg; edycję ikon przy pomocy KIconEdit; dołączanie innych programów
107 potrzebnych do programowania przez dodanie ich do menu Tools według
108 własnych potrzeb.
109
110 %prep
111 %setup -q
112 %patch100 -p0
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116 %patch3 -p1
117
118 %{__sed} -i -e 's/Terminal=0/Terminal=false/' \
119         -e 's/\(^Categories=.*$\)/\1;/' \
120         kdevelop.desktop
121
122 %build
123 cp -f /usr/share/automake/config.sub admin
124 %{__make} -f admin/Makefile.common cvs
125 %configure \
126         --disable-rpath \
127         --with-qt-libraries=%{_libdir} \
128         %{!?with_ada:--disable-ada} \
129         --disable-final \
130 %if "%{_lib}" == "lib64"
131         --enable-libsuffix=64 \
132 %endif
133         --with-apr-config=%{_bindir}/apr-1-config \
134         --with-apu-config=%{_bindir}/apu-1-config \
135         --with-svn-include=%{_includedir}/subversion-1 \
136         --with-svn-lib=%{_libdir} \
137         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full}
138
139 # disabled, breaks with new antlr
140 # %{?with_ada:%{__make} -C languages/ada genparser}
141
142 %{__make}
143
144 rm -f makeinstall.stamp
145
146 %install
147 if [ ! -f makeinstall.stamp -o ! -d $RPM_BUILD_ROOT ]; then
148         rm -rf makeinstall.stamp installed.stamp $RPM_BUILD_ROOT
149
150         %{__make} install \
151                 DESTDIR=$RPM_BUILD_ROOT \
152                 kde_libs_htmldir=%{_kdedocdir} \
153                 kde_htmldir=%{_kdedocdir}
154
155         touch makeinstall.stamp
156 fi
157
158 if [ ! -f installed.stamp ]; then
159         mv $RPM_BUILD_ROOT%{_iconsdir}/{lo,hi}color/16x16/actions/kdevelop_tip.png
160         mv $RPM_BUILD_ROOT%{_iconsdir}/{lo,hi}color/32x32/actions/kdevelop_tip.png
161
162         rm -f $RPM_BUILD_ROOT%{_libdir}/kde3/*.la
163         rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
164
165         touch installed.stamp
166 fi
167
168 %find_lang %{name} --with-kde --all-name
169
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post   -p /sbin/ldconfig
175 %postun -p /sbin/ldconfig
176
177 %files -f %{name}.lang
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_bindir}/kdevassistant
180 %attr(755,root,root) %{_bindir}/kdevdesigner
181 %attr(755,root,root) %{_bindir}/kdevelop
182 %attr(755,root,root) %{_bindir}/kdevelop-htdig
183 %attr(755,root,root) %{_bindir}/kdevprj2kdevelop
184 %attr(755,root,root) %{_bindir}/kdevprofileeditor
185 %attr(755,root,root) %{_libdir}/*.so
186 %attr(755,root,root) %{_libdir}/*.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libd.so.0
188 %attr(755,root,root) %ghost %{_libdir}/libdesignerintegration.so.0
189 %attr(755,root,root) %ghost %{_libdir}/libdocumentation_interfaces.so.0
190 %attr(755,root,root) %ghost %{_libdir}/libgdbmi_parser.so.0
191 %attr(755,root,root) %ghost %{_libdir}/libkdevbuildbase.so.0
192 %attr(755,root,root) %ghost %{_libdir}/libkdevbuildtoolswidgets.so.0
193 %attr(755,root,root) %ghost %{_libdir}/libkdevcatalog.so.0
194 %attr(755,root,root) %ghost %{_libdir}/libkdevcppparser.so.0
195 %attr(755,root,root) %ghost %{_libdir}/libkdevelop.so.1
196 %attr(755,root,root) %ghost %{_libdir}/libkdevextras.so.0
197 %attr(755,root,root) %ghost %{_libdir}/libkdevpropertyeditor.so.0
198 %attr(755,root,root) %ghost %{_libdir}/libkdevqmakeparser.so.0
199 %attr(755,root,root) %ghost %{_libdir}/libkdevshell.so.0
200 %attr(755,root,root) %ghost %{_libdir}/libkdevwidgets.so.0
201 %attr(755,root,root) %ghost %{_libdir}/libkinterfacedesigner.so.0
202 %attr(755,root,root) %ghost %{_libdir}/liblang_debugger.so.0
203 %attr(755,root,root) %ghost %{_libdir}/liblang_interfaces.so.0
204 %attr(755,root,root) %ghost %{_libdir}/libprofileengine.so.0
205 %attr(755,root,root) %{_libdir}/kde3/*.so
206 %attr(755,root,root) %{_libdir}/kconf_update_bin/kdev-gen-settings-kconf_update
207 %{_datadir}/apps/kconf_update/kdev-gen-settings.upd
208 %{_datadir}/apps/kdevabbrev
209 %if %{with ada}
210 %{_datadir}/apps/kdevadaproject
211 %{_datadir}/apps/kdevadasupport
212 %endif
213 %{_datadir}/apps/kdevantproject
214 %{_datadir}/apps/kdevappoutputview
215 %{_datadir}/apps/kdevappwizard
216 %{_datadir}/apps/kdevassistant
217 %{_datadir}/apps/kdevastyle
218 %{_datadir}/apps/kdevautoproject
219 %{_datadir}/apps/kdevbashsupport
220 %{_datadir}/apps/kdevclassview
221 %{_datadir}/apps/kdevcppsupport
222 %{_datadir}/apps/kdevcsharpsupport
223 %{_datadir}/apps/kdevctags2
224 %{_datadir}/apps/kdevcustomproject
225 %{_datadir}/apps/kdevcvsservice
226 %{_datadir}/apps/kdevdebugger
227 %{_datadir}/apps/kdevdesigner
228 %{_datadir}/apps/kdevdesignerpart
229 %{_datadir}/apps/kdevdiff
230 %{_datadir}/apps/kdevdistpart
231 %{_datadir}/apps/kdevdocumentation
232 %{_datadir}/apps/kdevdoxygen
233 %{_datadir}/apps/kdevelop
234 %{_datadir}/apps/kdevfilecreate
235 %{_datadir}/apps/kdevfilelist
236 %{_datadir}/apps/kdevfilter
237 %{_datadir}/apps/kdevfortransupport
238 %{_datadir}/apps/kdevfullscreen
239 %{_datadir}/apps/kdevgrepview
240 %{_datadir}/apps/kdevjavasupport
241 %{_datadir}/apps/kdevmakeview
242 %{_datadir}/apps/kdevpartexplorer
243 %{_datadir}/apps/kdevpascalproject
244 %{_datadir}/apps/kdevpascalsupport
245 %{_datadir}/apps/kdevperlsupport
246 %{_datadir}/apps/kdevphpsupport
247 %{_datadir}/apps/kdevpythonsupport
248 %{_datadir}/apps/kdevquickopen
249 %{_datadir}/apps/kdevrbdebugger
250 %{_datadir}/apps/kdevregexptest
251 %{_datadir}/apps/kdevreplace
252 %{_datadir}/apps/kdevrubysupport
253 %{_datadir}/apps/kdevscripting
254 %{_datadir}/apps/kdevscriptproject
255 %{_datadir}/apps/kdevsnippet
256 %{_datadir}/apps/kdevsqlsupport
257 %{_datadir}/apps/kdevtipofday
258 %{_datadir}/apps/kdevtools
259 %{_datadir}/apps/kdevtrollproject
260 %{_datadir}/apps/kdevvalgrind
261 %{_datadir}/apps/kio_pydoc
262 %{_datadir}/config/kdevassistantrc
263 %{_datadir}/config/kdeveloprc
264 %{_datadir}/desktop-directories/kde-development-kdevelop.directory
265 %{_datadir}/mimelnk/application/x-kdevelop.desktop
266 %{_datadir}/mimelnk/text/x-fortran.desktop
267 %{_datadir}/services/*.desktop
268 %{_datadir}/services/*.protocol
269 %{_datadir}/services/kded/kdevsvnd.desktop
270 %{_datadir}/servicetypes/*.desktop
271 %{_desktopdir}/kde/*.desktop
272 %{_iconsdir}/hicolor/*/actions/breakpoint_add.png
273 %{_iconsdir}/hicolor/*/actions/breakpoint_delete.png
274 %{_iconsdir}/hicolor/*/actions/breakpoint_delete_all.png
275 %{_iconsdir}/hicolor/*/actions/breakpoint_edit.png
276 %{_iconsdir}/hicolor/*/actions/kdevelop_tip.png
277 %{_iconsdir}/hicolor/*/actions/ktip.png
278 %{_iconsdir}/hicolor/*/apps/kdevassistant.png
279 %{_iconsdir}/hicolor/*/apps/kdevdesigner.png
280 %{_iconsdir}/hicolor/*/apps/kdevelop.png
281
282 %{_includedir}/kdevelop
283 %{_includedir}/kinterfacedesigner
This page took 0.987963 seconds and 3 git commands to generate.