]> git.pld-linux.org Git - packages/kdenlive.git/blob - kdenlive.spec
- updated BRs
[packages/kdenlive.git] / kdenlive.spec
1 %define         kdeappsver      19.04.0
2 %define         qtver           5.9.0
3 %define         kaname          kdenlive
4 Summary:        KDE movie editor
5 Summary(pl.UTF-8):      Edytor filmów dla KDE
6 Name:           kdenlive
7 Version:        19.04.0
8 Release:        1
9 License:        GPL
10 Group:          X11/Applications/Multimedia
11 Source0:        http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
12 # Source0-md5:  1386b04b1aef5832ae21525aaf4fc8b7
13 Patch0:         c11.patch
14 Patch1:         qt-5.15.patch
15 URL:            http://kdenlive.org/
16 BuildRequires:  Qt5Concurrent-devel
17 BuildRequires:  Qt5Core-devel
18 BuildRequires:  Qt5DBus-devel
19 BuildRequires:  Qt5Gui-devel
20 BuildRequires:  Qt5Network-devel
21 BuildRequires:  Qt5Qml-devel
22 BuildRequires:  Qt5Quick-devel
23 BuildRequires:  Qt5Script-devel
24 BuildRequires:  Qt5Svg-devel
25 BuildRequires:  Qt5WebKit-devel
26 BuildRequires:  Qt5Widgets-devel
27 BuildRequires:  cmake
28 BuildRequires:  gettext-tools
29 BuildRequires:  kf5-attica-devel
30 BuildRequires:  kf5-karchive-devel
31 BuildRequires:  kf5-kbookmarks-devel
32 BuildRequires:  kf5-kconfig-devel
33 BuildRequires:  kf5-kconfigwidgets-devel
34 BuildRequires:  kf5-kcoreaddons-devel
35 BuildRequires:  kf5-kcrash-devel
36 BuildRequires:  kf5-kdbusaddons-devel
37 BuildRequires:  kf5-kdeclarative-devel
38 BuildRequires:  kf5-kdoctools-devel
39 BuildRequires:  kf5-kfilemetadata-devel
40 BuildRequires:  kf5-kguiaddons-devel
41 BuildRequires:  kf5-ki18n-devel
42 BuildRequires:  kf5-kiconthemes-devel
43 BuildRequires:  kf5-kio-devel
44 BuildRequires:  kf5-knewstuff-devel
45 BuildRequires:  kf5-knotifications-devel
46 BuildRequires:  kf5-knotifyconfig-devel
47 BuildRequires:  kf5-kplotting-devel
48 BuildRequires:  kf5-ktextwidgets-devel
49 BuildRequires:  kf5-kwidgetsaddons-devel
50 BuildRequires:  kf5-kxmlgui-devel
51 BuildRequires:  kf5-sonnet-devel
52 BuildRequires:  libv4l-devel
53 BuildRequires:  mlt-devel >= 6.12.0
54 BuildRequires:  ninja
55 BuildRequires:  pkgconfig
56 BuildRequires:  qjson-devel >= 0.5
57 BuildRequires:  rpmbuild(macros) >= 1.129
58 BuildRequires:  shared-desktop-ontologies-devel
59 BuildRequires:  soprano-devel
60 Requires:       Qt5Gui-platform-xcb-egl
61 Requires:       Qt5Gui-platform-xcb-glx
62 Requires:       Qt5Quick-controls
63 Suggests:       dvdauthor
64 Suggests:       dvgrab
65 Suggests:       ffmpeg-ffplay
66 Suggests:       frei0r-plugins
67 Suggests:       mlt >= 6.0.0
68 Suggests:       recordmydesktop
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 Kdenlive is a non-linear video editor for KDE. It provides all project
73 management and editing tools while relying on a separate rendering
74 program (currently PIAVE) to perform the editing operations. Support
75 is planned for transitions, effects, multiple file formats, and full
76 project and asset management support. The current beta is capable of
77 editing raw DV or AVI DV files, with tools such as move, razor, and
78 resize, selecting parts of clips using in/outpoints, and exporting the
79 result to another raw DV file. You may playback/preview the contents
80 of the timeline at any point during the edit. Full project save/load
81 is supported.
82
83 %description -l pl.UTF-8
84 Kdenlive to nieliniowy edytor filmów dla KDE. Dostarcza narzędzia do
85 zarządzania projektem i edycji polegające na oddzielnym programie
86 renderującym (aktualnie PIAVE) do wykonywania operacji edycji.
87 Planowana jest obsługa przejść, efektów, wielu formatów plików oraz
88 pełnego zarządzania projektem i kapitałem. Aktualna wersja beta może
89 modyfikować pliki w formacie surowego DV oraz AVI DV przy użyciu
90 narzędzi takich jak przemieszczanie, cięcia, zmiana rozmiaru,
91 wybieranie części klatek przy użyciu punktów wejściowych/wyjściowych
92 oraz eksportowanie wyniku do innego pliku w formacie surowego DV.
93 Można odtwarzać/podglądać zawartość w dowolnej chwili edycji.
94 Obsługiwany jest zapis/odczyt pełnego projektu.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100
101 %build
102 mkdir -p build
103 cd build
104 %cmake .. \
105         -G Ninja \
106         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
107         -DPLUGIN_INSTALL_DIR=%{_libdir}/qt5/plugins
108
109 %ninja_build
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %ninja_install -C build
115
116 %find_lang %{kaname} --all-name --with-kde
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files -f %{kaname}.lang
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_bindir}/%{name}*
124 %attr(755,root,root) %{_libdir}/qt5/plugins/mltpreview.so
125 %{_datadir}/metainfo/org.kde.kdenlive.appdata.xml
126 %{_datadir}/config.kcfg/kdenlivesettings.kcfg
127 %{_datadir}/knotifications5/kdenlive.notifyrc
128 %{_datadir}/kservices5/mltpreview.desktop
129 %dir %{_datadir}/kxmlgui5/kdenlive
130 %{_datadir}/kxmlgui5/kdenlive/kdenliveui.rc
131 %{_datadir}/mime/packages/*.xml
132 %{_datadir}/%{name}
133 %{_desktopdir}/org.kde.kdenlive.desktop
134 %{_docdir}/HTML/en/kdenlive
135 /etc/xdg/%{name}*.knsrc
136 /etc/xdg/kdenlive.categories
137 %{_iconsdir}/*/*/*/*.png
138 %{_iconsdir}/*/*/*/*.svg
139 %{_iconsdir}/*/*/*/*.svgz
140 %{_mandir}/man1/kdenlive*
This page took 0.074375 seconds and 3 git commands to generate.