]> git.pld-linux.org Git - packages/kdenlive.git/blob - kdenlive.spec
c4456f74a3eaaf6a9368c01c28142ec64b788211
[packages/kdenlive.git] / kdenlive.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.12.2
5 %define         qtver           5.15.2
6 %define         kaname          kdenlive
7 Summary:        KDE movie editor
8 Summary(pl.UTF-8):      Edytor filmów dla KDE
9 Name:           kdenlive
10 Version:        22.12.2
11 Release:        1
12 License:        GPL
13 Group:          X11/Applications/Multimedia
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  a5707d892c5f95b01654659fbcd9ff15
16 URL:            http://kdenlive.org/
17 BuildRequires:  Qt5Concurrent-devel
18 BuildRequires:  Qt5Core-devel
19 BuildRequires:  Qt5DBus-devel
20 BuildRequires:  Qt5Gui-devel
21 BuildRequires:  Qt5Multimedia-devel
22 BuildRequires:  Qt5Network-devel
23 BuildRequires:  Qt5NetworkAuth-devel
24 BuildRequires:  Qt5Qml-devel
25 BuildRequires:  Qt5Quick-controls2-devel
26 BuildRequires:  Qt5Quick-devel
27 BuildRequires:  Qt5Script-devel
28 BuildRequires:  Qt5Svg-devel
29 BuildRequires:  Qt5WebKit-devel
30 BuildRequires:  Qt5Widgets-devel
31 BuildRequires:  cmake
32 BuildRequires:  gettext-tools
33 BuildRequires:  kf5-attica-devel
34 BuildRequires:  kf5-karchive-devel
35 BuildRequires:  kf5-kbookmarks-devel
36 BuildRequires:  kf5-kconfig-devel
37 BuildRequires:  kf5-kconfigwidgets-devel
38 BuildRequires:  kf5-kcoreaddons-devel
39 BuildRequires:  kf5-kcrash-devel
40 BuildRequires:  kf5-kdbusaddons-devel
41 BuildRequires:  kf5-kdeclarative-devel
42 BuildRequires:  kf5-kdesignerplugin-devel
43 BuildRequires:  kf5-kdoctools-devel
44 BuildRequires:  kf5-kfilemetadata-devel
45 BuildRequires:  kf5-kguiaddons-devel
46 BuildRequires:  kf5-ki18n-devel
47 BuildRequires:  kf5-kiconthemes-devel
48 BuildRequires:  kf5-kio-devel
49 BuildRequires:  kf5-knewstuff-devel
50 BuildRequires:  kf5-knotifications-devel
51 BuildRequires:  kf5-knotifyconfig-devel
52 BuildRequires:  kf5-kplotting-devel
53 BuildRequires:  kf5-ktextwidgets-devel
54 BuildRequires:  kf5-kwidgetsaddons-devel
55 BuildRequires:  kf5-kxmlgui-devel
56 BuildRequires:  kf5-purpose-devel
57 BuildRequires:  kf5-sonnet-devel
58 BuildRequires:  libv4l-devel
59 BuildRequires:  mlt-devel >= 7.12.0
60 BuildRequires:  ninja
61 BuildRequires:  pkgconfig
62 BuildRequires:  qjson-devel >= 0.5
63 BuildRequires:  rpmbuild(macros) >= 1.129
64 BuildRequires:  rttr-devel
65 BuildRequires:  shared-desktop-ontologies-devel
66 BuildRequires:  soprano-devel
67 BuildConflicts: gstreamer0.10
68 Requires:       %{name}-data = %{version}-%{release}
69 Requires:       Qt5Gui-platform-xcb-egl
70 Requires:       Qt5Gui-platform-xcb-glx
71 Requires:       Qt5Quick-controls
72 Suggests:       dvdauthor
73 Suggests:       dvgrab
74 Suggests:       ffmpeg-ffplay
75 Suggests:       frei0r-plugins
76 Suggests:       mlt >= 7.12.0
77 Suggests:       recordmydesktop
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 Kdenlive is a non-linear video editor for KDE. It provides all project
82 management and editing tools while relying on a separate rendering
83 program (currently PIAVE) to perform the editing operations. Support
84 is planned for transitions, effects, multiple file formats, and full
85 project and asset management support. The current beta is capable of
86 editing raw DV or AVI DV files, with tools such as move, razor, and
87 resize, selecting parts of clips using in/outpoints, and exporting the
88 result to another raw DV file. You may playback/preview the contents
89 of the timeline at any point during the edit. Full project save/load
90 is supported.
91
92 %description -l pl.UTF-8
93 Kdenlive to nieliniowy edytor filmów dla KDE. Dostarcza narzędzia do
94 zarządzania projektem i edycji polegające na oddzielnym programie
95 renderującym (aktualnie PIAVE) do wykonywania operacji edycji.
96 Planowana jest obsługa przejść, efektów, wielu formatów plików
97 oraz pełnego zarządzania projektem i kapitałem. Aktualna wersja
98 beta może modyfikować pliki w formacie surowego DV oraz AVI DV przy
99 użyciu narzędzi takich jak przemieszczanie, cięcia, zmiana
100 rozmiaru, wybieranie części klatek przy użyciu punktów
101 wejściowych/wyjściowych oraz eksportowanie wyniku do innego pliku w
102 formacie surowego DV. Można odtwarzać/podglądać zawartość w
103 dowolnej chwili edycji. Obsługiwany jest zapis/odczyt pełnego
104 projektu.
105
106 %package data
107 Summary:        Data files for %{kaname}
108 Summary(pl.UTF-8):      Dane dla %{kaname}
109 Group:          X11/Applications/Multimedia
110 BuildArch:      noarch
111
112 %description data
113 Data files for %{kaname}.
114
115 %description data -l pl.UTF-8
116 Dane dla %{kaname}.
117
118 %prep
119 %setup -q
120
121 %build
122 mkdir -p build
123 cd build
124 %cmake .. \
125         -G Ninja \
126         %{!?with_tests:-DBUILD_TESTING=OFF} \
127         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
128         -DHTML_INSTALL_DIR=%{_kdedocdir} \
129         -DPLUGIN_INSTALL_DIR=%{_libdir}/qt5/plugins
130
131 %ninja_build
132
133 %if %{with tests}
134 ctest
135 %endif
136
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %ninja_install -C build
142
143 %find_lang %{kaname} --all-name --with-kde
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %files
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_bindir}/%{name}*
151 %{_libdir}/qt5/plugins/mltpreview.so
152
153 %files data  -f %{kaname}.lang
154 %defattr(644,root,root,755)
155 %{_datadir}/metainfo/org.kde.kdenlive.appdata.xml
156 %{_datadir}/config.kcfg/kdenlivesettings.kcfg
157 %{_datadir}/knotifications5/kdenlive.notifyrc
158 %{_datadir}/kservices5/mltpreview.desktop
159 %dir %{_datadir}/kxmlgui5/kdenlive
160 %{_datadir}/kxmlgui5/kdenlive/kdenliveui.rc
161 %{_datadir}/mime/packages/*.xml
162 %{_datadir}/%{name}
163 %{_desktopdir}/org.kde.kdenlive.desktop
164 %{_iconsdir}/*/*/*/*.png
165 %{_iconsdir}/*/*/*/*.svg
166 %{_iconsdir}/*/*/*/*.svgz
167 %{_mandir}/man1/kdenlive*
168 %{_datadir}/knsrcfiles/*.knsrc
169 %{_datadir}/qlogging-categories5/kdenlive.categories
This page took 0.040681 seconds and 2 git commands to generate.