]> git.pld-linux.org Git - packages/kdenlive.git/blob - kdenlive.spec
- updated to 22.04.0
[packages/kdenlive.git] / kdenlive.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.04.0
5 %define         qtver           5.9.0
6 %define         kaname          kdenlive
7 Summary:        KDE movie editor
8 Summary(pl.UTF-8):      Edytor filmów dla KDE
9 Name:           kdenlive
10 Version:        22.04.0
11 Release:        1
12 License:        GPL
13 Group:          X11/Applications/Multimedia
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  fa390ede040ccaf338400bcb18fa61fe
16 URL:            http://kdenlive.org/
17 BuildConflicts: gstreamer0.10
18 BuildRequires:  Qt5Concurrent-devel
19 BuildRequires:  Qt5Core-devel
20 BuildRequires:  Qt5DBus-devel
21 BuildRequires:  Qt5Gui-devel
22 BuildRequires:  Qt5Multimedia-devel
23 BuildRequires:  Qt5Network-devel
24 BuildRequires:  Qt5NetworkAuth-devel
25 BuildRequires:  Qt5Qml-devel
26 BuildRequires:  Qt5Quick-devel
27 BuildRequires:  Qt5Script-devel
28 BuildRequires:  Qt5Svg-devel
29 BuildRequires:  Qt5WebKit-devel
30 BuildRequires:  Qt5Widgets-devel
31 BuildRequires:  cmake
32 BuildRequires:  gettext-tools
33 BuildRequires:  kf5-attica-devel
34 BuildRequires:  kf5-karchive-devel
35 BuildRequires:  kf5-kbookmarks-devel
36 BuildRequires:  kf5-kconfig-devel
37 BuildRequires:  kf5-kconfigwidgets-devel
38 BuildRequires:  kf5-kcoreaddons-devel
39 BuildRequires:  kf5-kcrash-devel
40 BuildRequires:  kf5-kdbusaddons-devel
41 BuildRequires:  kf5-kdeclarative-devel
42 BuildRequires:  kf5-kdoctools-devel
43 BuildRequires:  kf5-kfilemetadata-devel
44 BuildRequires:  kf5-kguiaddons-devel
45 BuildRequires:  kf5-ki18n-devel
46 BuildRequires:  kf5-kiconthemes-devel
47 BuildRequires:  kf5-kio-devel
48 BuildRequires:  kf5-knewstuff-devel
49 BuildRequires:  kf5-knotifications-devel
50 BuildRequires:  kf5-knotifyconfig-devel
51 BuildRequires:  kf5-kplotting-devel
52 BuildRequires:  kf5-ktextwidgets-devel
53 BuildRequires:  kf5-kwidgetsaddons-devel
54 BuildRequires:  kf5-kxmlgui-devel
55 BuildRequires:  kf5-purpose-devel
56 BuildRequires:  kf5-sonnet-devel
57 BuildRequires:  libv4l-devel
58 BuildRequires:  mlt-devel >= 7.0
59 BuildRequires:  ninja
60 BuildRequires:  pkgconfig
61 BuildRequires:  qjson-devel >= 0.5
62 BuildRequires:  rpmbuild(macros) >= 1.129
63 BuildRequires:  rttr-devel
64 BuildRequires:  shared-desktop-ontologies-devel
65 BuildRequires:  soprano-devel
66 Requires:       Qt5Gui-platform-xcb-egl
67 Requires:       Qt5Gui-platform-xcb-glx
68 Requires:       Qt5Quick-controls
69 Suggests:       dvdauthor
70 Suggests:       dvgrab
71 Suggests:       ffmpeg-ffplay
72 Suggests:       frei0r-plugins
73 Suggests:       mlt >= 6.0.0
74 Suggests:       recordmydesktop
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %description
78 Kdenlive is a non-linear video editor for KDE. It provides all project
79 management and editing tools while relying on a separate rendering
80 program (currently PIAVE) to perform the editing operations. Support
81 is planned for transitions, effects, multiple file formats, and full
82 project and asset management support. The current beta is capable of
83 editing raw DV or AVI DV files, with tools such as move, razor, and
84 resize, selecting parts of clips using in/outpoints, and exporting the
85 result to another raw DV file. You may playback/preview the contents
86 of the timeline at any point during the edit. Full project save/load
87 is supported.
88
89 %description -l pl.UTF-8
90 Kdenlive to nieliniowy edytor filmów dla KDE. Dostarcza narzędzia do
91 zarządzania projektem i edycji polegające na oddzielnym programie
92 renderującym (aktualnie PIAVE) do wykonywania operacji edycji.
93 Planowana jest obsługa przejść, efektów, wielu formatów plików oraz
94 pełnego zarządzania projektem i kapitałem. Aktualna wersja beta może
95 modyfikować pliki w formacie surowego DV oraz AVI DV przy użyciu
96 narzędzi takich jak przemieszczanie, cięcia, zmiana rozmiaru,
97 wybieranie części klatek przy użyciu punktów wejściowych/wyjściowych
98 oraz eksportowanie wyniku do innego pliku w formacie surowego DV.
99 Można odtwarzać/podglądać zawartość w dowolnej chwili edycji.
100 Obsługiwany jest zapis/odczyt pełnego projektu.
101
102 %prep
103 %setup -q
104
105 %build
106 mkdir -p build
107 cd build
108 %cmake .. \
109         -G Ninja \
110         %{!?with_tests:-DBUILD_TESTING=OFF} \
111         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
112         -DHTML_INSTALL_DIR=%{_kdedocdir} \
113         -DPLUGIN_INSTALL_DIR=%{_libdir}/qt5/plugins
114
115 %ninja_build
116
117 %if %{with tests}
118 ctest
119 %endif
120
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %ninja_install -C build
126
127 %find_lang %{kaname} --all-name --with-kde
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files -f %{kaname}.lang
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/%{name}*
135 %attr(755,root,root) %{_libdir}/qt5/plugins/mltpreview.so
136 %{_datadir}/metainfo/org.kde.kdenlive.appdata.xml
137 %{_datadir}/config.kcfg/kdenlivesettings.kcfg
138 %{_datadir}/knotifications5/kdenlive.notifyrc
139 %{_datadir}/kservices5/mltpreview.desktop
140 %dir %{_datadir}/kxmlgui5/kdenlive
141 %{_datadir}/kxmlgui5/kdenlive/kdenliveui.rc
142 %{_datadir}/mime/packages/*.xml
143 %{_datadir}/%{name}
144 %{_desktopdir}/org.kde.kdenlive.desktop
145 %{_iconsdir}/*/*/*/*.png
146 %{_iconsdir}/*/*/*/*.svg
147 %{_iconsdir}/*/*/*/*.svgz
148 %{_mandir}/man1/kdenlive*
149 %{_datadir}/knsrcfiles/*.knsrc
150 %{_datadir}/qlogging-categories5/kdenlive.categories
This page took 0.082127 seconds and 3 git commands to generate.