]> git.pld-linux.org Git - packages/kde4-kwebkitpart.git/blob - kde4-kwebkitpart.spec
5c9eaf95acec7df749840b3d3f1e448579971417
[packages/kde4-kwebkitpart.git] / kde4-kwebkitpart.spec
1
2 %define         qtver           4.8.4
3 %define         kdever          4.10.2
4 %define         snap            20130415
5 %define         orgname         kwebkitpart
6
7 %define         rel     1
8 Summary:        kde4-kwebkitpart - QWebkit plugin
9 Name:           kde4-kwebkitpart
10 Version:        %{kdever}
11 Release:        0.%{snap}.%{rel}
12 License:        GPL v2
13 Group:          X11/Libraries
14 # git clone git://anongit.kde.org/kwebkitpart
15 Source0:        %{orgname}-%{snap}.tar.bz2
16 # Source0-md5:  b0c8afbeaf30937b551ef8598b316af5
17 BuildRequires:  QtCore-devel >= %{qtver}
18 BuildRequires:  QtSvg-devel >= %{qtver}
19 BuildRequires:  QtUiTools-devel >= %{qtver}
20 BuildRequires:  QtWebKit-devel >= %{qtver}
21 BuildRequires:  automoc4
22 BuildRequires:  cmake >= 2.8.0
23 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
24 BuildRequires:  qt4-build >= %{qtver}
25 BuildRequires:  qt4-qmake >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.600
27 Obsoletes:      webkitkde
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 KDE part library to use QtWebkit instread of KHTML. It works as plugin
32 for Konqueror.
33
34 %prep
35 %setup -q -n %{orgname}-%{snap}
36
37 %build
38 install -d build
39 cd build
40 %cmake \
41         ../
42
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} -C build install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post   -p /sbin/ldconfig
55 %postun -p /sbin/ldconfig
56
57 %files
58 %defattr(644,root,root,755)
59 %attr(755,root,root) %{_libdir}/kde4/kwebkitpart.so
60 %{_iconsdir}/hicolor/*x*/apps/webkit.png
61 %{_datadir}/kde4/services/kwebkitpart.desktop
62 %{_datadir}/apps/kwebkitpart
This page took 0.046606 seconds and 2 git commands to generate.