]> git.pld-linux.org Git - packages/kde4-kwebkitpart.git/blob - kde4-kwebkitpart.spec
- Added URL.
[packages/kde4-kwebkitpart.git] / kde4-kwebkitpart.spec
1
2 %define         qtver           4.8.4
3 %define         kdever          4.10.2
4 %define         snap            20130415
5 %define         orgname         kwebkitpart
6
7 %define         rel     1
8 Summary:        kde4-kwebkitpart - QWebkit plugin
9 Name:           kde4-kwebkitpart
10 Version:        %{kdever}
11 Release:        0.%{snap}.%{rel}
12 License:        GPL v2
13 Group:          X11/Libraries
14 # git clone git://anongit.kde.org/kwebkitpart
15 Source0:        %{orgname}-%{snap}.tar.bz2
16 # Source0-md5:  b0c8afbeaf30937b551ef8598b316af5
17 URL:            https://projects.kde.org/projects/extragear/base/kwebkitpart
18 BuildRequires:  QtCore-devel >= %{qtver}
19 BuildRequires:  QtSvg-devel >= %{qtver}
20 BuildRequires:  QtUiTools-devel >= %{qtver}
21 BuildRequires:  QtWebKit-devel >= %{qtver}
22 BuildRequires:  automoc4
23 BuildRequires:  cmake >= 2.8.0
24 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
25 BuildRequires:  qt4-build >= %{qtver}
26 BuildRequires:  qt4-qmake >= %{qtver}
27 BuildRequires:  rpmbuild(macros) >= 1.600
28 Obsoletes:      webkitkde
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 KDE part library to use QtWebkit instread of KHTML. It works as plugin
33 for Konqueror.
34
35 %prep
36 %setup -q -n %{orgname}-%{snap}
37
38 %build
39 install -d build
40 cd build
41 %cmake \
42         ../
43
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} -C build install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post   -p /sbin/ldconfig
56 %postun -p /sbin/ldconfig
57
58 %files
59 %defattr(644,root,root,755)
60 %attr(755,root,root) %{_libdir}/kde4/kwebkitpart.so
61 %{_iconsdir}/hicolor/*x*/apps/webkit.png
62 %{_datadir}/kde4/services/kwebkitpart.desktop
63 %{_datadir}/apps/kwebkitpart
This page took 0.07223 seconds and 3 git commands to generate.