]> git.pld-linux.org Git - packages/kde4-kremotecontrol.git/blob - kde4-kremotecontrol.spec
- 4.10.0
[packages/kde4-kremotecontrol.git] / kde4-kremotecontrol.spec
1 #
2 %define         _state          stable
3 %define         orgname         kremotecontrol
4 %define         qtver           4.8.0
5
6 Summary:        K Desktop Environment - Infrared Remote Control
7 Name:           kde4-kremotecontrol
8 Version:        4.10.0
9 Release:        1
10 License:        GPL
11 Group:          X11/Applications
12 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
13 # Source0-md5:  613e3b416fcf2601c4b4b24d5dc545b6
14 URL:            http://www.kde.org/
15 BuildRequires:  QtXmlPatterns-devel
16 BuildRequires:  automoc4 >= 0.9.88
17 BuildRequires:  cmake >= 2.8.0
18 BuildRequires:  docbook-dtd42-xml
19 BuildRequires:  docbook-style-xsl
20 BuildRequires:  kde4-kdebase-devel >= %{version}
21 BuildRequires:  qt4-build >= %{qtver}
22 BuildRequires:  qt4-qmake >= %{qtver}
23 BuildRequires:  xorg-lib-libXtst-devel
24 Obsoletes:      kde4-kdeutils-irkick
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 KRemoteControl is a KDE frontend for your remote controls. It allows
29 to configure actions for button presses on remotes. All types of
30 remotes supported by Solid are also supported by KRemoteControl.
31
32 %prep
33 %setup -q -n %{orgname}-%{version}
34
35 %build
36 install -d build
37 cd build
38 %cmake \
39         ..
40 %{__make}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} -C build/ install \
46         DESTDIR=$RPM_BUILD_ROOT \
47         kde_htmldir=%{_kdedocdir}
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %attr(755,root,root) %{_bindir}/krcdnotifieritem
55 %attr(755,root,root) %{_libdir}/kde4/kcm_remotecontrol.so
56 %attr(755,root,root) %{_libdir}/kde4/kded_kremotecontroldaemon.so
57 %attr(755,root,root) %{_libdir}/kde4/kremotecontrol_lirc.so
58 %attr(755,root,root) %{_libdir}/kde4/plasma_engine_kremoteconrol.so
59 %attr(755,root,root) %{_libdir}/liblibkremotecontrol.so.*.*.*
60 %attr(755,root,root) %ghost %{_libdir}/liblibkremotecontrol.so.?
61 %{_datadir}/apps/kremotecontrol
62 %{_datadir}/apps/kremotecontroldaemon
63 %{_datadir}/kde4/services/kcm_remotecontrol.desktop
64 %{_datadir}/kde4/services/kded/kremotecontroldaemon.desktop
65 %{_datadir}/kde4/services/kremotecontrolbackends
66 %{_datadir}/kde4/services/plasma-engine-kremotecontrol.desktop
67 %{_datadir}/kde4/servicetypes/kremotecontrolmanager.desktop
68 %{_desktopdir}/kde4/krcdnotifieritem.desktop
69 %{_iconsdir}/hicolor/*x*/actions/krcd_flash.png
70 %{_iconsdir}/hicolor/*x*/actions/krcd_off.png
71 %{_iconsdir}/hicolor/*x*/apps/krcd.png
72 %{_iconsdir}/hicolor/*x*/devices/infrared-remote.png
73 %{_kdedocdir}/en/kcontrol
This page took 0.078613 seconds and 3 git commands to generate.