]> git.pld-linux.org Git - packages/kde4-kopete.git/blob - kde4-kopete.spec
- handle NPAPI skypebuttons plugin (disable by default, package if enabled)
[packages/kde4-kopete.git] / kde4-kopete.spec
1 #
2 # Conditional build:
3 %bcond_with     npapi   # NPAPI browser plugin (skypebuttons)
4
5 %define         _state          stable
6 %define         orgname         kopete
7 %define         qt_ver          4.8.3
8
9 Summary:        Multi-protocol plugin-based instant messenger
10 Summary(pl.UTF-8):      Komunikator obsługujący wiele protokołów
11 Name:           kde4-kopete
12 Version:        4.14.3
13 Release:        12
14 License:        GPL v2+ with OpenSSL exception (kopete), LGPL v2+ (libkopete)
15 Group:          X11/Applications
16 Source0:        http://download.kde.org/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
17 # Source0-md5:  d05e478101292ebb08da2af00d1329ab
18 Patch0:         %{name}-FindLibgadu.patch
19 Patch2:         mediastreamer.patch
20 Patch3:         gcc6.patch
21 Patch4:         macros.patch
22 Patch5:         %{name}-qt.patch
23 URL:            http://www.kde.org/
24 BuildRequires:  automoc4
25 BuildRequires:  cmake >= 2.8.0
26 BuildRequires:  kde4-kdebase-devel >= %{version}
27 BuildRequires:  kde4-kdepim-devel >= 4.14.0-2
28 BuildRequires:  kde4-kdepimlibs-devel >= 4.14.0-2
29 BuildRequires:  jsoncpp-devel
30 BuildRequires:  libgadu-devel >= 1.8.0
31 BuildRequires:  libktorrent-devel >= 1.0.2
32 BuildRequires:  libmms-devel
33 BuildRequires:  libmsn-devel >= 4.1
34 BuildRequires:  libotr-devel >= 4.0.0
35 BuildRequires:  meanwhile-devel
36 BuildRequires:  mediastreamer-devel >= 2.3.0
37 BuildRequires:  openssl-devel >= 0.9.7d
38 BuildRequires:  ortp-devel >= 0.16.1-3
39 BuildRequires:  qca-devel >= 2.0.0
40 BuildRequires:  qimageblitz-devel
41 BuildRequires:  qt4-build >= %{qt_ver}
42 BuildRequires:  qt4-qmake >= %{qt_ver}
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  rpmbuild(macros) >= 1.600
45 BuildRequires:  speex-devel
46 BuildRequires:  telepathy-qt4-devel >= 0.9.0
47 BuildRequires:  xmms-devel
48 BuildRequires:  xorg-lib-libXdamage-devel
49 BuildRequires:  xorg-lib-libXtst-devel
50 Obsoletes:      kde4-kdenetwork-kopete < 4.11
51 Obsoletes:      kde4-kdenetwork-kopete-protocol-aim < 4.11
52 Obsoletes:      kde4-kdenetwork-kopete-protocol-bonjour < 4.11
53 Obsoletes:      kde4-kdenetwork-kopete-protocol-gg < 4.11
54 Obsoletes:      kde4-kdenetwork-kopete-protocol-groupwise < 4.11
55 Obsoletes:      kde4-kdenetwork-kopete-protocol-icq < 4.11
56 Obsoletes:      kde4-kdenetwork-kopete-protocol-jabber < 4.11
57 Obsoletes:      kde4-kdenetwork-kopete-protocol-meanwhile < 4.11
58 Obsoletes:      kde4-kdenetwork-kopete-protocol-msn < 4.11
59 Obsoletes:      kde4-kdenetwork-kopete-protocol-skype < 4.11
60 Obsoletes:      kde4-kdenetwork-kopete-protocol-sms < 4.11
61 Obsoletes:      kde4-kdenetwork-kopete-protocol-testbed < 4.11
62 Obsoletes:      kde4-kdenetwork-kopete-protocol-winpopup < 4.11
63 Obsoletes:      kde4-kdenetwork-kopete-protocol-wlm < 4.11
64 Obsoletes:      kde4-kdenetwork-kopete-protocol-yahoo < 4.11
65 Obsoletes:      kde4-kdenetwork-kopete-tool-alias < 4.11
66 Obsoletes:      kde4-kdenetwork-kopete-tool-autoaway < 4.11
67 Obsoletes:      kde4-kdenetwork-kopete-tool-autoreplace < 4.11
68 Obsoletes:      kde4-kdenetwork-kopete-tool-avdeviceconfig < 4.11
69 Obsoletes:      kde4-kdenetwork-kopete-tool-contactnotes < 4.11
70 Obsoletes:      kde4-kdenetwork-kopete-tool-highlight < 4.11
71 Obsoletes:      kde4-kdenetwork-kopete-tool-history < 4.11
72 Obsoletes:      kde4-kdenetwork-kopete-tool-importer < 4.11
73 Obsoletes:      kde4-kdenetwork-kopete-tool-latex < 4.11
74 Obsoletes:      kde4-kdenetwork-kopete-tool-motionaway < 4.11
75 Obsoletes:      kde4-kdenetwork-kopete-tool-nowlistening < 4.11
76 Obsoletes:      kde4-kdenetwork-kopete-tool-spellcheck < 4.11
77 Obsoletes:      kde4-kdenetwork-kopete-tool-texteffect < 4.11
78 Obsoletes:      kde4-kdenetwork-kopete-tool-translator < 4.11
79 Obsoletes:      kde4-kdenetwork-kopete-tool-webpresence < 4.11
80 Obsoletes:      kde4-kdenetwork-libkopete < 4.11
81 Obsoletes:      kde4-kdenetwork-libkopete_oscar < 4.11
82 Obsoletes:      kde4-kdenetwork-libkopete_otr < 4.11
83 Obsoletes:      kde4-kdenetwork-libkopete_videodevice < 4.11
84 Obsoletes:      kdenetwork-libkopete < 10:4
85 Obsoletes:      kdenetwork-libkopete_msn < 10:4
86 Obsoletes:      kdenetwork-libkopete_videodevice < 10:4
87 Obsoletes:      kdenetwork-libkopete_oscar < 10:4
88 Obsoletes:      kdenetwork-kopete < 10:4
89 Obsoletes:      kdenetwork-kopete-protocol-aim < 10:4
90 Obsoletes:      kdenetwork-kopete-protocol-gg < 10:4
91 Obsoletes:      kdenetwork-kopete-protocol-groupwise < 10:4
92 Obsoletes:      kdenetwork-kopete-protocol-icq < 10:4
93 Obsoletes:      kdenetwork-kopete-protocol-irc < 10:4
94 Obsoletes:      kdenetwork-kopete-protocol-jabber < 10:4
95 Obsoletes:      kdenetwork-kopete-protocol-meanwhile < 10:4
96 Obsoletes:      kdenetwork-kopete-protocol-msn < 10:4
97 Obsoletes:      kdenetwork-kopete-protocol-skype < 10:4
98 Obsoletes:      kdenetwork-kopete-protocol-sms < 10:4
99 Obsoletes:      kdenetwork-kopete-protocol-winpopup < 10:4
100 Obsoletes:      kdenetwork-kopete-protocol-yahoo < 10:4
101 Obsoletes:      kdenetwork-kopete-protocol-testbed < 10:4
102 Obsoletes:      kdenetwork-kopete-tool-alias < 10:4
103 Obsoletes:      kdenetwork-kopete-tool-autoaway < 10:4
104 Obsoletes:      kdenetwork-kopete-tool-autoreplace < 10:4
105 Obsoletes:      kdenetwork-kopete-tool-avdeviceconfig < 10:4
106 Obsoletes:      kdenetwork-kopete-tool-conectionstatus < 10:4
107 Obsoletes:      kdenetwork-kopete-tool-contactnotes < 10:4
108 Obsoletes:      kdenetwork-kopete-tool-cryptography < 10:4
109 Obsoletes:      kdenetwork-kopete-tool-highlight < 10:4
110 Obsoletes:      kdenetwork-kopete-tool-history < 10:4
111 Obsoletes:      kdenetwork-kopete-tool-importer < 10:4
112 Obsoletes:      kdenetwork-kopete-tool-latex < 10:4
113 Obsoletes:      kdenetwork-kopete-tool-motionaway < 10:4
114 Obsoletes:      kdenetwork-kopete-tool-nowlistening < 10:4
115 Obsoletes:      kdenetwork-kopete-tool-smpppdcs < 10:4
116 Obsoletes:      kdenetwork-kopete-tool-spellcheck < 10:4
117 Obsoletes:      kdenetwork-kopete-tool-texteffect < 10:4
118 Obsoletes:      kdenetwork-kopete-tool-translator < 10:4
119 Obsoletes:      kdenetwork-kopete-tool-webpresence < 10:4
120 Obsoletes:      kopete < 1
121 Obsoletes:      kopete-designer < 1
122 Obsoletes:      kopete-libkopete < 1
123 Obsoletes:      kopete-libkopete_msn < 1
124 Obsoletes:      kopete-libkopete_videodevice < 1
125 Obsoletes:      kopete-libkopete_oscar < 1
126 Obsoletes:      kopete-plugin-protocols-aim < 1
127 Obsoletes:      kopete-plugin-protocols-gg < 1
128 Obsoletes:      kopete-plugin-protocols-icq < 1
129 Obsoletes:      kopete-plugin-protocols-irc < 1
130 Obsoletes:      kopete-plugin-protocols-jabber < 1
131 Obsoletes:      kopete-plugin-protocols-msn < 1
132 Obsoletes:      kopete-plugin-protocols-oscar < 1
133 Obsoletes:      kopete-plugin-protocols-sms < 1
134 Obsoletes:      kopete-plugin-protocols-winpopup < 1
135 Obsoletes:      kopete-plugin-protocols-yahoo < 1
136 Obsoletes:      kopete-plugin-tools-autoaway < 1
137 Obsoletes:      kopete-plugin-tools-autoreplace < 1
138 Obsoletes:      kopete-plugin-tools-conectionstatus < 1
139 Obsoletes:      kopete-plugin-tools-contactnotes < 1
140 Obsoletes:      kopete-plugin-tools-cryptography < 1
141 Obsoletes:      kopete-plugin-tools-highlight < 1
142 Obsoletes:      kopete-plugin-tools-history < 1
143 Obsoletes:      kopete-plugin-tools-importer < 1
144 Obsoletes:      kopete-plugin-tools-motionaway < 1
145 Obsoletes:      kopete-plugin-tools-nowlistening < 1
146 Obsoletes:      kopete-plugin-tools-spellcheck < 1
147 Obsoletes:      kopete-plugin-tools-texteffect < 1
148 Obsoletes:      kopete-plugin-tools-translator < 1
149 Obsoletes:      kopete-plugin-tools-webpresence < 1
150 Obsoletes:      kopete-protocol-aim < 1
151 Obsoletes:      kopete-protocol-gg < 1
152 Obsoletes:      kopete-protocol-groupwise < 1
153 Obsoletes:      kopete-protocol-icq < 1
154 Obsoletes:      kopete-protocol-irc < 1
155 Obsoletes:      kopete-protocol-jabber < 1
156 Obsoletes:      kopete-protocol-meanwhile < 1
157 Obsoletes:      kopete-protocol-msn < 1
158 Obsoletes:      kopete-protocol-sms < 1
159 Obsoletes:      kopete-protocol-winpopup < 1
160 Obsoletes:      kopete-protocol-yahoo < 1
161 Obsoletes:      kopete-tool-alias < 1
162 Obsoletes:      kopete-tool-autoaway < 1
163 Obsoletes:      kopete-tool-autoreplace < 1
164 Obsoletes:      kopete-tool-avdeviceconfig < 1
165 Obsoletes:      kopete-tool-connectionstatus < 1
166 Obsoletes:      kopete-tool-contactnotes < 1
167 Obsoletes:      kopete-tool-cryptography < 1
168 Obsoletes:      kopete-tool-highlight < 1
169 Obsoletes:      kopete-tool-history < 1
170 Obsoletes:      kopete-tool-importer < 1
171 Obsoletes:      kopete-tool-latex < 1
172 Obsoletes:      kopete-tool-motionaway < 1
173 Obsoletes:      kopete-tool-nowlistening < 1
174 Obsoletes:      kopete-tool-smpppdcs < 1
175 Obsoletes:      kopete-tool-spellcheck < 1
176 Obsoletes:      kopete-tool-texteffect < 1
177 Obsoletes:      kopete-tool-translator < 1
178 Obsoletes:      kopete-tool-webpresence < 1
179 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
180
181 %description
182 Kopete is a flexible and extendable multiple protocol instant
183 messaging system designed as a plugin-based system. All protocols are
184 plugins and allow modular installment, configuration, and usage
185 without the main application knowing anything about the plugin being
186 loaded. The goal of Kopete is to provide users with a standard and
187 easy to use interface between all of their instant messaging systems,
188 but at the same time also providing developers with the ease of
189 writing plugins to support a new protocol. The core Kopete development
190 team provides a handful of plugins that most users can use, in
191 addition to templates for new developers to base a plugin off of.
192
193 %description -l pl.UTF-8
194 Kopete to rozszerzalny i rozbudowywalny komunikator obsługujący wiele
195 protokołów, zaprojektowany w oparciu o wtyczki. Wszystkie protokoły są
196 wtyczkami, co pozwala na modularną instalację, konfigurację i używanie
197 bez potrzeby obsługi ładowanych wtyczek w głównej aplikacji. Celem
198 Kopete jest wyposażenie użytkowników w standardowy i łatwy w użyciu
199 interfejs pomiędzy wszystkimi systemami komunikatorów, a jednocześnie
200 zapewnienie programistom łatwości pisania wtyczek obsługujących nowe
201 protokoły. Załoga programistów Kopete udostępnia podręczny zestaw
202 wtyczek używanych przez większość użytkowników oraz szablony dla
203 nowych programistów, na których można opierać nowe wtyczki.
204
205 %package devel
206 Summary:        kopete header files
207 Summary(pl.UTF-8):      Pliki nagłówkowe kopete
208 License:        LGPL v2+
209 Group:          X11/Development/Libraries
210 Requires:       %{name} = %{version}-%{release}
211 Requires:       kde4-kdelibs-devel >= %{version}
212 Obsoletes:      kopete-devel < 1
213
214 %description devel
215 kopete header files.
216
217 %description devel -l pl.UTF-8
218 Pliki nagłówkowe kopete.
219
220 %description devel -l pt_BR.UTF-8
221 Arquivos de inclusão para compilar aplicações que usem as bibliotecas
222 do kopete.
223
224 %package -n browser-plugin-kde4-kopete-skypebuttons
225 Summary:        Skypebuttons plugin for NPAPI compatible browsers
226 Summary(pl.UTF-8):      Wtyczka skypebuttons dla przeglądarek zgodnych z NPAPI
227 Group:          X11/Applications/Networking
228 Requires:       %{name} = %{version}-%{release}
229
230 %description -n browser-plugin-kde4-kopete-skypebuttons
231 Skypebuttons plugin for NPAPI compatible browsers.
232
233 %description -n browser-plugin-kde4-kopete-skypebuttons -l pl.UTF-8
234 Wtyczka skypebuttons dla przeglądarek zgodnych z NPAPI.
235
236 %prep
237 %setup -q -n %{orgname}-%{version}
238 %patch0 -p1
239 %patch2 -p1
240 %patch3 -p1
241 %patch4 -p1
242 %patch5 -p1
243
244 %build
245 install -d build
246 cd build
247 %cmake .. \
248         %{!?with_npapi:-DBUILD_skypebuttons=OFF} \
249         -DMOZPLUGIN_INSTALL_DIR=%{_browserpluginsdir} \
250         -DWITH_libjingle=OFF
251
252 %{__make}
253
254 %install
255 rm -rf $RPM_BUILD_ROOT
256
257 %{__make} -C build install \
258         DESTDIR=$RPM_BUILD_ROOT \
259         kde_htmldir=%{_kdedocdir}
260
261 %find_lang kopete --with-kde
262
263 %clean
264 rm -rf $RPM_BUILD_ROOT
265
266 %post
267 /sbin/ldconfig
268 %update_browser_plugins
269
270 %postun
271 /sbin/ldconfig
272 if [ "$1" = 0 ]; then
273         %update_browser_plugins
274 fi
275
276 %files -f kopete.lang
277 %defattr(644,root,root,755)
278 %doc COPYING README TODO
279 %attr(755,root,root) %{_bindir}/kopete
280 %attr(755,root,root) %{_bindir}/kopete_latexconvert.sh
281 %attr(755,root,root) %{_bindir}/winpopup-install
282 %attr(755,root,root) %{_bindir}/winpopup-send
283 %attr(755,root,root) %{_libdir}/libkopete.so.*.*.*
284 %attr(755,root,root) %ghost %{_libdir}/libkopete.so.4
285 %attr(755,root,root) %{_libdir}/libkopete_oscar.so.*.*.*
286 %attr(755,root,root) %ghost %{_libdir}/libkopete_oscar.so.4
287 %attr(755,root,root) %{_libdir}/libkopete_otr_shared.so.*.*.*
288 %attr(755,root,root) %ghost %{_libdir}/libkopete_otr_shared.so.1
289 %attr(755,root,root) %{_libdir}/libkopete_videodevice.so.*.*.*
290 %attr(755,root,root) %ghost %{_libdir}/libkopete_videodevice.so.4
291 %attr(755,root,root) %{_libdir}/libkopeteaddaccountwizard.so.*.*.*
292 %attr(755,root,root) %ghost %{_libdir}/libkopeteaddaccountwizard.so.1
293 %attr(755,root,root) %{_libdir}/libkopetechatwindow_shared.so.*.*.*
294 %attr(755,root,root) %ghost %{_libdir}/libkopetechatwindow_shared.so.1
295 %attr(755,root,root) %{_libdir}/libkopetecontactlist.so.*.*.*
296 %attr(755,root,root) %ghost %{_libdir}/libkopetecontactlist.so.1
297 %attr(755,root,root) %{_libdir}/libkopeteidentity.so.*.*.*
298 %attr(755,root,root) %ghost %{_libdir}/libkopeteidentity.so.1
299 %attr(755,root,root) %{_libdir}/libkopeteprivacy.so.*.*.*
300 %attr(755,root,root) %ghost %{_libdir}/libkopeteprivacy.so.1
301 %attr(755,root,root) %{_libdir}/libkopetestatusmenu.so.*.*.*
302 %attr(755,root,root) %ghost %{_libdir}/libkopetestatusmenu.so.1
303 %attr(755,root,root) %{_libdir}/libkyahoo.so.*.*.*
304 %attr(755,root,root) %ghost %{_libdir}/libkyahoo.so.1
305 %attr(755,root,root) %{_libdir}/liboscar.so.*.*.*
306 %attr(755,root,root) %ghost %{_libdir}/liboscar.so.1
307 %attr(755,root,root) %{_libdir}/libqgroupwise.so
308 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_accountconfig.so
309 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_addbookmarks.so
310 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_appearanceconfig.so
311 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_autoreplace.so
312 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_avdeviceconfig.so
313 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_behaviorconfig.so
314 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_chatwindowconfig.so
315 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_highlight.so
316 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_history.so
317 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_history2.so
318 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_latex.so
319 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_nowlistening.so
320 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_otr.so
321 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_pipes.so
322 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_pluginconfig.so
323 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_privacy.so
324 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_statusconfig.so
325 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_texteffect.so
326 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_translator.so
327 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_urlpicpreview.so
328 %attr(755,root,root) %{_libdir}/kde4/kcm_kopete_webpresence.so
329 %attr(755,root,root) %{_libdir}/kde4/kopete_addbookmarks.so
330 %attr(755,root,root) %{_libdir}/kde4/kopete_aim.so
331 %attr(755,root,root) %{_libdir}/kde4/kopete_autoreplace.so
332 %attr(755,root,root) %{_libdir}/kde4/kopete_bonjour.so
333 %attr(755,root,root) %{_libdir}/kde4/kopete_chatwindow.so
334 %attr(755,root,root) %{_libdir}/kde4/kopete_contactnotes.so
335 %attr(755,root,root) %{_libdir}/kde4/kopete_emailwindow.so
336 %attr(755,root,root) %{_libdir}/kde4/kopete_gadu.so
337 %attr(755,root,root) %{_libdir}/kde4/kopete_groupwise.so
338 %attr(755,root,root) %{_libdir}/kde4/kopete_highlight.so
339 %attr(755,root,root) %{_libdir}/kde4/kopete_history.so
340 %attr(755,root,root) %{_libdir}/kde4/kopete_history2.so
341 %attr(755,root,root) %{_libdir}/kde4/kopete_icq.so
342 %attr(755,root,root) %{_libdir}/kde4/kopete_jabber.so
343 %attr(755,root,root) %{_libdir}/kde4/kopete_latex.so
344 %attr(755,root,root) %{_libdir}/kde4/kopete_meanwhile.so
345 %attr(755,root,root) %{_libdir}/kde4/kopete_nowlistening.so
346 %attr(755,root,root) %{_libdir}/kde4/kopete_otr.so
347 %attr(755,root,root) %{_libdir}/kde4/kopete_pipes.so
348 %attr(755,root,root) %{_libdir}/kde4/kopete_privacy.so
349 %attr(755,root,root) %{_libdir}/kde4/kopete_qq.so
350 %attr(755,root,root) %{_libdir}/kde4/kopete_skype.so
351 %attr(755,root,root) %{_libdir}/kde4/kopete_sms.so
352 %attr(755,root,root) %{_libdir}/kde4/kopete_statistics.so
353 %attr(755,root,root) %{_libdir}/kde4/kopete_testbed.so
354 %attr(755,root,root) %{_libdir}/kde4/kopete_texteffect.so
355 %attr(755,root,root) %{_libdir}/kde4/kopete_translator.so
356 %attr(755,root,root) %{_libdir}/kde4/kopete_urlpicpreview.so
357 %attr(755,root,root) %{_libdir}/kde4/kopete_webpresence.so
358 %attr(755,root,root) %{_libdir}/kde4/kopete_wlm.so
359 %attr(755,root,root) %{_libdir}/kde4/kopete_wp.so
360 %attr(755,root,root) %{_libdir}/kde4/kopete_yahoo.so
361 %attr(755,root,root) %{_libdir}/kde4/libchattexteditpart.so
362 %attr(755,root,root) %{_libdir}/kde4/plugins/accessible/chatwindowaccessiblewidgetfactory.so
363 %attr(755,root,root) %{_datadir}/apps/kconf_update/kopete-*.pl
364 %attr(755,root,root) %{_datadir}/apps/kconf_update/kopete-*.sh
365 %{_datadir}/apps/kconf_update/kopete-*.upd
366 %{_datadir}/apps/kopete
367 %{_datadir}/apps/kopete_contactnotes
368 %{_datadir}/apps/kopete_groupwise
369 %{_datadir}/apps/kopete_history
370 %{_datadir}/apps/kopete_history2
371 %{_datadir}/apps/kopete_jabber
372 %{_datadir}/apps/kopete_latex
373 %{_datadir}/apps/kopete_otr
374 %{_datadir}/apps/kopete_privacy
375 %{_datadir}/apps/kopete_skype
376 %{_datadir}/apps/kopete_statistics
377 %{_datadir}/apps/kopete_translator
378 %{_datadir}/apps/kopete_wlm
379 %{_datadir}/apps/kopete_yahoo
380 %{_datadir}/apps/kopeterichtexteditpart
381 %{_datadir}/config/kopeterc
382 %{_datadir}/config.kcfg/history2config.kcfg
383 %{_datadir}/config.kcfg/historyconfig.kcfg
384 %{_datadir}/config.kcfg/kopete_otr.kcfg
385 %{_datadir}/config.kcfg/kopeteappearancesettings.kcfg
386 %{_datadir}/config.kcfg/kopetebehaviorsettings.kcfg
387 %{_datadir}/config.kcfg/kopetestatussettings.kcfg
388 %{_datadir}/config.kcfg/latexconfig.kcfg
389 %{_datadir}/config.kcfg/nowlisteningconfig.kcfg
390 %{_datadir}/config.kcfg/translatorconfig.kcfg
391 %{_datadir}/config.kcfg/urlpicpreview.kcfg
392 %{_datadir}/config.kcfg/webpresenceconfig.kcfg
393 %{_datadir}/dbus-1/interfaces/org.kde.Kopete.xml
394 %{_datadir}/dbus-1/interfaces/org.kde.kopete.Client.xml
395 %{_datadir}/dbus-1/interfaces/org.kde.kopete.Statistics.xml
396 %{_datadir}/kde4/services/aim.protocol
397 %{_datadir}/kde4/services/callto.protocol
398 %{_datadir}/kde4/services/skype.protocol
399 %{_datadir}/kde4/services/tel.protocol
400 %{_datadir}/kde4/services/xmpp.protocol
401 %{_datadir}/kde4/services/chatwindow.desktop
402 %{_datadir}/kde4/services/emailwindow.desktop
403 %{_datadir}/kde4/services/kopete_*.desktop
404 %{_datadir}/kde4/services/kconfiguredialog
405 %{_datadir}/kde4/servicetypes/kopeteplugin.desktop
406 %{_datadir}/kde4/servicetypes/kopeteprotocol.desktop
407 %{_datadir}/kde4/servicetypes/kopeteui.desktop
408 %{_datadir}/sounds/Kopete_*.ogg
409 %{_desktopdir}/kde4/kopete.desktop
410 %{_iconsdir}/hicolor/*x*/apps/kopete*.png
411 %{_iconsdir}/hicolor/scalable/apps/kopete*.svgz
412 %{_iconsdir}/oxygen/*x*/actions/account_offline_overlay.png
413 %{_iconsdir}/oxygen/*x*/actions/contact_*_overlay.png
414 %{_iconsdir}/oxygen/*x*/actions/emoticon.png
415 %{_iconsdir}/oxygen/*x*/actions/im-status-message-edit.png
416 %{_iconsdir}/oxygen/*x*/actions/metacontact_unknown.png
417 %{_iconsdir}/oxygen/*x*/actions/status_unknown.png
418 %{_iconsdir}/oxygen/*x*/actions/status_unknown_overlay.png
419 %{_iconsdir}/oxygen/*x*/actions/view-user-offline-kopete.png
420 %{_iconsdir}/oxygen/*x*/actions/voicecall.png
421 %{_iconsdir}/oxygen/*x*/actions/webcamreceive.png
422 %{_iconsdir}/oxygen/*x*/actions/webcamsend.png
423 %{_iconsdir}/oxygen/22x22/status/object-locked-*.png
424 %{_iconsdir}/oxygen/32x32/actions/newmessage.mng
425 %{_iconsdir}/oxygen/48x48/actions/mail-encrypt.png
426 %{_iconsdir}/oxygen/scalable/actions/account_offline_overlay.svgz
427 %{_iconsdir}/oxygen/scalable/actions/im-status-message-edit.svgz
428 %{_iconsdir}/oxygen/scalable/actions/mail-encrypt.svgz
429 %{_iconsdir}/oxygen/scalable/actions/view-user-offline-kopete.svgz
430 %{_iconsdir}/oxygen/scalable/actions/voicecall.svgz
431 %{_iconsdir}/oxygen/scalable/actions/webcamreceive.svgz
432 %{_iconsdir}/oxygen/scalable/actions/webcamsend.svgz
433 %{_iconsdir}/oxygen/scalable/status/object-locked-*.svgz
434
435 %files devel
436 %defattr(644,root,root,755)
437 %attr(755,root,root) %{_libdir}/libkopete*.so
438 %attr(755,root,root) %{_libdir}/libkyahoo.so
439 %attr(755,root,root) %{_libdir}/liboscar.so
440 %{_includedir}/kopete
441
442 %if %{with npapi}
443 %files -n browser-plugin-kde4-kopete-skypebuttons
444 %defattr(644,root,root,755)
445 %attr(755,root,root) %{_browserpluginsdir}/skypebuttons.so
446 %endif
This page took 0.137114 seconds and 3 git commands to generate.