]> git.pld-linux.org Git - packages/kde4-kmouth.git/blob - kde4-kmouth.spec
Initial commit
[packages/kde4-kmouth.git] / kde4-kmouth.spec
1 %define         _state          stable
2 %define         orgname         kmouth
3 %define         qtver           4.8.1
4
5 Summary:        K Desktop Environment - A program that speaks for you
6 Name:           kde4-%{orgname}
7 Version:        4.9.0
8 Release:        1
9 License:        GPL v2
10 Group:          X11/Applications/Graphics
11 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
12 # Source0-md5:  3a29f2ef9e2d792afc895256bbd7d752
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt3Support-devel >= %{qtver}
15 BuildRequires:  QtCore-devel >= %{qtver}
16 BuildRequires:  automoc4 >= 0.9.88
17 BuildRequires:  cmake >= 2.8.0
18 BuildRequires:  kde4-kdelibs-devel >= %{version}
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  perl
21 BuildRequires:  qt4-build >= %{qtver}
22 BuildRequires:  qt4-qmake >= %{qtver}
23 BuildRequires:  rpmbuild(macros) >= 1.600
24 BuildRequires:  xorg-lib-libX11-devel
25 Requires:       kde4-kaccessible >= %{version}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Program that allows people who have lost their voice to let their
30 computer speak for them.
31
32 %prep
33 %setup -q -n %{orgname}-%{version}
34
35 %build
36 install -d build
37 cd build
38 %cmake \
39         ../
40
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} -C build/ install \
47         DESTDIR=$RPM_BUILD_ROOT \
48         kde_htmldir=%{_kdedocdir}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %attr(755,root,root) %{_bindir}/kmousetool
56 %{_desktopdir}/kde4/kmousetool.desktop
57 %{_datadir}/apps/kmousetool
58 %{_iconsdir}/hicolor/*/actions/kmousetool_off.png
59 %{_iconsdir}/hicolor/*/actions/kmousetool_on.png
60 %{_iconsdir}/hicolor/*/apps/kmousetool.png
61 %{_docdir}/kde/HTML/en/kmousetool
62 %{_mandir}/man1/kmousetool.1*
This page took 0.058883 seconds and 3 git commands to generate.