]> git.pld-linux.org Git - packages/kde4-kdevelop.git/blob - kde4-kdevelop.spec
c18c40fea33a44f680c5a9dfa91ac7cf8d465ce3
[packages/kde4-kdevelop.git] / kde4-kdevelop.spec
1 #
2 # Conditional build:
3 #
4 %define         _state          stable
5 %define         kdever          4.12.0
6 %define         qtver           4.8.0
7 %define         orgname         kdevelop
8 %define         kdevplatform    1.7.0
9
10 Summary:        KDE Integrated Development Environment
11 Summary(de.UTF-8):      KDevelop ist eine grafische Entwicklungsumgebung für KDE
12 Summary(pl.UTF-8):      Zintegrowane środowisko programisty dla KDE
13 Summary(pt_BR.UTF-8):   Ambiente Integrado de Desenvolvimento para o KDE
14 Summary(zh_CN.UTF-8):   KDE C/C++集成开发环境
15 Name:           kde4-kdevelop
16 Version:        4.7.0
17 Release:        1
18 License:        GPL
19 Group:          X11/Development/Tools
20 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/kdevelop/%{version}/src/%{orgname}-%{version}.tar.xz
21 # Source0-md5:  0912f881cb1219450aeb155494846bbd
22 Patch0:         %{name}-stable.patch
23 URL:            http://www.kdevelop.org/
24 BuildRequires:  QtHelp-devel >= %{qtver}
25 BuildRequires:  QtNetwork-devel >= %{qtver}
26 BuildRequires:  automoc4
27 BuildRequires:  cmake >= 2.8.9
28 BuildRequires:  docbook-style-xsl
29 BuildRequires:  gettext-tools
30 BuildRequires:  kde4-kdebase-workspace-devel >= 4.10.0
31 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
32 BuildRequires:  kde4-okteta-devel >= %{kdever}
33 BuildRequires:  kde4-kdevplatform-devel >= %{kdevplatform}
34 BuildRequires:  libstdc++-devel >= 3.3
35 BuildRequires:  pkgconfig
36 BuildRequires:  qt4-build >= %{qtver}
37 BuildRequires:  qt4-qmake >= %{qtver}
38 BuildRequires:  rpm-pythonprov
39 BuildRequires:  rpmbuild(macros) >= 1.600
40 BuildRequires:  zlib-devel >= 1.2.0
41 BuildConflicts: star
42 Requires:       libstdc++-gdb
43 Requires(post,postun):  desktop-file-utils
44 Requires(post,postun):  shared-mime-info
45 #Provides svn ioslave and perl doc ioslave
46 Suggests:       kde4-kdesdk-kioslaves >= %{kdever}
47 #Provides additional project templates
48 Suggests:       kde4-kapptemplate >= %{kdever}
49 #Provides ui viewer
50 Suggests:       kde4-kde-dev-utils >= %{kdever}
51 Suggests:       kde4-kompare >= %{kdever}
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         filterout       -flto
55
56 %description
57 The KDevelop Integrated Development Environment provides many features
58 that developers need as well as providing a unified interface to
59 programs like gdb, the C/C++ compiler, and make.
60
61 KDevelop manages or provides: all development tools needed for C++
62 programming like Compiler, Linker, automake and autoconf; KAppWizard,
63 which generates complete, ready-to-go sample applications;
64 Classgenerator, for creating new classes and integrating them into the
65 current project; File management for sources, headers, documentation
66 etc. to be included in the project; The creation of User-Handbooks
67 written with SGML and the automatic generation of HTML-output with the
68 KDE look and feel; Automatic HTML-based API-documentation for your
69 project's classes with cross-references to the used libraries;
70 Internationalization support for your application, allowing
71 translators to easily add their target language to a project;
72
73 KDevelop also includes WYSIWYG (What you see is what you get)-creation
74 of user interfaces with a built-in dialog editor; Debugging your
75 application by integrating KDbg; Editing of project-specific pixmaps
76 with KIconEdit; The inclusion of any other program you need for
77 development by adding it to the "Tools"-menu according to your
78 individual needs.
79
80 %description -l de.UTF-8
81 KDevelop ist eine grafische Entwicklungsumgebung für KDE.
82
83 Das KDevelop-Projekt wurde 1998 begonnen, um eine einfach zu
84 bedienende grafische (integrierte) Entwicklungsumgebung für C++ und C
85 auf Unix-basierten Betriebssystemen bereitzustellen. Seit damals ist
86 die KDevelop-IDE öffentlich unter der GPL erhältlich und unterstützt
87 u. a. Qt-, KDE-, GNOME-, C++- und C-Projekte.
88
89 %description -l pl.UTF-8
90 KDevelop to zintegrowane środowisko programistyczne dla KDE, dające
91 wiele możliwości przydatnych programistom oraz zunifikowany interfejs
92 do programów typu gdb, kompilator C/C++ oraz make.
93
94 KDevelop obsługuje lub zawiera: wszystkie narzędzia programistyczne
95 potrzebne do programowania w C++ jak kompilator, linker, automake,
96 autoconf; KAppWizard, generujący kompletne, gotowe do uruchomienia,
97 proste aplikacje; Classgenerator do tworzenia nowych klas i włączania
98 ich do projektu; zarządzanie plikami źródłowymi, nagłówkowymi,
99 dokumentacją itp.; tworzenie podręczników użytkownika pisanych w SGML
100 i automatyczne generowanie wyjścia HTML pasującego do KDE;
101 automatyczne tworzenie dokumentacji API w HTML do klas projektu z
102 odniesieniami do używanych bibliotek; wsparcie dla
103 internacjonalizacji, pozwalające tłumaczom łatwo dodawać pliki z
104 tłumaczeniami do projektu.
105
106 KDevelop ma także tworzenie interfejsów użytkownika przy użyciu
107 edytora dialogów WYSIWYG; odpluskwianie aplikacji poprzez integrację z
108 KDbg; edycję ikon przy pomocy KIconEdit; dołączanie innych programów
109 potrzebnych do programowania przez dodanie ich do menu Tools według
110 własnych potrzeb.
111
112 %package devel
113 Summary:        kdevelop - header files and development documentation
114 Summary(pl.UTF-8):      kdevelop - pliki nagłówkowe i dokumentacja
115 Group:          X11/Development/Libraries
116 Requires:       %{name} = %{version}-%{release}
117
118 %description devel
119 This package contains header files and development documentation for
120 kdevelop.
121
122 %description devel -l pl.UTF-8
123 Pakiet ten zawiera pliki nagłówkowe i dokumentację potrzebną przy
124 pisaniu własnych programów wykorzystujących kdevelop.
125
126 %prep
127 %setup -q -n %{orgname}-%{version}
128 %patch0 -p1
129
130 %build
131 install -d build
132 cd build
133 %cmake \
134         ../
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 install -d $RPM_BUILD_ROOT%{_desktopdir}
141 %{__make} -C build install \
142         DESTDIR=$RPM_BUILD_ROOT \
143         kde_htmldir=%{_kdedocdir}
144
145 install app/kdevelop.desktop $RPM_BUILD_ROOT%{_desktopdir}
146
147 %find_lang %{orgname} --all-name --with-kde
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post
153 /sbin/ldconfig
154 %update_mime_database
155 %update_desktop_database
156
157 %postun
158 /sbin/ldconfig
159 %update_mime_database
160 %update_desktop_database_postun
161
162 %files -f %{orgname}.lang
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/kdevelop
165 %attr(755,root,root) %{_bindir}/kdevelop!
166 %attr(755,root,root) %{_libdir}/kde4/kcm_kdev_makebuilder.so
167 %attr(755,root,root) %{_libdir}/kde4/kcm_kdev_cmakebuilder.so
168 %attr(755,root,root) %{_libdir}/kde4/kcm_kdevcmake_settings.so
169 %attr(755,root,root) %{_libdir}/kde4/kcm_kdev_ninjabuilder.so
170 %attr(755,root,root) %{_libdir}/kde4/kcm_kdevcustombuildsystem.so
171 %attr(755,root,root) %{_libdir}/kde4/kcm_kdevcustomdefinesandincludes.so
172 %attr(755,root,root) %{_libdir}/kde4/kdevastyle.so
173 %attr(755,root,root) %{_libdir}/kde4/kdevcmakebuilder.so
174 %attr(755,root,root) %{_libdir}/kde4/kdevcmakedocumentation.so
175 %attr(755,root,root) %{_libdir}/kde4/kdevcmakemanager.so
176 %attr(755,root,root) %{_libdir}/kde4/kdevcompilerprovider.so
177 %attr(755,root,root) %{_libdir}/kde4/kdevcpplanguagesupport.so
178 %attr(755,root,root) %{_libdir}/kde4/kdevcustombuildsystem.so
179 %attr(755,root,root) %{_libdir}/kde4/kdevcustommakemanager.so
180 %attr(755,root,root) %{_libdir}/kde4/kdevcustomscript.so
181 %attr(755,root,root) %{_libdir}/kde4/kdevdefinesandincludesmanager.so
182 %attr(755,root,root) %{_libdir}/kde4/kdevexecuteplasmoid.so
183 %attr(755,root,root) %{_libdir}/kde4/kdevgdb.so
184 %attr(755,root,root) %{_libdir}/kde4/kdevghprovider.so
185 %attr(755,root,root) %{_libdir}/kde4/kdevokteta.so
186 %attr(755,root,root) %{_libdir}/kde4/kdevmakebuilder.so
187 %attr(755,root,root) %{_libdir}/kde4/kdevmanpage.so
188 %attr(755,root,root) %{_libdir}/kde4/kdevninja.so
189 %attr(755,root,root) %{_libdir}/kde4/kdevqthelp.so
190 %attr(755,root,root) %{_libdir}/kde4/kdevqthelp_config.so
191 %attr(755,root,root) %{_libdir}/kde4/kdevkdeprovider.so
192 %attr(755,root,root) %{_libdir}/kde4/krunner_kdevelopsessions.so
193 %attr(755,root,root) %{_libdir}/kde4/plasma_engine_kdevelopsessions.so
194 %attr(755,root,root) %{_libdir}/libkdev4cmakecommon.so
195 %attr(755,root,root) %{_libdir}/libkdev4cppduchain.so
196 %attr(755,root,root) %{_libdir}/libkdev4cppparser.so
197 %attr(755,root,root) %{_libdir}/libkdev4cpprpp.so
198 %attr(755,root,root) %{_libdir}/libkdev4includesdefinessettings.so
199 %{_datadir}/apps/kdevappwizard
200 %{_datadir}/apps/kdevcodegen/templates/*
201 %{_datadir}/apps/kdevcustommakemanager
202 %{_datadir}/apps/kdevelop
203 %{_datadir}/apps/kdevfiletemplates/templates/*
204 %dir %{_datadir}/apps/kdevgdb
205 %{_datadir}/apps/kdevgdb/kdevgdbui.rc
206 %dir %{_datadir}/apps/kdevgdb/printers
207 %{_datadir}/apps/kdevgdb/printers/gdbinit
208 %{_datadir}/apps/kdevgdb/printers/helper.py
209 %{_datadir}/apps/kdevgdb/printers/qt4.py
210 %{_datadir}/apps/kdevgdb/printers/kde4.py
211 %dir %{_datadir}/apps/kdevmanpage
212 %{_datadir}/apps/kdevmanpage/manpagedocumentation.css
213 %{_datadir}/apps/kdevokteta
214 %{_datadir}/apps/plasma/plasmoids/kdevelopsessions
215 %{_datadir}/apps/plasma/services/org.kde.plasma.dataengine.kdevelopsessions.operations
216 %{_datadir}/config/kdeveloprc
217 %{_datadir}/config/kdevelop-qthelp.knsrc
218 %dir %{_datadir}/apps/kdevcppsupport
219 %{_datadir}/apps/kdevcppsupport/kdevcppsupport.rc
220 %{_datadir}/kde4/services/kcm_kdev_cmakebuilder.desktop
221 %{_datadir}/kde4/services/kcm_kdev_makebuilder.desktop
222 %{_datadir}/kde4/services/kcm_kdevcmake_settings.desktop
223 %{_datadir}/kde4/services/kcm_kdev_ninjabuilder.desktop
224 %{_datadir}/kde4/services/kcm_kdevcustombuildsystem.desktop
225 %{_datadir}/kde4/services/kcm_kdevcustomdefinesandincludes.desktop
226 %{_datadir}/kde4/services/kdevastyle.desktop
227 %{_datadir}/kde4/services/kdevcmakebuilder.desktop
228 %{_datadir}/kde4/services/kdevcmakedocumentation.desktop
229 %{_datadir}/kde4/services/kdevcmakemanager.desktop
230 %{_datadir}/kde4/services/kdevcompilerprovider.desktop
231 %{_datadir}/kde4/services/kdevcustombuildsystem.desktop
232 %{_datadir}/kde4/services/kdevcustomscript.desktop
233 %{_datadir}/kde4/services/kdevcppsupport.desktop
234 %{_datadir}/kde4/services/kdevcustommakemanager.desktop
235 %{_datadir}/kde4/services/kdevdefinesandincludesmanager.desktop
236 %{_datadir}/kde4/services/kdevexecuteplasmoid.desktop
237 %{_datadir}/kde4/services/kdevgdb.desktop
238 %{_datadir}/kde4/services/kdevghprovider.desktop
239 %{_datadir}/kde4/services/kdevmakebuilder.desktop
240 %{_datadir}/kde4/services/kdevmanpage.desktop
241 %{_datadir}/kde4/services/kdevninja.desktop
242 %{_datadir}/kde4/services/kdevokteta.desktop
243 %{_datadir}/kde4/services/kdevqthelp.desktop
244 %{_datadir}/kde4/services/kdevqthelp_config.desktop
245 %{_datadir}/kde4/services/kdevelopsessions.desktop
246 %{_datadir}/kde4/services/kdevkdeprovider.desktop
247 %{_datadir}/kde4/services/plasma-applet-kdevelopsessions.desktop
248 %{_datadir}/kde4/services/plasma-dataengine-kdevelopsessions.desktop
249 %{_datadir}/mime/packages/kdevelop.xml
250 %{_desktopdir}/kdevelop.desktop
251 %{_desktopdir}/kde4/kdevelop.desktop
252 %{_desktopdir}/kde4/kdevelop_ps.desktop
253 %{_iconsdir}/*/*x*/*/*.png
254 %{_includedir}/kdevelop
255
256 %files devel
257 %defattr(644,root,root,755)
258 %{_datadir}/apps/cmake/modules/FindKDevelop.cmake
This page took 0.095995 seconds and 2 git commands to generate.