]> git.pld-linux.org Git - packages/kde4-kdesdk.git/blob - kde4-kdesdk.spec
8805cb304d089e02af703778a4a594eecbbc8729
[packages/kde4-kdesdk.git] / kde4-kdesdk.spec
1 #
2 # TODO:
3 # - add man files
4 #
5 %define         orgname         kdesdk
6 %define         _state          stable
7 %define         qtver           4.8.1
8
9 Summary:        KDESDK - Software Development Kit for KDE
10 Summary(pl.UTF-8):      KDESDK - Wsparcie programistyczne dla KDE
11 Name:           kde4-kdesdk
12 Version:        4.10.4
13 Release:        1
14 License:        GPL
15 Group:          X11/Development/Tools
16 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
17 # Source0-md5:  d137f29845aea8a7e6ed36dca1123c2a
18 #Patch100: %{name}-branch.diff
19 Patch0:         %{name}-kiosvn.patch
20 Patch1:         %{name}-include.patch
21 URL:            http://www.kde.org/
22 BuildRequires:  QtNetwork-devel >= %{qtver}
23 BuildRequires:  QtScriptTools-devel >= %{qtver}
24 BuildRequires:  antlr
25 BuildRequires:  automoc4 >= 0.9.88
26 BuildRequires:  binutils-devel
27 BuildRequires:  boost-devel >= 1.35.0
28 BuildRequires:  bzip2-devel
29 BuildRequires:  cmake >= 2.8.0
30 BuildRequires:  db-devel
31 BuildRequires:  docbook-dtd42-xml
32 BuildRequires:  docbook-style-xsl
33 BuildRequires:  emacs-common
34 BuildRequires:  gettext-devel
35 BuildRequires:  giflib-devel
36 BuildRequires:  hunspell-devel
37 # required for dolphin plugins
38 BuildRequires:  kde4-kdebase-devel >= %{version}
39 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libltdl-devel
42 BuildRequires:  libxslt-devel
43 BuildRequires:  qca-devel >= 2.0.0
44 BuildRequires:  qt4-build >= %{qtver}
45 BuildRequires:  qt4-qmake >= %{qtver}
46 BuildRequires:  rpm-pythonprov
47 BuildRequires:  rpmbuild(macros) >= 1.600
48 BuildRequires:  shared-mime-info
49 BuildRequires:  strigi-devel >= 0.7.2
50 BuildRequires:  subversion-devel >= 0.37.0
51 BuildRequires:  utempter-devel
52 BuildRequires:  xorg-lib-libXpm-devel
53 BuildRequires:  xorg-lib-libXtst-devel
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %define         _gimpdir        %{_datadir}/gimp/2.0
57 %define         _appdefsdir     %{_datadir}/X11/app-defaults
58 %define         _emacspkgdir    /usr/share/emacs/%(rpm -q --qf %{V} emacs-common | tr -d '[a-z]')
59 %define         _xemacspkgdir   /usr/share/xemacs-packages
60 %define         _zshfcdir       /usr/share/zsh/latest/functions
61
62 %description
63 Software Development Kit for KDE.
64
65 %description -l pl.UTF-8
66 Pakiet wspomagający programowanie w środowisku KDE.
67
68 %package kfile
69 Summary:        Developers' file formats enhanced information
70 Summary(pl.UTF-8):      Rozszerzone informacje o plikach używanych przez programistów
71 Group:          X11/Development/Libraries
72 Requires:       kde4-konqueror >= %{version}
73
74 %description kfile
75 This package adds a tab to konqueror "file properties" dialog window
76 with file enhanced informations for C++ source files, diff files,
77 gettext and designer translation sourcefiles.
78
79 %description kfile -l pl.UTF-8
80 Ten pakiet dodaje do okna dialogowego "właściwości pliku" konquerora
81 dodatkową zakładkę z rozszerzonymi informacjami o pliku.
82
83 %package cervisia
84 Summary:        A KDE CVS frontend
85 Summary(pl.UTF-8):      Frontend do CVS dla KDE
86 Group:          X11/Development/Tools
87 Requires:       cvs-client >= 1.10
88 Requires:       kde4-kdebase >= %{version}
89
90 %description cervisia
91 A KDE CVS frontend. It features:
92 - updating or retrieving the status of a working directory or single
93   files. Files are displayed in different colors depending on their
94   status, and the shown files can be filtered according to their status
95 - common operations like adding, removing and commiting files.
96 - advanced operations like adding and removing watches, editing and
97   unediting files, locking and unlocking.
98 - checking out and importing modules.
99 - graphical diff against the repository and between different
100   revisions.
101 - blame-annotated view of a file.
102 - view of the log messages in tree and list form.
103 - resolving of conflicts in a file.
104 - tagging and branching.
105 - updating to a tag, branch or date.
106 - a Changelog editor coupled with the commit dialog.
107
108 %description cervisia -l pl.UTF-8
109 Frontend do CVS dla KDE. Ma następujące możliwości:
110 - uaktualnianie lub odtwarzanie stanu katalogu lub pojedynczych
111   plików; pliki są wyświetlane w różnych kolorach zależnie od ich stanu,
112   a pokazywane pliki mogą być filtrowane według ich stanu
113 - podstawowe operacje, takie jak dodawanie, usuwanie i commitowanie
114   plików
115 - zaawansowane operacje, takie jak dodawanie i usuwanie śledzenia,
116   włączanie i wyłączanie edycji plików, blokowanie i odblokowywanie
117 - pobieranie i importowanie modułów
118 - graficzne wyświetlanie różnic względem repozytorium i między różnymi
119   rewizjami
120 - widok pliku opisany winnymi
121 - widok loga komentarzy do zmian w postaci drzewa i listy
122 - rozwiązywanie konfliktów w pliku
123 - tagowanie i branchowanie
124 - uaktualnianie do taga, brancha lub daty
125 - edytor changelogów połączony z oknem dialogowym do commitowania.
126
127 %package dolphin-plugins
128 Summary:        Dolphin VCS plugins
129 Group:          X11/Applications
130 Requires:       kde4-dolphin
131 Conflicts:      kde-kio-svn < 4.9.3
132 Obsoletes:      kde-kio-git
133
134 %description dolphin-plugins
135 This package contains plugins that offer integration of various version
136 control systems in Dolphin.
137
138 %package lokalize
139 Summary:        Computer-aided translation system that focuses on productivity and performance
140 Summary(pl.UTF-8):      a
141 Group:          X11/Development/Tools
142
143 %description lokalize
144 Lokalize is a computer-aided translation system that focuses on
145 productivity and performance. Translator does only creative work (of
146 delivering message in his/her mother language in laconic and easy to
147 understand form). Lokalize implies parapgraph-by-paragrah translation
148 approach (when translating documentation) and message-by-message
149 approach (when translating GUI).
150
151 %description lokalize -l pl.UTF-8
152
153
154 %package kde-resource-kdeaccounts
155 Summary:        A kdeaccounts plugin for the KDE PIM framework
156 Summary(pl.UTF-8):      Wtyczka do książki adresowej KDE dodająca obsługę kdeaccounts
157 Group:          X11/Applications
158 Requires:       kde4-kdepim-kaddressbook >= 4.4.5
159
160 %description kde-resource-kdeaccounts
161 A kdeaccounts plugin for the KDE adressbook. It allows adding the
162 people from KDE's CVS accounts file to the addressbook.
163
164 %description kde-resource-kdeaccounts -l pl.UTF-8
165 Wtyczka do książki adresowej KDE dodająca obsługę kdeaccounts. Dodaje
166 ona osoby posiadające konta w CVS KDE do książki adresowej.
167
168 %package kapptemplate
169 Summary:        KDE application framework generator
170 Summary(pl.UTF-8):      Generator szkieletu dla aplikacji KDE
171 Group:          X11/Development/Tools
172
173 %description kapptemplate
174 Modular shell script that will automatically create a framework for
175 either a normal KDE 3.x application, a KPart application, a KPart
176 plugin, or convert an existing application.
177
178 %description kapptemplate -l pl.UTF-8
179 Modularny skrypt, który potrafi automatycznie wygenerować szkielet
180 katalogów dla zwykłej aplikacji pod KDE 3.x, aplikacji KPart, wtyczki
181 KPart lub skonwertować istniejącą aplikację.
182
183 %package kcachegrind
184 Summary:        KCachegrind - visualization of traces generated by profiling
185 Summary(pl.UTF-8):      KCachegrind - wizualizacja ścieżek tworzonych przez profilowanie
186 Group:          X11/Development/Tools
187
188 %description kcachegrind
189 KCachegrind visualizes traces generated by profiling.
190
191 %description kcachegrind -l pl.UTF-8
192 KCachegrind wizualizuje ścieżki tworzone przez profilowanie.
193
194 %package kmtrace
195 Summary:        A mtrace to full backtrace conversion tool
196 Summary(pl.UTF-8):      Narzędzie do konwersji z mtrace do pełnego backtrace'a
197 Group:          X11/Development/Tools
198
199 %description kmtrace
200 kmtrace converts glibc's mtrace log into a full backtrace.
201
202 %description kmtrace -l pl.UTF-8
203 kmtrace konwertuje mtrace glibca do pełnego backtrace'a.
204
205 %package kompare
206 Summary:        Kompare - a program to view the differences between files
207 Summary(pl.UTF-8):      Kompare - program służący do porównywania zmian między plikami
208 Group:          X11/Development/Tools
209
210 %description kompare
211 Kompare is a program to view the differences between files. Features
212 include:
213
214   - comparison of files or directories via a graphical interface
215   - bezier-based connection widget lets you see both source and
216     destination as they really appear
217   - graphical viewing of patch files in normal, context, unified and
218     diff formats
219   - interactive application of differences
220   - full network transparency
221   - ability to view plain-text diff output in embedded viewer
222   - easy navigation of multiple-file diffs with dockable navigation tree
223   - graphical interface to commonly used diff command line options
224   - switch source and destination with one command
225   - diff statistics
226
227 %description kompare -l pl.UTF-8
228 Kompare to program służący do porównywania zmian między plikami.
229 Aktualnie dostępne funkcje:
230   - porównanie plików lub katalogów poprzez graficzny interfejs
231   - przedstawienie źródła i celu za pomocą krzywej Beziera
232   - graficzne przeglądanie łat w formatach diff, unidiff, context i
233     zwykłym
234   - interaktywne wprowadzanie zmian
235   - przezroczystość sieciowa
236   - możliwość oglądania wyjścia diff w wewnętrznej przeglądarce
237   - łatwa nawigacja między wieloplikowymi diffami wraz z dokowalnym
238     drzewem
239   - zamiana źródła i celu za pomocą pojedynczej komendy
240   - statystyki diffów
241
242 %package kprofilemethod
243 Summary:        Kprofilemethod - a set of macros which help profiling using QTime
244 Summary(pl.UTF-8):      Kprofilemethod - zestaw makr ułatwiających profilowanie z wykorzystaniem QTime
245 Group:          X11/Development/Tools
246
247 %description kprofilemethod
248 Kprofilemethod is a set of macros which help profiling using QTime.
249
250 %description kprofilemethod -l pl.UTF-8
251 Kprofilemethod to zestaw makr ułatwiających profilowanie z
252 wykorzystaniem QTime.
253
254 %package kstartperf
255 Summary:        A tool to measure startup time for KDE applications
256 Summary(pl.UTF-8):      Narzędzie służące do pomiaru czasu ładowania aplikacji KDE
257 Group:          X11/Development/Tools
258
259 %description kstartperf
260 kstartperf measures startup time for KDE applications.
261
262 %description kstartperf -l pl.UTF-8
263 Narzędzie służące do pomiaru czasu ładowania aplikacji KDE.
264
265 %package kuiviewer
266 Summary:        Qt Designer UI file Viewer
267 Summary(pl.UTF-8):      Przeglądarka plików UI generowanych przez Qt designera
268 Group:          X11/Development/Tools
269
270 %description kuiviewer
271 Qt Designer UI file Viewer.
272
273 %description kuiviewer -l pl.UTF-8
274 Przeglądarka plików UI generowanych przez Qt designera.
275
276 %package po2xml
277 Summary:        An xml2po and vice versa converters
278 Summary(pl.UTF-8):      Konwertery po2xml i vice versa
279 Group:          X11/Development/Tools
280 Requires:       /usr/bin/python
281
282 %description po2xml
283 An xml2po and vice versa converters.
284
285 %description po2xml -l pl.UTF-8
286 Konwertery po2xml i vice versa.
287
288 %package scripts-developer
289 Summary:        An set of scripts useful for building and maintaining KDE
290 Summary(pl.UTF-8):      Zestaw skryptów do kompilowania i utrzymywania KDE
291 Group:          X11/Development/Tools
292 Requires:       /usr/bin/perl
293
294 %description scripts-developer
295 This package contains:
296 - script that extracts strings in an application's .rc file, e.g.
297   testappui.rc, and writes into the pot file
298 - script that counts lines of code, comments and blank space in C and
299   C++ source files
300 - script for finding missing and packaging crystal icons.
301 - kdelnk to desktop and zonetab2pot converter
302 - set of kde-build scripts
303 - set of scripts that allow more comfortable profiling of KDE apps
304 - set of scripts to fix licence header/KDE includes directives and
305   strip irrelevant tags from .ui files
306 - KDE man pages generator
307 - multi-frame PNG to MNG converter
308
309 %description scripts-developer -l pl.UTF-8
310 Ten pakiet zawiera:
311 - skrypt, który wyciąga łańcuchy z plików .rc aplikacji, np.
312   testappgui.rc i zapisuje je do plików pot, z których tworzy się
313   tłumaczenia (pliki po)
314 - skrypt zliczający linijki kodu, komentarzy i znaków białych w
315   plikach źródłowych C i C++
316 - skrypt do wyszukiwania brakujących i pakietowania ikon z motywu
317   crystal.
318 - konwerter plików kdelnk na desktop i zonetab na pot
319 - zestaw skryptów kde-build
320 - zestaw skryptów umożliwiających wygodne profilowanie aplikacji KDE
321 - zestaw skryptów do poprawiania nagłówków informujących o licencji i
322   dyrektyw w plikach nagłówkowych KDE oraz usuwania nieistotnych
323   znaczników z plików .ui
324 - generator stron man dla KDE
325 - konwerter wieloramkowych PNG na MNG
326
327 %package scripts-cvs
328 Summary:        A set of scripts for maintaining KDE from CVS
329 Summary(pl.UTF-8):      Zestaw skryptów do zarządzania KDE z CVS
330 Group:          X11/Development/Tools
331 Requires:       /usr/bin/perl
332
333 %description scripts-cvs
334 A set of scripts for maintaining KDE from CVS.
335
336 %description scripts-cvs -l pl.UTF-8
337 Zestaw skryptów do zarządzania KDE z CVS.
338
339 %package scripts-doc
340 Summary:        A set of scripts for quick access to Qt/KDE documentation
341 Summary(pl.UTF-8):      Zestaw skryptów szybkiego dostępu do dokumentacji Qt/KDE
342 Group:          X11/Development/Tools
343
344 %description scripts-doc
345 A set of scripts for quick access to Qt/KDE documentation.
346
347 %description scripts-doc -l pl.UTF-8
348 Zestaw skryptów szybkiego dostępu do dokumentacji Qt/KDE.
349
350 %package scripts-kdekillall
351 Summary:        A script for killing KDE apps started with kdeinit
352 Summary(pl.UTF-8):      Skrypt do unicestwiania aplikacji KDE uruchomionych przez kdeinit
353 Group:          X11/Development/Tools
354
355 %description scripts-kdekillall
356 A script for killing KDE apps started with kdeinit.
357
358 %description scripts-kdekillall -l pl.UTF-8
359 Skrypt do unicestwiania aplikacji KDE uruchomionych przez kdeinit.
360
361 %package umbrello
362 Summary:        UML Modeler
363 Summary(pl.UTF-8):      Modeler UML
364 Group:          X11/Development/Tools
365 Obsoletes:      umbrello
366
367 %description umbrello
368 Umbrello UML Modeller is a UML diagram tool that can support you in
369 the software development process. Especially during the analysis and
370 design phases of this process, Umbrello UML Modeller will help you to
371 get a high quality product. UML can also be used to document your
372 software designs to help you and your fellow developers.
373
374 UML is the diagramming language used to describing such models. You
375 can represent your ideas in UML using different types of diagrams.
376 Umbrello UML Modeller 1.2 supports the following types:
377 - class Diagram
378 - sequence Diagram
379 - collaboration Diagram
380 - use Case Diagram
381 - state Diagram
382 - activity Diagram
383 - component Diagram
384
385 %description umbrello -l pl.UTF-8
386 Modeler UML Umbrello to narzędzie do diagramów UML pomagające w
387 procesie tworzenia oprogramowania. Szczególnie podczas etapów analizy
388 i projektowania, modeler UML Umbrello może pomóc w uzyskaniu wysokiej
389 jakości produktu. UML może być używany do dokumentowania projektu
390 programu, aby pomóc programiście i jego współpracownikom.
391
392 UML to język diagramów używany do opisu takich modeli. Można
393 przedstawiać idee w UML-u przy użyciu różnych rodzajów diagramów.
394 Modeler UML Umbrello 1.2 obsługuje następujące rodzaje:
395  - diagram klas
396  - diagram sekwencji
397  - diagram współpracy
398  - diagram przypadków użycia
399  - diagram stanów
400  - diagram aktywności
401  - diagram składników.
402
403 %package kpartloader
404 Summary:        UML Modeler
405 Summary(pl.UTF-8):      Modeler UML
406 Group:          X11/Development/Tools
407
408 %description kpartloader
409 UML Modeller
410
411 %description kpartloader -l pl.UTF-8
412 Modeler UML
413
414 %package strigi-analyzer
415 Summary:        Strigi Analyzer
416 Summary(pl.UTF-8):      Strigi Analyzer
417 Group:          X11/Development/Tools
418
419 %description strigi-analyzer
420 Strigi Analyzer.
421
422 %description strigi-analyzer -l pl.UTF-8
423 Strigi Analyzer.
424
425 %package -n kde-kio-slave
426 Summary:        kde-kio-slave
427 Summary(pl.UTF-8):      kde-kio-slave
428 Group:          X11/Libraries
429 Requires:       kde4-kdelibs >= %{version}
430
431 %description -n kde-kio-slave
432 kde-kio-slave.
433
434 %description -n kde-kio-slave -l pl.UTF-8
435 kde-kio-slave.
436
437 %package -n kde-kio-svn
438 Summary:        SVN protocol service
439 Summary(pl.UTF-8):      Obsługa protokołu SVN
440 Group:          X11/Libraries
441 Requires:       kde4-kdelibs >= %{version}
442
443 %description -n kde-kio-svn
444 SVN protocol service.
445
446 %description -n kde-kio-svn -l pl.UTF-8
447 Obsługa protokołu SVN.
448
449 %package okteta
450 Summary:        Binary file editor
451 Summary(pl.UTF-8):      Edytor plików binarnych
452 Group:          X11/Applications
453 Requires:       kde4-kdebase-workspace >= %{version}
454 Provides:       kde4-kdeutils-okteta
455 Obsoletes:      kde4-kdeutils-okteta
456
457 %description okteta
458 The program Okteta is another implementation of a standalone, plain
459 old-fashioned hex editor. It is based on the libkakao framework, with
460 plugins using the basic Okteta core and gui libraries.
461
462 %description okteta -l pl.UTF-8
463 Okteta to kolejna implementacja samodzielnego, tradycyjnego edytora
464 szesnastkowego. Jest oparty na szkielecie libkakao z wtyczkami
465 wykorzystującymi biblioteki core i gui Okteta.
466
467 %package devel
468 Summary:        Header files for compiling applications that use kdesdk libraries
469 Summary(pl.UTF-8):      Pliki nagłówkowe do kompilacji aplikacji używających bibliotek kdesdk
470 Summary(pt_BR.UTF-8):   Arquivos de inclusão para as bibliotecas do kdesdk
471 Group:          X11/Development/Libraries
472 Requires:       kde4-kdebase-devel >= %{version}
473 Requires:       kde4-kdesdk-okteta = %{version}-%{release}
474
475 %description devel
476 This package includes the header files you will need to compile
477 applications that use kdesdk libraries.
478
479 %description devel -l pl.UTF-8
480 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilacji aplikacji
481 używających bibliotek kdesdk.
482
483 %description devel -l pt_BR.UTF-8
484 Arquivos de inclusão para desenvolvimento e compilação de programas
485 que usem as bibliotecas do kdesdk.
486
487 %prep
488 %setup -q -n %{orgname}-%{version}
489 #%patch100 -p0
490 %patch0 -p0
491 %patch1 -p1
492
493 %build
494 install -d build
495 cd build
496 %cmake \
497         ../
498
499 %{__make}
500
501 %install
502 rm -rf $RPM_BUILD_ROOT
503
504 install -d $RPM_BUILD_ROOT{%{_gimpdir}/palettes,%{_appdefsdir}}
505
506 %{__make} -C build install \
507         DESTDIR=$RPM_BUILD_ROOT \
508         kde_htmldir=%{_kdedocdir}
509
510 rm -rf $RPM_BUILD_ROOT%{_iconsdir}/locolor
511
512 %find_lang      cervisia        --with-kde
513 %find_lang      kapptemplate    --with-kde
514 %find_lang      kcachegrind     --with-kde
515 %find_lang      kompare         --with-kde
516 %find_lang      lokalize        --with-kde
517 #%find_lang okteta             --with-kde
518 %find_lang      umbrello        --with-kde
519
520 %clean
521 rm -rf $RPM_BUILD_ROOT
522
523 %post   cervisia        -p /sbin/ldconfig
524 %postun cervisia        -p /sbin/ldconfig
525
526 %post   kmtrace         -p /sbin/ldconfig
527 %postun kmtrace         -p /sbin/ldconfig
528
529 %post   kompare         -p /sbin/ldconfig
530 %postun kompare         -p /sbin/ldconfig
531
532 %post   kstartperf      -p /sbin/ldconfig
533 %postun kstartperf      -p /sbin/ldconfig
534
535 %post   okteta          -p /sbin/ldconfig
536 %postun okteta          -p /sbin/ldconfig
537
538 %files cervisia -f cervisia.lang
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{_bindir}/cervisia
541 %attr(755,root,root) %{_bindir}/cvsaskpass
542 %attr(755,root,root) %{_bindir}/cvsservice
543 %attr(755,root,root) %{_libdir}/libkdeinit4_cervisia.so
544 %attr(755,root,root) %{_libdir}/libkdeinit4_cvsservice.so
545 %attr(755,root,root) %{_libdir}/libkdeinit4_cvsaskpass.so
546 %attr(755,root,root) %{_libdir}/kde4/*cervisia*.so
547 %{_datadir}/apps/cervisia*
548 %{_datadir}/config.kcfg/cervisiapart.kcfg
549 %{_datadir}/dbus-1/interfaces/*.cervisia.*.xml
550 %{_datadir}/kde4/services/cvsservice.desktop
551 %{_datadir}/kde4/services/cervisiapart.desktop
552 %{_desktopdir}/kde4/cervisia.desktop
553 %{_iconsdir}/*/*/actions/vcs-*-cvs-*.*
554 %{_iconsdir}/*/*/*/cervisia.png
555 %{_mandir}/man1/cervisia.1*
556
557 %files dolphin-plugins
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_libdir}/kde4/fileviewbazaarplugin.so
560 %attr(755,root,root) %{_libdir}/kde4/fileviewgitplugin.so
561 %attr(755,root,root) %{_libdir}/kde4/fileviewhgplugin.so
562 %attr(755,root,root) %{_libdir}/kde4/fileviewsvnplugin.so
563 %{_datadir}/config.kcfg/fileviewgitpluginsettings.kcfg
564 %{_datadir}/config.kcfg/fileviewhgpluginsettings.kcfg
565 %{_datadir}/config.kcfg/fileviewsvnpluginsettings.kcfg
566 %{_datadir}/kde4/services/fileviewbazaarplugin.desktop
567 %{_datadir}/kde4/services/fileviewgitplugin.desktop
568 %{_datadir}/kde4/services/fileviewhgplugin.desktop
569 %{_datadir}/kde4/services/fileviewsvnplugin.desktop
570
571 %files lokalize -f lokalize.lang
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_bindir}/lokalize
574 %attr(755,root,root) %{_libdir}/kde4/pothumbnail.so
575 %{_datadir}/apps/lokalize
576 %{_datadir}/config.kcfg/lokalize.kcfg
577 %{_datadir}/config.kcfg/pocreatorsettings.kcfg
578 %{_datadir}/kde4/services/pothumbnail.desktop
579 %{_desktopdir}/kde4/lokalize.desktop
580 %{_iconsdir}/*/*/actions/msgid2msgstr.png
581 %{_iconsdir}/*/*/actions/insert_arg.png
582 %{_iconsdir}/*/*/actions/prevfuzzy.png
583 %{_iconsdir}/*/*/actions/insert_tag.png
584 %{_iconsdir}/*/*/actions/approved.png
585 %{_iconsdir}/*/*/actions/diff.png
586 %{_iconsdir}/*/*/actions/preverror.png
587 %{_iconsdir}/*/*/actions/prevfuzzyuntrans.png
588 %{_iconsdir}/*/*/actions/prevpo.png
589 %{_iconsdir}/*/*/actions/prevtemplate.png
590 %{_iconsdir}/*/*/actions/search2msgstr.png
591 %{_iconsdir}/*/*/apps/lokalize.png
592 %{_iconsdir}/*/*/actions/nexterror.png
593 %{_iconsdir}/*/*/actions/nextfuzzy.png
594 %{_iconsdir}/*/*/actions/nextfuzzyuntrans.png
595 %{_iconsdir}/*/*/actions/nextpo.png
596 %{_iconsdir}/*/*/actions/nexttemplate.png
597 %{_iconsdir}/*/*/actions/nextuntranslated.png
598 %{_iconsdir}/*/*/actions/prevuntranslated.png
599 %{_iconsdir}/*/*/actions/transsearch.png
600 %{_iconsdir}/*/*/actions/catalogmanager.png
601 %{_iconsdir}/*/*/actions/approved.svgz
602 %{_iconsdir}/*/*/apps/lokalize.svgz
603
604 %files kapptemplate -f kapptemplate.lang
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_bindir}/kapptemplate
607 %{_datadir}/config.kcfg/kapptemplate.kcfg
608 %{_desktopdir}/kde4/kapptemplate.desktop
609 %dir %{_datadir}/apps/kdevappwizard
610 %{_datadir}/apps/kdevappwizard/templates
611 %{_datadir}/apps/kdevappwizard/template_previews
612 %{_iconsdir}/*/*x*/apps/kapptemplate.*
613
614 %files kcachegrind -f kcachegrind.lang
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_bindir}/kcachegrind
617 %attr(755,root,root) %{_bindir}/hotshot2calltree
618 %attr(755,root,root) %{_bindir}/op2calltree
619 %attr(755,root,root) %{_bindir}/pprof2calltree
620 %attr(755,root,root) %{_bindir}/dprof2calltree
621 %attr(755,root,root) %{_bindir}/memprof2calltree
622 %{_datadir}/apps/kcachegrind
623 %{_desktopdir}/kde4/kcachegrind.desktop
624 %{_iconsdir}/hicolor/*/apps/kcachegrind.png
625
626 %files kmtrace
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_bindir}/demangle
629 %attr(755,root,root) %{_bindir}/kminspector
630 %attr(755,root,root) %{_bindir}/kmmatch
631 %attr(755,root,root) %{_bindir}/kmtrace
632 %attr(755,root,root) %{_libdir}/libktrace*.so*
633 %{_datadir}/apps/kmtrace
634 %{_includedir}/ktrace.h
635 %{_mandir}/man1/demangle.1*
636
637 %files kompare -f kompare.lang
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_bindir}/kompare
640 %attr(755,root,root) %{_libdir}/libkompareinterface.so.*.*.*
641 %attr(755,root,root) %{_libdir}/libkompareinterface.so
642 %attr(755,root,root) %{_libdir}/libkomparedialogpages.so
643 %attr(755,root,root) %{_libdir}/libkomparediff2.so
644 %attr(755,root,root) %{_libdir}/kde4/komparenavtreepart.so
645 %attr(755,root,root) %{_libdir}/kde4/komparepart.so
646 %attr(755,root,root) %{_libdir}/libkomparediff2.so.*.*.*
647 %attr(755,root,root) %{_libdir}/libkompareinterface.so.?
648 %attr(755,root,root) %{_libdir}/libkomparedialogpages.so.*.*.*
649 %attr(755,root,root) %{_libdir}/libkomparedialogpages.so.?
650 %attr(755,root,root) %{_libdir}/libkomparediff2.so.?
651
652 %{_datadir}/apps/kompare*
653 %{_datadir}/kde4/services/kompare*.desktop
654 %{_datadir}/kde4/servicetypes/kompare*.desktop
655 %{_desktopdir}/kde4/kompare.desktop
656 %{_iconsdir}/*/*/*/kompare.*
657 %{_includedir}/kompare
658
659 %files kprofilemethod
660 %defattr(644,root,root,755)
661 %{_includedir}/kprofilemethod.h
662
663 %files kstartperf
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_bindir}/kstartperf
666 %attr(755,root,root) %{_libdir}/kde4/kstartperf.so
667
668 %files kuiviewer
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_bindir}/kuiviewer
671 %attr(755,root,root) %{_libdir}/kde4/quithumbnail.so
672 %attr(755,root,root) %{_libdir}/kde4/kuiviewerpart.so
673 %dir %{_datadir}/apps/kuiviewer
674 %{_datadir}/apps/kuiviewer/kuiviewerui.rc
675 %dir %{_datadir}/apps/kuiviewerpart
676 %{_datadir}/apps/kuiviewerpart/kuiviewer_part.rc
677 %{_datadir}/kde4/services/designerthumbnail.desktop
678 %{_datadir}/kde4/services/kuiviewer_part.desktop
679 %{_desktopdir}/kde4/kuiviewer.desktop
680 %{_iconsdir}/*/*/apps/kuiviewer.png
681
682 %files po2xml
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_bindir}/po2xml
685 %attr(755,root,root) %{_bindir}/split2po
686 %attr(755,root,root) %{_bindir}/swappo
687 %attr(755,root,root) %{_bindir}/xml2pot
688 %{_mandir}/man1/po2xml.1*
689 %{_mandir}/man1/split2po.1*
690 %{_mandir}/man1/xml2pot.1*
691 %{_mandir}/man1/swappo.1*
692
693 %files scripts-developer
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_bindir}/adddebug
696 %attr(755,root,root) %{_bindir}/build-progress.sh
697 %attr(755,root,root) %{_bindir}/create*
698 %attr(755,root,root) %{_bindir}/cheatmake
699 %attr(755,root,root) %{_bindir}/extend*
700 %attr(755,root,root) %{_bindir}/extractattr
701 %attr(755,root,root) %{_bindir}/fixkdeincludes
702 %attr(755,root,root) %{_bindir}/fixuifiles
703 %attr(755,root,root) %{_bindir}/includemocs
704 %attr(755,root,root) %{_bindir}/kdemangen.pl
705 %attr(755,root,root) %{_bindir}/krazy-licensecheck
706 %attr(755,root,root) %{_bindir}/makeobj
707 %attr(755,root,root) %{_bindir}/png2mng.pl
708 %attr(755,root,root) %{_bindir}/cxxmetric
709 %attr(755,root,root) %{_bindir}/extractrc
710 %attr(755,root,root) %{_bindir}/findmissingcrystal
711 %attr(755,root,root) %{_bindir}/kdelnk2desktop.py
712 %attr(755,root,root) %{_bindir}/package_crystalsvg
713 %attr(755,root,root) %{_bindir}/zonetab2pot.py
714 %attr(755,root,root) %{_bindir}/fix-include.sh
715 %attr(755,root,root) %{_bindir}/kde_generate_export_header
716 %attr(755,root,root) %{_bindir}/optimizegraphics
717 %attr(755,root,root) %{_bindir}/wcgrep
718 %{_mandir}/man1/adddebug.1*
719 %{_mandir}/man1/cheatmake.1*
720 %{_mandir}/man1/create*.1*
721 %{_mandir}/man1/cxxmetric.1*
722 %{_mandir}/man1/extend*.1*
723 %{_mandir}/man1/extractrc.1*
724 %{_mandir}/man1/zonetab2pot.py.1*
725
726 %files scripts-cvs
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_bindir}/cvs*
729 %exclude %{_bindir}/cvsaskpass
730 %exclude %{_bindir}/cvsservice
731 %attr(755,root,root) %{_bindir}/noncvslist
732 %attr(755,root,root) %{_bindir}/pruneemptydirs
733 %{_mandir}/man1/cvs*.1*
734 %{_mandir}/man1/pruneemptydirs.1*
735
736 %files scripts-doc
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_bindir}/kdedoc
739 %attr(755,root,root) %{_bindir}/qtdoc
740 %{_mandir}/man1/qtdoc.1*
741
742 %files scripts-kdekillall
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_bindir}/kdekillall
745
746 %files umbrello -f umbrello.lang
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_bindir}/umbrello
749 %{_datadir}/apps/umbrello
750 %{_desktopdir}/kde4/umbrello.desktop
751 %{_iconsdir}/*/*x*/*/umbrello*.*
752 %{_iconsdir}/*/*/mimetypes/application-x-uml.png
753
754 %files kpartloader
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_bindir}/kpartloader
757 %dir %{_datadir}/apps/kpartloader
758 %{_datadir}/apps/kpartloader/kpartloaderui.rc
759
760 %files strigi-analyzer
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_libdir}/strigi/strigila_diff.so
763 %attr(755,root,root) %{_libdir}/strigi/strigita_ts.so
764 %attr(755,root,root) %{_libdir}/strigi/strigila_po.so
765 %attr(755,root,root) %{_libdir}/strigi/strigita_xlf.so
766 %{_datadir}/strigi/fieldproperties/strigi_translation.fieldproperties
767
768 %files -n kde-kio-svn
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_bindir}/*svn*
771 %exclude %{_bindir}/create_svnignore
772 %attr(755,root,root) %{_libdir}/kde4/kio_svn.so
773 %attr(755,root,root) %{_libdir}/kde4/kded_ksvnd.so
774 %{_datadir}/kde4/services/kded/*svn*.desktop
775 %{_datadir}/kde4/services/ServiceMenus/subversion*.desktop
776 %{_datadir}/kde4/services/svn*.protocol
777 %{_datadir}/dbus-1/interfaces/org.kde.ksvnd.xml
778 %{_iconsdir}/*/*/*/*svn*.*
779
780 %files -n kde-kio-slave
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{_libdir}/kde4/kio_perldoc.so
783 %dir %{_datadir}/apps/kio_perldoc
784 %{_datadir}/apps/kio_perldoc/pod2html.pl
785 %{_datadir}/kde4/services/perldoc.protocol
786
787 %files okteta
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_bindir}/okteta
790 %attr(755,root,root) %{_libdir}/kde4/libkbytearrayedit.so
791 %attr(755,root,root) %{_libdir}/kde4/oktetapart.so
792 %attr(755,root,root) %ghost %{_libdir}/libokteta1core.so.?
793 %attr(755,root,root) %{_libdir}/libokteta1core.so.*.*.*
794 %attr(755,root,root) %ghost %{_libdir}/libokteta1gui.so.?
795 %attr(755,root,root) %{_libdir}/libokteta1gui.so.*.*.*
796 %attr(755,root,root) %ghost %{_libdir}/libkasten2okteta1core.so.?
797 %attr(755,root,root) %{_libdir}/libkasten2okteta1core.so.*.*.*
798 %attr(755,root,root) %ghost %{_libdir}/libkasten2okteta1controllers.so.?
799 %attr(755,root,root) %{_libdir}/libkasten2okteta1controllers.so.*.*.*
800 %attr(755,root,root) %ghost %{_libdir}/libkasten2okteta1gui.so.?
801 %attr(755,root,root) %{_libdir}/libkasten2okteta1gui.so.*.*.*
802 %attr(755,root,root) %{_libdir}/kde4/plugins/designer/oktetadesignerplugin.so
803 %{_desktopdir}/kde4/okteta.desktop
804 %dir %{_datadir}/apps/oktetapart
805 %{_datadir}/apps/oktetapart/oktetapartbrowserui.rc
806 %{_datadir}/apps/oktetapart/oktetapartreadonlyui.rc
807 %{_datadir}/apps/oktetapart/oktetapartreadwriteui.rc
808 %{_datadir}/apps/okteta
809 %{_iconsdir}/hicolor/*x*/apps/okteta.png
810 %{_datadir}/kde4/services/kbytearrayedit.desktop
811 %{_datadir}/kde4/services/oktetapart.desktop
812 %{_kdedocdir}/en/okteta
813 %{_datadir}/mime/packages/okteta.xml
814 %{_datadir}/config/okteta-structures.knsrc
815 %{_datadir}/config.kcfg/structviewpreferences.kcfg
816 #kasten
817 %attr(755,root,root) %ghost %{_libdir}/libkasten2core.so.?
818 %attr(755,root,root) %{_libdir}/libkasten2core.so.*.*.*
819 %attr(755,root,root) %ghost %{_libdir}/libkasten2controllers.so.?
820 %attr(755,root,root) %{_libdir}/libkasten2controllers.so.*.*.*
821 %attr(755,root,root) %ghost %{_libdir}/libkasten2gui.so.?
822 %attr(755,root,root) %{_libdir}/libkasten2gui.so.*.*.*
823
824 %files devel
825 %defattr(644,root,root,755)
826 %attr(755,root,root) %{_bindir}/struct2osd.sh
827 %attr(755,root,root) %{_libdir}/libokteta1gui.so
828 %attr(755,root,root) %{_libdir}/libokteta1core.so
829 %attr(755,root,root) %{_libdir}/libkasten2controllers.so
830 %attr(755,root,root) %{_libdir}/libkasten2core.so
831 %attr(755,root,root) %{_libdir}/libkasten2gui.so
832 %attr(755,root,root) %{_libdir}/libkasten2okteta1controllers.so
833 %attr(755,root,root) %{_libdir}/libkasten2okteta1core.so
834 %attr(755,root,root) %{_libdir}/libkasten2okteta1gui.so
835
836 %{_includedir}/KDE/Kasten2
837 %{_includedir}/KDE/Okteta1
838 %{_includedir}/kasten2
839 %{_includedir}/okteta1
This page took 0.519362 seconds and 2 git commands to generate.