]> git.pld-linux.org Git - packages/kde4-kdebase-runtime.git/blob - kde4-kdebase-runtime.spec
- rel up for rebuild agains g++-11.2.0
[packages/kde4-kdebase-runtime.git] / kde4-kdebase-runtime.spec
1 #
2 # Conditional build:
3 %bcond_without  ntrack          # network status tracking
4
5 %define         _state          stable
6 %define         orgname         kde-runtime
7 %define         qt_ver          4.8.3
8 %define         attica_ver      0.4.0
9 %define         kactivities_ver 4.13.0
10
11 Summary:        KDE 4 base runtime components
12 Summary(pl.UTF-8):      Komponenty uruchomieniowe podstawowej części KDE 4
13 Name:           kde4-kdebase-runtime
14 Version:        4.14.3
15 Release:        16
16 License:        GPL v2+
17 Group:          X11/Applications
18 Source0:        http://download.kde.org/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
19 # Source0-md5:  fbba547e4446b51702e5de8bcae078d5
20 Source1:        kdebase-searchproviders.tar.bz2
21 # Source1-md5:  126c3524b5367f5096a628acbf9dc86f
22 Source2:        l10n-iso639-1
23 Patch100:       %{name}-branch.diff
24 Patch0:         %{name}-rpc.patch
25 Patch1:         moc.patch
26 Patch2:         %{name}-exiv2.patch
27 Patch3:         smbclient-detection.patch
28 URL:            http://www.kde.org/
29 BuildRequires:  NetworkManager-devel >= 0.7.0
30 BuildRequires:  OpenEXR-devel
31 BuildRequires:  alsa-lib-devel
32 BuildRequires:  attica-devel >= %{attica_ver}
33 BuildRequires:  automoc4 >= 0.9.88
34 BuildRequires:  bzip2-devel
35 BuildRequires:  clucene-core-devel >= 0.9.21
36 BuildRequires:  cmake >= 2.8.0
37 BuildRequires:  docbook-dtd42-xml
38 BuildRequires:  docbook-style-xsl
39 BuildRequires:  exiv2-devel >= 0.18.2
40 BuildRequires:  glib2-devel >= 2.0
41 BuildRequires:  gpgme-devel
42 BuildRequires:  kde4-kactivities-devel >= %{kactivities_ver}
43 BuildRequires:  kde4-kdelibs-devel >= %{version}
44 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
45 BuildRequires:  kde4-nepomuk-core-devel >= %{version}
46 BuildRequires:  libcanberra-devel
47 BuildRequires:  libgcrypt-devel >= 1.5.0
48 BuildRequires:  libjpeg-devel
49 BuildRequires:  libsmbclient-devel
50 BuildRequires:  libssh-devel >= 1:0.6.0
51 BuildRequires:  libtirpc-devel
52 BuildRequires:  libwebp-devel
53 %{?with_ntrack:BuildRequires:   ntrack-qt4-devel}
54 BuildRequires:  openslp-devel
55 BuildRequires:  phonon-devel >= 4.4.57
56 BuildRequires:  pkgconfig
57 BuildRequires:  pulseaudio-devel >= 0.9.16
58 BuildRequires:  qca-devel >= 2.0.0
59 BuildRequires:  qt4-build >= %{qt_ver}
60 BuildRequires:  rpmbuild(macros) >= 1.600
61 BuildRequires:  shared-desktop-ontologies-devel >= 0.7.1
62 BuildRequires:  shared-mime-info
63 BuildRequires:  soprano-devel >= 2.6.51
64 BuildRequires:  tar >= 1:1.22
65 BuildRequires:  xorg-lib-libXcursor-devel
66 BuildRequires:  xz
67 BuildRequires:  xz-devel
68 Requires:       attica >= %{attica_ver}
69 Requires:       exiv2-libs >= 0.18.2
70 Requires:       filesystem >= 4.1-15
71 Requires:       kde4-kactivities >= %{kactivities_ver}
72 Requires:       kde4-kdelibs >= %{version}
73 Requires:       kde4-kdepimlibs >= %{version}
74 Requires:       kde4-nepomuk-core >= %{version}
75 Requires:       libgcrypt >= 1.5.0
76 Requires:       libssh >= 1:0.6.0
77 Requires:       phonon >= 4.4.57
78 Requires:       pulseaudio-libs >= 0.9.16
79 Provides:       dbus(org.freedesktop.Notifications)
80 Obsoletes:      kdebase4-runtime
81 Conflicts:      kdebase4-runtime
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %description
85 KDE 4 runtime components.
86
87 %description -l pl.UTF-8
88 Komponenty uruchomieniowe podstawowej części KDE 4.
89
90 %package devel
91 Summary:        Development files for KDE 4 runtime components
92 Summary(pl.UTF-8):      Pliki programistyczne komponentów uruchomieniowych KDE 4
93 Group:          X11/Development/Libraries
94 Requires:       %{name} = %{version}-%{release}
95 Requires:       kde4-kdelibs-devel >= %{version}
96
97 %description devel
98 Development files for KDE 4 runtime components.
99
100 %description devel -l pl.UTF-8
101 Pliki programistyczne komponentów uruchomieniowych KDE 4.
102
103 %package -n kde4-phonon
104 Summary:        KDE 4 Phonon plugins
105 Summary(pl.UTF-8):      Wtyczki KDE 4 dla Phonona
106 Group:          X11/Applications
107 Requires:       phonon >= 4.4.57
108
109 %description -n kde4-phonon
110 KDE 4 Phonon plugins.
111
112 %description -n kde4-phonon -l pl.UTF-8
113 Wtyczki KDE 4 dla Phonona.
114
115 %prep
116 %setup -q -n %{orgname}-%{version} -a1
117 #%patch100 -p1
118 %patch0 -p1
119 %patch1 -p1
120 %patch2 -p1
121 %patch3 -p1
122
123 %build
124 install -d build
125 cd build
126 CFLAGS="%{rpmcflags} $(pkg-config --cflags libtirpc)"
127 CXXFLAGS="%{rpmcxxflags} $(pkg-config --cflags libtirpc)"
128 %cmake \
129         %{!?with_ntrack:-DQNTRACK=BOOL:FALSE} \
130         -DLIBEXEC_INSTALL_DIR=%{_libdir}/kde4/libexec \
131         ../
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} -C build install \
139         DESTDIR=$RPM_BUILD_ROOT \
140         kde_htmldir=%{_kdedocdir}
141
142 install -d $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
143 cp -a kdebase-searchproviders/*.desktop $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
144
145 # l10n dir contains per-country (ISO-3166 alpha2 indexed) localization; rpm uses per-language (ISO-639 alpha2 or alpha3) tags
146 collect_l10n_files() {
147         while read country language comment; do
148                 [ "$country" != "#" ] || continue
149                 if [ "$language" = "-" ]; then
150                         # no mapping. just add for now
151                         echo >&2 "No mapping for $country $comment, adding without %%lang tag"
152                         echo "%{_datadir}/locale/l10n/$country"
153                 else
154                         echo "%lang($language) %{_datadir}/locale/l10n/$country"
155                 fi
156         done
157 } < %{SOURCE2}
158 collect_l10n_files > %{name}.files
159
160 %{__rm} $RPM_BUILD_ROOT%{_datadir}/icons/default.kde4
161 # provided (conflicts) by hicolor-icon-theme
162 %{__rm} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post   -p /sbin/ldconfig
168 %postun -p /sbin/ldconfig
169
170 %files -f %{name}.files
171 %defattr(644,root,root,755)
172 %{_sysconfdir}/xdg/menus/kde-information.menu
173 %attr(755,root,root) %{_bindir}/kcmshell4
174 %attr(755,root,root) %{_bindir}/kde-cp
175 %attr(755,root,root) %{_bindir}/kde-mv
176 %attr(755,root,root) %{_bindir}/kde-open
177 %attr(755,root,root) %{_bindir}/kde4-menu
178 %attr(755,root,root) %{_bindir}/kdebugdialog
179 %attr(755,root,root) %{_bindir}/kfile4
180 %attr(755,root,root) %{_bindir}/kiconfinder
181 %attr(755,root,root) %{_bindir}/khelpcenter
182 %attr(755,root,root) %{_bindir}/khotnewstuff4
183 %attr(755,root,root) %{_bindir}/khotnewstuff-upload
184 %attr(755,root,root) %{_bindir}/kioclient
185 %attr(755,root,root) %{_bindir}/kmimetypefinder
186 %attr(755,root,root) %{_bindir}/knotify4
187 %attr(755,root,root) %{_bindir}/kquitapp
188 %attr(755,root,root) %{_bindir}/kreadconfig
189 %attr(755,root,root) %{_bindir}/kstart
190 %attr(755,root,root) %{_bindir}/kde4
191 %attr(755,root,root) %{_bindir}/kwalletd
192 %attr(755,root,root) %{_bindir}/ksvgtopng
193 %attr(755,root,root) %{_bindir}/keditfiletype
194 %attr(755,root,root) %{_bindir}/kglobalaccel
195 %attr(755,root,root) %{_bindir}/ktraderclient
196 %attr(755,root,root) %{_bindir}/ktrash
197 %attr(755,root,root) %{_bindir}/kuiserver
198 %attr(755,root,root) %{_bindir}/kwriteconfig
199 %attr(755,root,root) %{_bindir}/solid-hardware
200 %attr(755,root,root) %{_bindir}/plasma-remote-helper
201 %attr(755,root,root) %{_bindir}/plasmapkg
202 %attr(755,root,root) %{_libdir}/attica_kde.so
203 %attr(755,root,root) %{_libdir}/libkdeinit4_kcmshell4.so
204 %attr(755,root,root) %{_libdir}/libkdeinit4_khelpcenter.so
205 %attr(755,root,root) %{_libdir}/libkdeinit4_kuiserver.so
206 %attr(755,root,root) %{_libdir}/libkdeinit4_kwalletd.so
207 %attr(755,root,root) %{_libdir}/libkdeinit4_kglobalaccel.so
208 %attr(755,root,root) %{_libdir}/libknotifyplugin.so
209 # Is it ok to add those files to main package?
210 %attr(755,root,root) %ghost %{_libdir}/libkwalletbackend.so.4
211 %attr(755,root,root) %{_libdir}/libkwalletbackend.so.*.*.*
212 %attr(755,root,root) %ghost %{_libdir}/libmolletnetwork.so.4
213 %attr(755,root,root) %{_libdir}/libmolletnetwork.so.4.*.*
214 %attr(755,root,root) %{_libdir}/kde4/comicbookthumbnail.so
215 %attr(755,root,root) %{_libdir}/kde4/cursorthumbnail.so
216 %attr(755,root,root) %{_libdir}/kde4/djvuthumbnail.so
217 %attr(755,root,root) %{_libdir}/kde4/exrthumbnail.so
218 %attr(755,root,root) %{_libdir}/kde4/htmlthumbnail.so
219 %attr(755,root,root) %{_libdir}/kde4/imagethumbnail.so
220 %attr(755,root,root) %{_libdir}/kde4/jpegthumbnail.so
221 %attr(755,root,root) %{_libdir}/kde4/kcm_cgi.so
222 %attr(755,root,root) %{_libdir}/kde4/kcm_componentchooser.so
223 %attr(755,root,root) %{_libdir}/kde4/kcm_device_automounter.so
224 %attr(755,root,root) %{_libdir}/kde4/kcm_emoticons.so
225 %attr(755,root,root) %{_libdir}/kde4/kcm_filetypes.so
226 %attr(755,root,root) %{_libdir}/kde4/kcm_icons.so
227 %attr(755,root,root) %{_libdir}/kde4/kcm_kded.so
228 %attr(755,root,root) %{_libdir}/kde4/kcm_kdnssd.so
229 %attr(755,root,root) %{_libdir}/kde4/kcm_knotify.so
230 %attr(755,root,root) %{_libdir}/kde4/kcm_locale.so
231 %attr(755,root,root) %{_libdir}/kde4/kcm_trash.so
232 %attr(755,root,root) %{_libdir}/kde4/kded_device_automounter.so
233 %attr(755,root,root) %{_libdir}/kde4/kded_kpasswdserver.so
234 %attr(755,root,root) %{_libdir}/kde4/kded_ktimezoned.so
235 %attr(755,root,root) %{_libdir}/kde4/kded_remotedirnotify.so
236 %attr(755,root,root) %{_libdir}/kde4/kded_soliduiserver.so
237 %attr(755,root,root) %{_libdir}/kde4/kded_desktopnotifier.so
238 %attr(755,root,root) %{_libdir}/kde4/kded_networkstatus.so
239 %attr(755,root,root) %{_libdir}/kde4/kded_networkwatcher.so
240 %attr(755,root,root) %{_libdir}/kde4/kded_recentdocumentsnotifier.so
241 %attr(755,root,root) %{_libdir}/kde4/kded_solidautoeject.so
242 %attr(755,root,root) %{_libdir}/kde4/kio_applications.so
243 %attr(755,root,root) %{_libdir}/kde4/kio_bookmarks.so
244 %attr(755,root,root) %{_libdir}/kde4/kio_desktop.so
245 %attr(755,root,root) %{_libdir}/kde4/kio_about.so
246 %attr(755,root,root) %{_libdir}/kde4/kio_archive.so
247 %attr(755,root,root) %{_libdir}/kde4/kio_cgi.so
248 %attr(755,root,root) %{_libdir}/kde4/kio_filter.so
249 %attr(755,root,root) %{_libdir}/kde4/kio_finger.so
250 %attr(755,root,root) %{_libdir}/kde4/kio_fish.so
251 %attr(755,root,root) %{_libdir}/kde4/kio_floppy.so
252 %attr(755,root,root) %{_libdir}/kde4/kio_info.so
253 %attr(755,root,root) %{_libdir}/kde4/kio_man.so
254 %attr(755,root,root) %{_libdir}/kde4/kio_network.so
255 %attr(755,root,root) %{_libdir}/kde4/kio_nfs.so
256 %attr(755,root,root) %{_libdir}/kde4/kio_recentdocuments.so
257 %attr(755,root,root) %{_libdir}/kde4/kio_remote.so
258 %attr(755,root,root) %{_libdir}/kde4/kio_settings.so
259 %attr(755,root,root) %{_libdir}/kde4/kio_sftp.so
260 %attr(755,root,root) %{_libdir}/kde4/kio_smb.so
261 %attr(755,root,root) %{_libdir}/kde4/kio_thumbnail.so
262 %attr(755,root,root) %{_libdir}/kde4/kio_trash.so
263 %attr(755,root,root) %{_libdir}/kde4/libkmanpart.so
264 %attr(755,root,root) %{_libdir}/kde4/fixhosturifilter.so
265 %attr(755,root,root) %{_libdir}/kde4/kcm_attica.so
266 %attr(755,root,root) %{_libdir}/kde4/kcmspellchecking.so
267 %attr(755,root,root) %{_libdir}/kde4/kshorturifilter.so
268 %attr(755,root,root) %{_libdir}/kde4/kuriikwsfilter.so
269 %attr(755,root,root) %{_libdir}/kde4/kurisearchfilter.so
270 %attr(755,root,root) %{_libdir}/kde4/localdomainurifilter.so
271 %attr(755,root,root) %{_libdir}/kde4/librenaudioplugin.so
272 %attr(755,root,root) %{_libdir}/kde4/librenimageplugin.so
273 %attr(755,root,root) %{_libdir}/kde4/plasma-kpart.so
274 %attr(755,root,root) %{_libdir}/kde4/plasma_appletscript_declarative.so
275 %attr(755,root,root) %{_libdir}/kde4/plasma_appletscript_simple_javascript.so
276 %attr(755,root,root) %{_libdir}/kde4/plasma_containment_newspaper.so
277 %attr(755,root,root) %{_libdir}/kde4/plasma_dataenginescript_javascript.so
278 %attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_javascriptaddon.so
279 %attr(755,root,root) %{_libdir}/kde4/plasma_runnerscript_javascript.so
280 %attr(755,root,root) %{_libdir}/kde4/svgthumbnail.so
281 %attr(755,root,root) %{_libdir}/kde4/textthumbnail.so
282 %attr(755,root,root) %{_libdir}/kde4/windowsexethumbnail.so
283 %attr(755,root,root) %{_libdir}/kde4/windowsimagethumbnail.so
284
285 %attr(755,root,root) %{_libdir}/kde4/imports
286
287 %attr(755,root,root) %{_libdir}/kde4/plugins/imageformats/kimg_webp.so
288
289 %attr(755,root,root) %{_libdir}/kde4/libexec/drkonqi
290 %attr(755,root,root) %{_libdir}/kde4/libexec/kdeeject
291 %attr(755,root,root) %{_libdir}/kde4/libexec/kdesu
292 %attr(755,root,root) %{_libdir}/kde4/libexec/kdesud
293 %attr(755,root,root) %{_libdir}/kde4/libexec/kdontchangethehostname
294 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_docbookdig.pl
295 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_htdig.pl
296 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_htsearch.pl
297 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_indexbuilder
298 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_mansearch.pl
299 %attr(755,root,root) %{_libdir}/kde4/libexec/kioexec
300 %attr(755,root,root) %{_libdir}/kde4/libexec/knetattach
301 %attr(755,root,root) %{_libdir}/kde4/libexec/kcmremotewidgetshelper
302 %{_libdir}/kde4/platformimports
303 %{_sysconfdir}/dbus-1/system.d/org.kde.kcontrol.kcmremotewidgets.conf
304 %{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
305 # top desktoptheme dirs owned by kdelibs
306 %{_datadir}/apps/desktoptheme/default/dialogs
307 %{_datadir}/apps/desktoptheme/default/icons
308 %{_datadir}/apps/desktoptheme/default/opaque
309 %{_datadir}/apps/desktoptheme/default/toolbar-icons
310 %{_datadir}/apps/desktoptheme/default/translucent
311 %{_datadir}/apps/desktoptheme/default/widgets
312 %{_datadir}/apps/desktoptheme/default/colors
313 %{_datadir}/apps/desktoptheme/default/metadata.desktop
314 %{_datadir}/apps/desktoptheme/oxygen
315 %{_datadir}/apps/desktoptheme/appdashboard
316 %{_datadir}/apps/drkonqi
317 %{_datadir}/apps/hardwarenotifications
318 %dir %{_datadir}/apps/kcm_componentchooser
319 %{_datadir}/apps/kcm_componentchooser/kcm_browser.desktop
320 %{_datadir}/apps/kcm_componentchooser/kcm_filemanager.desktop
321 %{_datadir}/apps/kcm_componentchooser/kcm_kemail.desktop
322 %{_datadir}/apps/kcm_componentchooser/kcm_terminal.desktop
323 %{_datadir}/apps/kcm_componentchooser/kcm_wm.desktop
324 %{_datadir}/apps/kcmlocale
325 %{_datadir}/apps/kconf_update/drkonqi-rename-config-section.upd
326 %{_datadir}/apps/kconf_update/kuriikwsfilter.upd
327 %{_datadir}/apps/kconf_update/kwallet-4.13.upd
328 %{_datadir}/apps/kde/kde.notifyrc
329 %dir %{_datadir}/apps/kglobalaccel
330 %{_datadir}/apps/kglobalaccel/kglobalaccel.notifyrc
331 %{_datadir}/apps/khelpcenter
332 %{_datadir}/apps/kio_bookmarks
333 %{_datadir}/apps/kio_desktop
334 %{_datadir}/apps/kio_docfilter
335 %{_datadir}/apps/kio_finger
336 %{_datadir}/apps/kio_info
337 %dir %{_datadir}/apps/konqueror/dirtree
338 %dir %{_datadir}/apps/konqueror/dirtree/remote
339 %{_datadir}/apps/konqueror/dirtree/remote/smb-network.desktop
340 %dir %{_datadir}/apps/konqsidebartng
341 %dir %{_datadir}/apps/konqsidebartng/virtual_folders
342 %dir %{_datadir}/apps/konqsidebartng/virtual_folders/remote
343 %{_datadir}/apps/konqsidebartng/virtual_folders/remote/virtualfolder_network.desktop
344 %dir %{_datadir}/apps/ksmserver
345 %dir %{_datadir}/apps/ksmserver/windowmanagers
346 %{_datadir}/apps/ksmserver/windowmanagers/compiz-custom.desktop
347 %{_datadir}/apps/ksmserver/windowmanagers/compiz.desktop
348 %{_datadir}/apps/ksmserver/windowmanagers/metacity.desktop
349 %{_datadir}/apps/ksmserver/windowmanagers/openbox.desktop
350 %{_datadir}/apps/kwalletd
351 %dir %{_datadir}/apps/remoteview
352 %{_datadir}/apps/remoteview/network.desktop
353 %{_datadir}/apps/remoteview/smb-network.desktop
354 %{_datadir}/config.kcfg/khelpcenter.kcfg
355 %{_datadir}/config.kcfg/jpegcreatorsettings.kcfg
356 %{_datadir}/config/khotnewstuff.knsrc
357 %{_datadir}/config/icons.knsrc
358 %{_datadir}/config/emoticons.knsrc
359 %{_datadir}/config/kshorturifilterrc
360 %{_datadir}/config/khotnewstuff_upload.knsrc
361 %{_datadir}/dbus-1/services/org.kde.knotify.service
362 %{_datadir}/dbus-1/services/org.kde.kuiserver.service
363 # xml files to -devel (or have some runtime users?)
364 %{_datadir}/dbus-1/interfaces/org.kde.KTimeZoned.xml
365 %{_datadir}/dbus-1/interfaces/org.kde.khelpcenter.kcmhelpcenter.xml
366 %{_datadir}/dbus-1/interfaces/org.kde.network.kioslavenotifier.xml
367 %{_datadir}/dbus-1/system-services/org.kde.kcontrol.kcmremotewidgets.service
368 %{_datadir}/emoticons/kde4
369 %{_datadir}/kde4/services/qimageioplugins/webp.desktop
370 %{_datadir}/kde4/services/about.protocol
371 %{_datadir}/kde4/services/applications.protocol
372 %{_datadir}/kde4/services/ar.protocol
373 %{_datadir}/kde4/services/kcm_attica.desktop
374 %{_datadir}/kde4/services/bookmarks.protocol
375 %{_datadir}/kde4/services/bzip.protocol
376 %{_datadir}/kde4/services/bzip2.protocol
377 %{_datadir}/kde4/services/cgi.protocol
378 %{_datadir}/kde4/services/comicbookthumbnail.desktop
379 %{_datadir}/kde4/services/componentchooser.desktop
380 %{_datadir}/kde4/services/cursorthumbnail.desktop
381 %{_datadir}/kde4/services/device_automounter_kcm.desktop
382 %{_datadir}/kde4/services/djvuthumbnail.desktop
383 %{_datadir}/kde4/services/emoticons.desktop
384 %{_datadir}/kde4/services/exrthumbnail.desktop
385 %{_datadir}/kde4/services/finger.protocol
386 %{_datadir}/kde4/services/fish.protocol
387 %{_datadir}/kde4/services/fixhosturifilter.desktop
388 %{_datadir}/kde4/services/floppy.protocol
389 %{_datadir}/kde4/services/gzip.protocol
390 %{_datadir}/kde4/services/htmlthumbnail.desktop
391 %{_datadir}/kde4/services/icons.desktop
392 %{_datadir}/kde4/services/imagethumbnail.desktop
393 %{_datadir}/kde4/services/info.protocol
394 %{_datadir}/kde4/services/jpegthumbnail.desktop
395 %{_datadir}/kde4/services/kcm_kdnssd.desktop
396 %{_datadir}/kde4/services/kcmcgi.desktop
397 %{_datadir}/kde4/services/kcmkded.desktop
398 %{_datadir}/kde4/services/kcmnotify.desktop
399 %{_datadir}/kde4/services/kcmtrash.desktop
400 %{_datadir}/kde4/services/kded/device_automounter.desktop
401 %{_datadir}/kde4/services/kded/kpasswdserver.desktop
402 %{_datadir}/kde4/services/kded/ktimezoned.desktop
403 %{_datadir}/kde4/services/kded/networkstatus.desktop
404 %{_datadir}/kde4/services/kded/remotedirnotify.desktop
405 %{_datadir}/kde4/services/kded/soliduiserver.desktop
406 %{_datadir}/kde4/services/khelpcenter.desktop
407 %{_datadir}/kde4/services/kmanpart.desktop
408 %{_datadir}/kde4/services/knotify4.desktop
409 %{_datadir}/kde4/services/kshorturifilter.desktop
410 %{_datadir}/kde4/services/kuiserver.desktop
411 %{_datadir}/kde4/services/kuriikwsfilter.desktop
412 %{_datadir}/kde4/services/kurisearchfilter.desktop
413 %{_datadir}/kde4/services/kwalletd.desktop
414 %{_datadir}/kde4/services/language.desktop
415 %{_datadir}/kde4/services/localdomainurifilter.desktop
416 %{_datadir}/kde4/services/lzma.protocol
417 %{_datadir}/kde4/services/man.protocol
418 %{_datadir}/kde4/services/nfs.protocol
419 %{_datadir}/kde4/services/programs.protocol
420 %{_datadir}/kde4/services/remote.protocol
421 %{_datadir}/kde4/services/renaudiodlg.desktop
422 %{_datadir}/kde4/services/renimagedlg.desktop
423 %{_datadir}/kde4/services/searchproviders
424 %{_datadir}/kde4/services/settings.protocol
425 %{_datadir}/kde4/services/sftp.protocol
426 %{_datadir}/kde4/services/smb.protocol
427 %{_datadir}/kde4/services/spellchecking.desktop
428 %{_datadir}/kde4/services/svgthumbnail.desktop
429 %{_datadir}/kde4/services/tar.protocol
430 %{_datadir}/kde4/services/textthumbnail.desktop
431 %{_datadir}/kde4/services/thumbnail.protocol
432 %{_datadir}/kde4/services/trash.protocol
433 %{_datadir}/kde4/services/zip.protocol
434 %{_datadir}/kde4/services/xz.protocol
435 %{_datadir}/kde4/services/desktop.protocol
436 %{_datadir}/kde4/services/kded/desktopnotifier.desktop
437 %{_datadir}/kde4/services/desktopthumbnail.desktop
438 %{_datadir}/kde4/services/directorythumbnail.desktop
439 %{_datadir}/kde4/services/filetypes.desktop
440 %{_datadir}/kde4/services/kded/networkwatcher.desktop
441 %{_datadir}/kde4/services/kded/solidautoeject.desktop
442 %{_datadir}/kde4/services/kded/recentdocumentsnotifier.desktop
443 %{_datadir}/kde4/services/kglobalaccel.desktop
444 %{_datadir}/kde4/services/network.protocol
445 %{_datadir}/kde4/services/plasma-containment-newspaper.desktop
446 %{_datadir}/kde4/services/plasma-kpart.desktop
447 %{_datadir}/kde4/services/plasma-packagestructure-javascript-addon.desktop
448 %{_datadir}/kde4/services/plasma-scriptengine-applet-declarative.desktop
449 %{_datadir}/kde4/services/plasma-scriptengine-applet-simple-javascript.desktop
450 %{_datadir}/kde4/services/plasma-scriptengine-dataengine-javascript.desktop
451 %{_datadir}/kde4/services/plasma-scriptengine-runner-javascript.desktop
452 %{_datadir}/kde4/services/recentdocuments.protocol
453 %{_datadir}/kde4/services/windowsexethumbnail.desktop
454 %{_datadir}/kde4/services/windowsimagethumbnail.desktop
455 %{_datadir}/kde4/servicetypes/knotifynotifymethod.desktop
456 %{_datadir}/kde4/servicetypes/plasma-javascriptaddon.desktop
457 %{_datadir}/kde4/servicetypes/searchprovider.desktop
458 %{_datadir}/kde4/servicetypes/thumbcreator.desktop
459 %{_datadir}/desktop-directories/kde-*.directory
460 %{_datadir}/mime/packages/network.xml
461 %{_datadir}/mime/packages/webp.xml
462
463 %dir %{_datadir}/locale/l10n
464 %{_datadir}/locale/l10n/C
465 %{_datadir}/locale/l10n/caribbean.desktop
466 %{_datadir}/locale/l10n/centralafrica.desktop
467 %{_datadir}/locale/l10n/centralamerica.desktop
468 %{_datadir}/locale/l10n/centralasia.desktop
469 %{_datadir}/locale/l10n/centraleurope.desktop
470 %{_datadir}/locale/l10n/eastafrica.desktop
471 %{_datadir}/locale/l10n/eastasia.desktop
472 %{_datadir}/locale/l10n/easteurope.desktop
473 %{_datadir}/locale/l10n/middleeast.desktop
474 %{_datadir}/locale/l10n/northafrica.desktop
475 %{_datadir}/locale/l10n/northamerica.desktop
476 %{_datadir}/locale/l10n/northeurope.desktop
477 %{_datadir}/locale/l10n/oceania.desktop
478 %{_datadir}/locale/l10n/southafrica.desktop
479 %{_datadir}/locale/l10n/southamerica.desktop
480 %{_datadir}/locale/l10n/southasia.desktop
481 %{_datadir}/locale/l10n/southeastasia.desktop
482 %{_datadir}/locale/l10n/southeurope.desktop
483 %{_datadir}/locale/l10n/westafrica.desktop
484 %{_datadir}/locale/l10n/westeurope.desktop
485 # really?
486 %{_datadir}/locale/currency
487
488 %{_datadir}/sounds/KDE-*.ogg
489 %{_desktopdir}/kde4/Help.desktop
490 %{_desktopdir}/kde4/knetattach.desktop
491 %{_iconsdir}/hicolor/*x*/apps/knetattach.png
492 %{_iconsdir}/hicolor/scalable/apps/knetattach.svgz
493 %lang(en) %{_kdedocdir}/en/fundamentals
494 %lang(en) %{_kdedocdir}/en/kcontrol/attica
495 %lang(en) %{_kdedocdir}/en/kcontrol/bookmarks
496 %lang(en) %{_kdedocdir}/en/kcontrol/cache
497 %lang(en) %{_kdedocdir}/en/kcontrol/componentchooser
498 %lang(en) %{_kdedocdir}/en/kcontrol/cookies
499 %lang(en) %{_kdedocdir}/en/kcontrol/ebrowsing
500 %lang(en) %{_kdedocdir}/en/kcontrol/emoticons
501 %lang(en) %{_kdedocdir}/en/kcontrol/filemanager
502 %lang(en) %{_kdedocdir}/en/kcontrol/filetypes
503 %lang(en) %{_kdedocdir}/en/kcontrol/history
504 %lang(en) %{_kdedocdir}/en/kcontrol/icons
505 %lang(en) %{_kdedocdir}/en/kcontrol/kcm_ssl
506 %lang(en) %{_kdedocdir}/en/kcontrol/kcmcgi
507 %lang(en) %{_kdedocdir}/en/kcontrol/kcmcss
508 %lang(en) %{_kdedocdir}/en/kcontrol/kcmlaunch
509 %lang(en) %{_kdedocdir}/en/kcontrol/kcmnotify
510 %lang(en) %{_kdedocdir}/en/kcontrol/kded
511 %lang(en) %{_kdedocdir}/en/kcontrol/khtml-adblock
512 %lang(en) %{_kdedocdir}/en/kcontrol/khtml-behavior
513 %lang(en) %{_kdedocdir}/en/kcontrol/khtml-general
514 %lang(en) %{_kdedocdir}/en/kcontrol/khtml-java-js
515 %lang(en) %{_kdedocdir}/en/kcontrol/khtml-plugins
516 %lang(en) %{_kdedocdir}/en/kcontrol/language
517 %lang(en) %{_kdedocdir}/en/kcontrol/nepomuk
518 %lang(en) %{_kdedocdir}/en/kcontrol/netpref
519 %lang(en) %{_kdedocdir}/en/kcontrol/performance
520 %lang(en) %{_kdedocdir}/en/kcontrol/proxy
521 %lang(en) %{_kdedocdir}/en/kcontrol/smb
522 %lang(en) %{_kdedocdir}/en/kcontrol/solid-device-automounter
523 %lang(en) %{_kdedocdir}/en/kcontrol/spellchecking
524 %lang(en) %{_kdedocdir}/en/kcontrol/trash
525 %lang(en) %{_kdedocdir}/en/kcontrol/useragent
526 %lang(en) %{_kdedocdir}/en/kdebugdialog
527 %lang(en) %{_kdedocdir}/en/kdesu
528 %lang(en) %{_kdedocdir}/en/khelpcenter
529 %lang(en) %{_kdedocdir}/en/kioslave/bzip2
530 %lang(en) %{_kdedocdir}/en/kioslave/bookmarks
531 %lang(en) %{_kdedocdir}/en/kioslave/cgi
532 %lang(en) %{_kdedocdir}/en/kioslave/finger
533 %lang(en) %{_kdedocdir}/en/kioslave/fish
534 %lang(en) %{_kdedocdir}/en/kioslave/floppy
535 %lang(en) %{_kdedocdir}/en/kioslave/gzip
536 %lang(en) %{_kdedocdir}/en/kioslave/info
537 %lang(en) %{_kdedocdir}/en/kioslave/man
538 %lang(en) %{_kdedocdir}/en/kioslave/nepomuksearch
539 %lang(en) %{_kdedocdir}/en/kioslave/network
540 %lang(en) %{_kdedocdir}/en/kioslave/nfs
541 %lang(en) %{_kdedocdir}/en/kioslave/sftp
542 %lang(en) %{_kdedocdir}/en/kioslave/smb
543 %lang(en) %{_kdedocdir}/en/kioslave/tar
544 %lang(en) %{_kdedocdir}/en/kioslave/thumbnail
545 %lang(en) %{_kdedocdir}/en/kioslave/xz
546 %lang(en) %{_kdedocdir}/en/knetattach
547 %lang(en) %{_kdedocdir}/en/onlinehelp
548 %{_mandir}/man1/kdesu.1*
549 %{_mandir}/man1/plasmapkg.1*
550
551 %files devel
552 %defattr(644,root,root,755)
553 %{_includedir}/knotify*.h
554 %attr(755,root,root) %{_libdir}/libkwalletbackend.so
555 %attr(755,root,root) %{_libdir}/libmolletnetwork.so
556 %{_datadir}/apps/cmake/modules/FindCLucene.cmake
557 %{_datadir}/apps/cmake/modules/FindSLP.cmake
558
559 %files -n kde4-phonon
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_devicepreference_update
562 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_deviceuids_update
563 %attr(755,root,root) %{_libdir}/kde4/kcm_phonon.so
564 %attr(755,root,root) %{_libdir}/kde4/kded_phononserver.so
565 %dir %{_libdir}/kde4/plugins/phonon_platform
566 %attr(755,root,root) %{_libdir}/kde4/plugins/phonon_platform/kde.so
567 %{_datadir}/kde4/services/kcm_phonon.desktop
568 %{_datadir}/kde4/services/kded/phononserver.desktop
569 %{_datadir}/kde4/servicetypes/phononbackend.desktop
570
571 %{_datadir}/apps/kcm_phonon
572 %{_datadir}/apps/kconf_update/devicepreference.upd
573 %{_datadir}/apps/libphonon
574 %{_datadir}/apps/phonon
575 %lang(en) %{_kdedocdir}/en/kcontrol/phonon
This page took 0.129365 seconds and 3 git commands to generate.