]> git.pld-linux.org Git - packages/kde4-kate.git/blob - kde4-kate.spec
- 4.10.0
[packages/kde4-kate.git] / kde4-kate.spec
1 %define         _state          stable
2 %define         orgname         kate
3 %define         qtver           4.8.3
4
5 Summary:        K Desktop Environment - Advanced Text Editor
6 Summary(pl.UTF-8):      K Desktop Environment -  Zaawansowany edytor tekstu
7 Name:           kde4-kate
8 Version:        4.10.0
9 Release:        1
10 License:        GPL
11 Group:          X11/Applications/Editors
12 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
13 # Source0-md5:  dfb02f35f1aaf4e9083c16e7f797bede
14 URL:            http://www.kde.org/
15 BuildRequires:  kde4-kdelibs-devel >= %{version}
16 BuildRequires:  shared-mime-info
17 Obsoletes:      kde4-kdebase-kwrite < 4.6.99
18 Obsoletes:      kde4-kdesdk-kate < 4.6.99
19 Obsoletes:      kate <= 4.8.0
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 KDE advanced text editor featuring among others:
24 - fast opening/editing of files even the big ones (opens a 50MB file
25   in a few seconds)
26 - powerful syntaxhighlighting engine, extensible via XML files
27 - Code Folding capabilities for C++, C, PHP and more
28 - Dynamic Word Wrap - long lines are wrapped at the window border on
29   the fly for better overview
30 - multiple views allows you to view more instances of the same
31   document and/or more documents at one time
32 - support for different encodings globally and at write time
33 - built in dockable terminal emulation
34 - sidebars with a list of open documents, a directory viewer with a
35   directory chooser, a filter chooser and more
36 - a plugin interface to allow third party plugins
37 - a "Filter" command allows you to run selected text through a shell
38   command
39
40 KWrite is a simple texteditor, with syntaxhighlighting, codefolding,
41 dynamic word wrap and more, it's the lightweight version of Kate,
42 providing more speed for minor tasks.
43
44 %description -l pl.UTF-8
45 Kate (KDE advanced text editor) to zaawansowany edytor tekstu KDE o
46 możliwościach obejmujących m.in.:
47 - szybkie otwieranie i edycję nawet dużych plików (otwiera plik 50MB w
48   parę sekund)
49 - potężny silnik podświetlania składni, rozszerzalny za pomocą plików
50   XML
51 - możliwość zwijania kodu dla C++, C, PHP i innych języków
52 - dynamiczne zawijanie wierszy - długie linie są zawijane na granicy
53   okna w locie dla lepszej widoczności
54 - wiele widoków pozwalających oglądać więcej instancji tego samego
55   dokumentu i/lub więcej dokumentów w tym samym czasie
56 - obsługę różnych kodowań globalnie i w czasie zapisu
57 - wbudowaną emulację dokowalnego terminala
58 - paski z listą otwartych dokumentów, przeglądarkę katalogów z
59   możliwością wybierania katalogu i filtrów
60 - interfejs wtyczek obsługujący zewnętrzne wtyczki
61 - polecenie "Filtr" pozwalające przepuszczać zaznaczony tekst przez
62   polecenie powłoki
63
64 KWrite to prosty edytor tekstu z podświetlaniem składni, zwijaniem
65 kodu, dynamicznym zawijaniem wierszy itp. Jest lżejszą wersją Kate,
66 szybszą dla mniejszych zadań.
67
68 %package devel
69 Summary:        kate development files
70 Summary(pl.UTF-8):      Pliki dla programistów kate
71 Group:          X11/Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Obsoletes:      kate-devel <= 4.8.0
74
75 %description devel
76 kate development files.
77
78 %description devel -l pl.UTF-8
79 Pliki dla programistów kate.
80
81 %prep
82 %setup -q -n %{orgname}-%{version}
83
84 %build
85 install -d build
86 cd build
87 %cmake \
88         ..
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} -C build/ install \
95         DESTDIR=$RPM_BUILD_ROOT \
96         kde_htmldir=%{_kdedocdir}
97
98 %find_lang      kate            --with-kde
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files -f %{orgname}.lang
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_bindir}/kate
109 %attr(755,root,root) %{_bindir}/ktesnippets_editor
110 %attr(755,root,root) %{_bindir}/kwrite
111 %attr(755,root,root) %{_libdir}/kde4/*.so
112 %attr(755,root,root) %{_libdir}/libkateinterfaces.so
113 %attr(755,root,root) %{_libdir}/libkateinterfaces.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libkateinterfaces.so.?
115 %attr(755,root,root) %{_libdir}/libkatepartinterfaces.so
116 %attr(755,root,root) %{_libdir}/libkatepartinterfaces.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libkatepartinterfaces.so.?
118 %attr(755,root,root) %{_libdir}/libkdeinit4_kate.so
119 %attr(755,root,root) %{_libdir}/libkdeinit4_kwrite.so
120 %attr(755,root,root) %{_libdir}/libktexteditor_codesnippets_core.so
121 %attr(755,root,root) %{_libdir}/libktexteditor_codesnippets_core.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libktexteditor_codesnippets_core.so.?
123 %{_datadir}/apps/kate
124 %{_datadir}/apps/katepart
125 %{_datadir}/apps/katexmltools
126 %{_datadir}/apps/kconf_update/kate-2.4.upd
127 %{_datadir}/apps/ktexteditor_*
128 %{_datadir}/apps/kwrite
129 %{_datadir}/config/katefiletemplates.knsrc
130 %{_datadir}/config/katemoderc
131 %{_datadir}/config/katepartpluginsrc
132 %{_datadir}/config/katerc
133 %{_datadir}/config/ktexteditor_codesnippets_core.knsrc
134 %{_datadir}/kde4/services/kate*.desktop
135 %{_datadir}/kde4/services/ktexteditor_*.desktop
136 %{_datadir}/kde4/services/plasma-applet-katesession.desktop
137 %{_datadir}/kde4/servicetypes/kateplugin.desktop
138 %{_datadir}/mime/packages/ktesnippets.xml
139 %{_desktopdir}/kde4/kate.desktop
140 %{_desktopdir}/kde4/ktesnippets_editor.desktop
141 %{_desktopdir}/kde4/kwrite.desktop
142 %{_iconsdir}/*/*/actions/debug.png
143 %{_iconsdir}/*/*/actions/repoadd.png
144 %{_iconsdir}/*/*/actions/repomanage.png
145 %{_iconsdir}/*/*/actions/snippetadd.png
146 %{_iconsdir}/*/*/actions/snippetedit.png
147 %{_iconsdir}/*/*/apps/kate.*
148 %{_kdedocdir}/en/kwrite
149 %{_mandir}/man1/kate.1*
150
151 %files devel
152 %defattr(644,root,root,755)
153 %{_includedir}/kate
154 %{_includedir}/ktexteditor_codesnippets_core
155 %{_includedir}/kate_export.h
This page took 0.348343 seconds and 3 git commands to generate.