]> git.pld-linux.org Git - packages/kde4-kate.git/blob - kde4-kate.spec
2b25f70d9094d88b2cfe06dd8e9114f8a75ddfd1
[packages/kde4-kate.git] / kde4-kate.spec
1 # TODO:
2 #        /usr/lib64/python2.7/site-packages/PyKate4/__init__.py
3 #        /usr/lib64/python2.7/site-packages/PyKate4/kate.so
4 #        /usr/share/kde4/services/pate.desktop
5
6 %define         _state          stable
7 %define         orgname         kate
8 %define         qtver           4.8.3
9
10 Summary:        K Desktop Environment - Advanced Text Editor
11 Summary(pl.UTF-8):      K Desktop Environment -  Zaawansowany edytor tekstu
12 Name:           kde4-kate
13 Version:        4.14.0
14 Release:        1
15 License:        GPL
16 Group:          X11/Applications/Editors
17 Source0:        http://download.kde.org/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
18 # Source0-md5:  9d9eb94e924d192a940e515c74a71b05
19 URL:            http://www.kde.org/
20 BuildRequires:  kde4-kdelibs-devel >= %{version}
21 BuildRequires:  python-PyKDE4-devel >= %{version}
22 BuildRequires:  shared-mime-info
23 Obsoletes:      kate <= 4.8.0
24 Obsoletes:      kde4-kdebase-kwrite < 4.6.99
25 Obsoletes:      kde4-kdesdk-kate < 4.6.99
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 KDE advanced text editor featuring among others:
30 - fast opening/editing of files even the big ones (opens a 50MB file
31   in a few seconds)
32 - powerful syntaxhighlighting engine, extensible via XML files
33 - Code Folding capabilities for C++, C, PHP and more
34 - Dynamic Word Wrap - long lines are wrapped at the window border on
35   the fly for better overview
36 - multiple views allows you to view more instances of the same
37   document and/or more documents at one time
38 - support for different encodings globally and at write time
39 - built in dockable terminal emulation
40 - sidebars with a list of open documents, a directory viewer with a
41   directory chooser, a filter chooser and more
42 - a plugin interface to allow third party plugins
43 - a "Filter" command allows you to run selected text through a shell
44   command
45
46 KWrite is a simple texteditor, with syntaxhighlighting, codefolding,
47 dynamic word wrap and more, it's the lightweight version of Kate,
48 providing more speed for minor tasks.
49
50 %description -l pl.UTF-8
51 Kate (KDE advanced text editor) to zaawansowany edytor tekstu KDE o
52 możliwościach obejmujących m.in.:
53 - szybkie otwieranie i edycję nawet dużych plików (otwiera plik 50MB w
54   parę sekund)
55 - potężny silnik podświetlania składni, rozszerzalny za pomocą plików
56   XML
57 - możliwość zwijania kodu dla C++, C, PHP i innych języków
58 - dynamiczne zawijanie wierszy - długie linie są zawijane na granicy
59   okna w locie dla lepszej widoczności
60 - wiele widoków pozwalających oglądać więcej instancji tego samego
61   dokumentu i/lub więcej dokumentów w tym samym czasie
62 - obsługę różnych kodowań globalnie i w czasie zapisu
63 - wbudowaną emulację dokowalnego terminala
64 - paski z listą otwartych dokumentów, przeglądarkę katalogów z
65   możliwością wybierania katalogu i filtrów
66 - interfejs wtyczek obsługujący zewnętrzne wtyczki
67 - polecenie "Filtr" pozwalające przepuszczać zaznaczony tekst przez
68   polecenie powłoki
69
70 KWrite to prosty edytor tekstu z podświetlaniem składni, zwijaniem
71 kodu, dynamicznym zawijaniem wierszy itp. Jest lżejszą wersją Kate,
72 szybszą dla mniejszych zadań.
73
74 %package devel
75 Summary:        kate development files
76 Summary(pl.UTF-8):      Pliki dla programistów kate
77 Group:          X11/Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Obsoletes:      kate-devel <= 4.8.0
80
81 %description devel
82 kate development files.
83
84 %description devel -l pl.UTF-8
85 Pliki dla programistów kate.
86
87 %prep
88 %setup -q -n %{orgname}-%{version}
89
90 %build
91 install -d build
92 cd build
93 %cmake \
94         ..
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} -C build/ install \
101         DESTDIR=$RPM_BUILD_ROOT \
102         kde_htmldir=%{_kdedocdir}
103
104 %find_lang      kate            --with-kde
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files -f %{orgname}.lang
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_bindir}/kate
115 #%attr(755,root,root) %{_bindir}/ktesnippets_editor
116 %attr(755,root,root) %{_bindir}/kwrite
117 %attr(755,root,root) %{_libdir}/kde4/*.so
118 %attr(755,root,root) %{_libdir}/libkateinterfaces.so
119 %attr(755,root,root) %{_libdir}/libkateinterfaces.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libkateinterfaces.so.?
121 %attr(755,root,root) %{_libdir}/libkatepartinterfaces.so
122 %attr(755,root,root) %{_libdir}/libkatepartinterfaces.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libkatepartinterfaces.so.?
124 %attr(755,root,root) %{_libdir}/libkdeinit4_kate.so
125 %attr(755,root,root) %{_libdir}/libkdeinit4_kwrite.so
126 %dir %{py_sitedir}/PyKate4
127 %{py_sitedir}/PyKate4/__init__.py
128 %attr(755,root,root) %{py_sitedir}/PyKate4/kate.so
129 %{_datadir}/apps/kate
130 %{_datadir}/apps/katepart
131 %{_datadir}/apps/katexmltools
132 %{_datadir}/apps/kconf_update/kate-2.4.upd
133 %{_datadir}/apps/ktexteditor_*
134 %{_datadir}/apps/kwrite
135 %{_datadir}/config/katemoderc
136 %{_datadir}/config/katerc
137 %{_datadir}/config/kateschemarc
138 %{_datadir}/config/katesyntaxhighlightingrc
139 %{_datadir}/config/ktexteditor_codesnippets_core.knsrc
140 %{_datadir}/kde4/services/kate*.desktop
141 %{_datadir}/kde4/services/ktexteditor_*.desktop
142 %{_datadir}/kde4/services/pate.desktop
143 %{_datadir}/kde4/services/plasma-applet-katesession.desktop
144 %{_datadir}/kde4/servicetypes/kateplugin.desktop
145 %{_datadir}/kde4/servicetypes/katepythonplugin.desktop
146 %{_desktopdir}/kde4/kate.desktop
147 %{_desktopdir}/kde4/kwrite.desktop
148 %{_iconsdir}/*/*/actions/debug-kategdb.png
149 %{_iconsdir}/*/*/apps/kate.*
150 %{_iconsdir}/*/*/apps/ktexteditorautobrace.*
151 %{_kdedocdir}/en/kwrite
152 %{_mandir}/man1/kate.1*
153
154 %files devel
155 %defattr(644,root,root,755)
156 %{_includedir}/kate
157 %{_includedir}/kate_export.h
This page took 0.047993 seconds and 2 git commands to generate.