]> git.pld-linux.org Git - packages/kbd.git/blob - kbd.spec
8708acd2fb8ee58851642218d1f3ef52f8a69c2c
[packages/kbd.git] / kbd.spec
1 # NOTE: kbd's vlock is a fork of vlock v1.x
2 #       comparing with vlock v2.x it has NLS, but no plugins support
3 # TODO:
4 # - pam file for vlock
5 # - probably it doesn't make sense to package ppc keymaps on x86 and vice versa
6 #
7 # Conditional build:
8 %bcond_without  vlock   # don't build vlock
9 #
10 Summary:        Linux console utilities
11 Summary(ko.UTF-8):      콘솔을 설정하는 도구 (글쇠판, 가상 터미널, 그 밖에)
12 Summary(pl.UTF-8):      Narzędzia do obsługi konsoli
13 Name:           kbd
14 Version:        2.0.3
15 Release:        1
16 License:        GPL v2+
17 Group:          Applications/Console
18 Source0:        ftp://ftp.altlinux.org/pub/people/legion/kbd/%{name}-%{version}.tar.gz
19 # Source0-md5:  d636ee56f35233b5cd6f855c08372489
20 Source1:        %{name}.init
21 Source2:        %{name}.sysconfig
22 Source3:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
23 # Source3-md5:  93c72a27e4fdeba23cb62d62343e9483
24 Source4:        lat2u-16.psf.gz
25 # Source4-md5:  dc90a9bcff858175beea32a9b3bebb33
26 Source5:        lat2u.sfm.gz
27 # Source5-md5:  8ac4abc169fa1236fc3e64163c043113
28 Source52:       http://pkgs.fedoraproject.org/repo/pkgs/kbd/%{name}-latarcyrheb-16-fixed.tar.bz2/cb1e2d5ba5d4cb8b0a27367029d36a56/kbd-latarcyrheb-16-fixed.tar.bz2
29 # Source52-md5: cb1e2d5ba5d4cb8b0a27367029d36a56
30 Source6:        console.sh
31 Source7:        console.csh
32 Source8:        %{name}-pl1.kmap
33 Source9:        %{name}-mac-pl.kmap
34 Source10:       %{name}-pl3.map
35 Source11:       %{name}-pl4.map
36 Source12:       console.upstart
37 Patch0:         %{name}-unicode_start.patch
38 Patch1:         %{name}-tty-detect.patch
39 URL:            http://kbd-project.org/
40 BuildRequires:  autoconf >= 2.60
41 BuildRequires:  automake >= 1:1.9
42 BuildRequires:  bison
43 #BuildRequires: check >= 0.9.4
44 BuildRequires:  doxygen
45 BuildRequires:  flex
46 BuildRequires:  gettext-tools >= 0.14.1
47 BuildRequires:  libtool >= 2:2
48 %{?with_vlock:BuildRequires:    pam-devel}
49 BuildRequires:  pkgconfig
50 Requires(post,preun):   /sbin/chkconfig
51 Requires:       %{name}-libs = %{version}-%{release}
52 Requires:       open
53 Requires:       rc-scripts >= 0.4.3.0
54 Requires:       sed
55 Requires:       util-linux
56 Obsoletes:      console-data
57 Obsoletes:      console-tools
58 Obsoletes:      console-tools-devel
59 Obsoletes:      console-tools-static
60 Conflicts:      man-pages < 1.43-5
61 Conflicts:      util-linux < 2.11
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %define         _ldatadir       /lib/%{name}
65
66 %description
67 This package contains utilities to load console fonts and keyboard
68 maps. It also includes a number of different fonts and keyboard maps.
69
70 %description -l pl.UTF-8
71 Pakiet zawiera narzędzia do ładowania fontów konsolowych oraz map
72 klawiatury. Dodatkowo dołączono znaczną liczbę różnych fontów i map.
73
74 %package vlock
75 Summary:        Utility to lock one or more virtual consoles
76 Summary(pl.UTF-8):      Narzędzie do blokowania jednej lub wielu konsol wirtualnych
77 Group:          Applications/Console
78 Requires:       %{name} = %{version}-%{release}
79
80 %description vlock
81 Utility to lock one or more virtual consoles.
82
83 %description vlock -l pl.UTF-8
84 Narzędzie do blokowania jednej lub wielu konsol wirtualnych.
85
86 %package libs
87 Summary:        libkeymap - library to manage the Linux keymaps
88 Summary(pl.UTF-8):      libkeymap - biblioteka do zarządzania linuksowymi przypisaniami klawiszy
89 Group:          Libraries
90
91 %description libs
92 libkeymap - library to manage the Linux keymaps.
93
94 %description libs -l pl.UTF-8
95 libkeymap - biblioteka do zarządzania linuksowymi przypisaniami
96 klawiszy.
97
98 %package devel
99 Summary:        Header files for libkeymap library
100 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libkeymap
101 Group:          Development/Libraries
102 Requires:       %{name}-libs = %{version}-%{release}
103
104 %description devel
105 Header files for libkeymap library.
106
107 %description devel -l pl.UTF-8
108 Pliki nagłówkowe biblioteki libkeymap.
109
110 %package static
111 Summary:        Static libkeymap library
112 Summary(pl.UTF-8):      Statyczna biblioteka libkeymap
113 Group:          Development/Libraries
114 Requires:       %{name}-devel = %{version}-%{release}
115
116 %description static
117 Static libkeymap library.
118
119 %description static -l pl.UTF-8
120 Statyczna biblioteka libkeymap.
121
122 %prep
123 %setup -q -a52
124 %patch0 -p1
125 %patch1 -p1
126
127 # force rebuild
128 %{__rm} docs/reference/libkeymap/Doxyfile
129
130 %build
131 %{__gettextize}
132 %{__libtoolize}
133 %{__aclocal} -I m4
134 %{__autoconf}
135 %{__autoheader}
136 %{__automake}
137 %configure \
138         --datadir=%{_ldatadir} \
139         --localedir=%{_datadir}/locale \
140         --enable-libkeymap \
141         --enable-nls \
142         --enable-optional-progs \
143         --disable-silent-rules \
144         %{!?with_vlock:--disable-vlock}
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149 install -d $RPM_BUILD_ROOT{/bin,/etc/{profile.d,rc.d/init.d,sysconfig,init}}
150
151 %{__make} install \
152         DESTDIR=$RPM_BUILD_ROOT \
153         gnulocaledir=$RPM_BUILD_ROOT%{_datadir}/locale
154
155 # some binaries are needed in /bin but the rest is not
156 for f in setfont dumpkeys kbd_mode unicode_start unicode_stop; do
157         mv $RPM_BUILD_ROOT%{_bindir}/$f $RPM_BUILD_ROOT/bin
158 done
159
160 # move library to /lib* for utils in /bin
161 install -d $RPM_BUILD_ROOT/%{_lib}
162 mv $RPM_BUILD_ROOT%{_libdir}/libkeymap.so.* $RPM_BUILD_ROOT/%{_lib}
163 ln -sf $(basename $RPM_BUILD_ROOT/%{_lib}/libkeymap.so.*.*.*) $RPM_BUILD_ROOT%{_libdir}/libkeymap.so
164 # no external dependencies; also .pc file exists
165 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libkeymap.la
166
167 # optional-progs:
168 # obsoleted by setfont
169 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/getunimap,%{_mandir}/man8/getunimap.8}
170 # optional-progs: man pages for not installed utils from contrib
171 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{codepage,splitfont}.1
172 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/{mk_modmap,vcstime}.8
173
174 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/console
175 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/console
176 cp -p %{SOURCE12} $RPM_BUILD_ROOT/etc/init/console.conf
177 %ifarch sparc sparc64
178 %{__sed} -i -e 's/KEYTABLE=pl2/KEYTABLE=sunkeymap/' $RPM_BUILD_ROOT/etc/sysconfig/console
179 %endif
180
181 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_ldatadir}/consolefonts/lat2u-16.psfu.gz
182 gunzip -c %{SOURCE5} > $RPM_BUILD_ROOT%{_ldatadir}/unimaps/lat2u.uni
183
184 gzip -c %{SOURCE8} > $RPM_BUILD_ROOT%{_ldatadir}/keymaps/i386/qwerty/pl1.map.gz
185 gzip -c %{SOURCE9} > $RPM_BUILD_ROOT%{_ldatadir}/keymaps/mac/all/mac-pl.map.gz
186 gzip -c %{SOURCE10} > $RPM_BUILD_ROOT%{_ldatadir}/keymaps/i386/qwerty/pl3.map.gz
187 gzip -c %{SOURCE11} > $RPM_BUILD_ROOT%{_ldatadir}/keymaps/i386/qwerty/pl4.map.gz
188
189 cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/profile.d
190 cp -p %{SOURCE7} $RPM_BUILD_ROOT/etc/profile.d
191
192 bzip2 -dc %{SOURCE3} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
193
194 # Greek is el, not gr
195 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/gr
196 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.kbd-non-english-man-pages,kbd-keypaps_instead_keytables.patch}*
197
198 # doxygen docs
199 %{__rm} -rf docs-doxy
200 %{__mv} $RPM_BUILD_ROOT%{_docdir}/kbd/html docs-doxy
201
202 %find_lang %{name}
203
204 %clean
205 rm -rf $RPM_BUILD_ROOT
206
207 %post
208 /sbin/chkconfig --add console
209
210 %preun
211 if [ "$1" = "0" ]; then
212         /sbin/chkconfig --del console
213 fi
214
215 %post   libs -p /sbin/ldconfig
216 %postun libs -p /sbin/ldconfig
217
218 %files -f %{name}.lang
219 %defattr(644,root,root,755)
220 # COPYING contains copyright summary, not GPL text
221 %doc AUTHORS COPYING CREDITS ChangeLog README docs/doc/kbd.FAQ.txt
222 %attr(754,root,root) /etc/rc.d/init.d/console
223 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/console
224 %config(noreplace) %verify(not md5 mtime size) /etc/init/console.conf
225 %attr(755,root,root) /etc/profile.d/console.csh
226 %attr(755,root,root) /etc/profile.d/console.sh
227
228 %attr(755,root,root) /bin/dumpkeys
229 %attr(755,root,root) /bin/kbd_mode
230 %attr(755,root,root) /bin/setfont
231 %attr(755,root,root) /bin/unicode_start
232 %attr(755,root,root) /bin/unicode_stop
233 %attr(755,root,root) %{_bindir}/chvt
234 %attr(755,root,root) %{_bindir}/clrunimap
235 %attr(755,root,root) %{_bindir}/deallocvt
236 %attr(755,root,root) %{_bindir}/fgconsole
237 %attr(755,root,root) %{_bindir}/getkeycodes
238 %attr(755,root,root) %{_bindir}/kbdinfo
239 %attr(755,root,root) %{_bindir}/kbdrate
240 %attr(755,root,root) %{_bindir}/loadkeys
241 %attr(755,root,root) %{_bindir}/loadunimap
242 %attr(755,root,root) %{_bindir}/mapscrn
243 %attr(755,root,root) %{_bindir}/openvt
244 %attr(755,root,root) %{_bindir}/outpsfheader
245 %attr(755,root,root) %{_bindir}/psfaddtable
246 %attr(755,root,root) %{_bindir}/psfgettable
247 %attr(755,root,root) %{_bindir}/psfstriptable
248 %attr(755,root,root) %{_bindir}/psfxtable
249 %ifarch %{ix86} %{x8664}
250 %attr(755,root,root) %{_bindir}/resizecons
251 %endif
252 %attr(755,root,root) %{_bindir}/screendump
253 %attr(755,root,root) %{_bindir}/setkeycodes
254 %attr(755,root,root) %{_bindir}/setleds
255 %attr(755,root,root) %{_bindir}/setlogcons
256 %attr(755,root,root) %{_bindir}/setmetamode
257 %attr(755,root,root) %{_bindir}/setpalette
258 %attr(755,root,root) %{_bindir}/setvesablank
259 %attr(755,root,root) %{_bindir}/setvtrgb
260 %attr(755,root,root) %{_bindir}/showconsolefont
261 %attr(755,root,root) %{_bindir}/showkey
262 %attr(755,root,root) %{_bindir}/spawn_console
263 %attr(755,root,root) %{_bindir}/spawn_login
264 %dir %{_ldatadir}
265 %{_ldatadir}/consolefonts
266 %{_ldatadir}/consoletrans
267 %{_ldatadir}/keymaps
268 %{_ldatadir}/unimaps
269
270 %{_mandir}/man1/chvt.1*
271 %{_mandir}/man1/deallocvt.1*
272 %{_mandir}/man1/dumpkeys.1*
273 %{_mandir}/man1/fgconsole.1*
274 %{_mandir}/man1/kbd_mode.1*
275 %{_mandir}/man1/loadkeys.1*
276 %{_mandir}/man1/openvt.1*
277 %{_mandir}/man1/psfaddtable.1*
278 %{_mandir}/man1/psfgettable.1*
279 %{_mandir}/man1/psfstriptable.1*
280 %{_mandir}/man1/psfxtable.1*
281 %{_mandir}/man1/screendump.1*
282 %{_mandir}/man1/setleds.1*
283 %{_mandir}/man1/setmetamode.1*
284 %{_mandir}/man1/showkey.1*
285 %{_mandir}/man1/unicode_start.1*
286 %{_mandir}/man1/unicode_stop.1*
287 %{_mandir}/man5/keymaps.5*
288 %{_mandir}/man8/clrunimap.8*
289 %{_mandir}/man8/getkeycodes.8*
290 %{_mandir}/man8/kbdrate.8*
291 %{_mandir}/man8/loadunimap.8*
292 %{_mandir}/man8/mapscrn.8*
293 %ifarch %{ix86} %{x8664}
294 %{_mandir}/man8/resizecons.8*
295 %endif
296 %{_mandir}/man8/setfont.8*
297 %{_mandir}/man8/setkeycodes.8*
298 %{_mandir}/man8/setlogcons.8*
299 %{_mandir}/man8/setvesablank.8*
300 %{_mandir}/man8/setvtrgb.8*
301 %{_mandir}/man8/showconsolefont.8*
302 %lang(es) %{_mandir}/es/man[158]/*
303 %lang(fi) %{_mandir}/fi/man[158]/*
304 %lang(fr) %{_mandir}/fr/man[158]/*
305 %lang(hu) %{_mandir}/hu/man[158]/*
306 %lang(ko) %{_mandir}/ko/man[158]/*
307 %lang(pl) %{_mandir}/pl/man[158]/*
308
309 %if %{with vlock}
310 %files vlock
311 %defattr(644,root,root,755)
312 %doc src/vlock/README.vlock
313 %attr(755,root,root) %{_bindir}/vlock
314 %{_mandir}/man1/vlock.1*
315 %endif
316
317 %files libs
318 %defattr(644,root,root,755)
319 %attr(755,root,root) /%{_lib}/libkeymap.so.*.*.*
320 %attr(755,root,root) %ghost /%{_lib}/libkeymap.so.0
321
322 %files devel
323 %defattr(644,root,root,755)
324 %doc docs-doxy/*
325 %attr(755,root,root) %{_libdir}/libkeymap.so
326 %{_includedir}/keymap
327 %{_includedir}/keymap.h
328 %{_pkgconfigdir}/libkeymap.pc
329
330 %files static
331 %defattr(644,root,root,755)
332 %{_libdir}/libkeymap.a
This page took 0.092324 seconds and 2 git commands to generate.