]> git.pld-linux.org Git - packages/kazehakase.git/blob - kazehakase.spec
- release 4 (xulrunner 1.8.1.13)
[packages/kazehakase.git] / kazehakase.spec
1 #
2 #Conditional builds
3 %bcond_without  gecko   # build without gecko support
4 %bcond_without  webkit  # build without webkit support
5 #
6 Summary:        A browser with multiple rendering engines support
7 Summary(pl.UTF-8):      Przeglądarka obsługująca wiele silników renderujących
8 Name:           kazehakase
9 Version:        0.5.4
10 Release:        4
11 License:        GPL
12 Group:          X11/Applications/Networking
13 Source0:        http://downloads.sourceforge.jp/kazehakase/30219/%{name}-%{version}.tar.gz
14 # Source0-md5:  75f8afb9ddf4493c3a1fb4eb38a044df
15 Patch0:         %{name}-desktop.patch
16 Patch1:         %{name}-agent.patch
17 Patch2:         %{name}-deprecated.patch
18 URL:            http://kazehakase.sourceforge.jp/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  gettext-devel
22 BuildRequires:  gnutls-devel
23 BuildRequires:  gtk+2-devel
24 %{?with_webkit:BuildRequires:   gtk-webkit-devel}
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 %{?with_gecko:BuildRequires:    xulrunner-devel}
29 Requires:       %{name}-libs = %{version}-%{release}
30 Requires:       kazehakase_engine
31 %requires_eq_to xulrunner xulrunner-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 # we have strict deps for it
35 %define         _noautoreq      libxpcom.so
36
37 %description
38 Kazehakase is a browser which allow use many rendering engines. For
39 now it support only Gecko (like Epiphany or Galeon) and webkit engines.
40
41 %description -l pl.UTF-8
42 Kazehakase jest przeglądarką, która pozwala na używanie wielu
43 silników renderujących. Na dzień dzisiejszy obsługuje silniki Gecko
44 (taki jak w Epiphany lub Galeonie) oraz webkit.
45
46 %package libs
47 Summary:        Kazehakase libraries
48 Summary(pl.UTF-8):      Biblioteki Kazehakase
49 Group:          Libraries
50
51 %description libs
52 This package contains Kazehakase libraries.
53
54 %description libs -l pl.UTF-8
55 Pakiet zawiera biblioteki Kazehakase.
56
57 %package plugin-gecko
58 Summary:        Gecko plugin engine for Kazehakase
59 Summary(pl.UTF-8):      Wtyczka Gecko dla Kazehakase
60 Group:          X11/Applications/Networking
61 Requires:       xulrunner
62 Provides:       kazehakase_engine
63
64 %description plugin-gecko
65 This plugin provides Gecko rendering engine support.
66
67 %description plugin-gecko -l pl.UTF-8
68 Ta wtyczka dodaje obsługę silnika renderującego Gecko.
69
70 %package plugin-webkit
71 Summary:        Webkit plugin engine for Kazehakase
72 Summary(pl.UTF-8):      Wtyczka webkit dla Kazehakase
73 Group:          X11/Applications/Networking
74 Provides:       kazehakase_engine
75
76 %description plugin-webkit
77 This plugin provides webkit rendering engine support.
78
79 %description plugin-webkit -l pl.UTF-8
80 Ta wtyczka dodaje obsługę silnika renderującego webkit.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I macros
91 %{__autoconf}
92 %{__automake}
93 %configure \
94         %{!?with_gecko:--disable-gecko}
95         %{!?with_webkit:--disable-webkit}
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         libkazehakasedir=%{_libdir} \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 # unnecessary
107 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
108 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/embed/*.la
109
110 %find_lang %{name}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   libs -p /sbin/ldconfig
116 %postun libs -p /sbin/ldconfig
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc README README.ja AUTHORS ChangeLog COPYING.README TODO.ja
121 %{_sysconfdir}/%{name}
122 %attr(755,root,root) %{_bindir}/*
123 %{_desktopdir}/%{name}.desktop
124 %{_datadir}/%{name}
125 %{_pixmapsdir}/*
126 %{_mandir}/man?/*
127
128 %files libs
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/lib*.so
131 %attr(755,root,root) %{_libdir}/lib*.so.*
132 %dir %{_libdir}/%{name}
133 %dir %{_libdir}/%{name}/embed
134
135 %if %{with_gecko}
136 %files plugin-gecko
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/%{name}/embed/gecko.so
139 %endif
140 %if %{with_webkit}
141 %files plugin-webkit
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/%{name}/embed/webkit_gtk.so
144 %endif
This page took 0.061761 seconds and 4 git commands to generate.