]> git.pld-linux.org Git - packages/kazehakase.git/blob - kazehakase.spec
- fix building with gnutls 2.8.x and xulrunner 1.9.1.x
[packages/kazehakase.git] / kazehakase.spec
1 #
2 #   - force kazehakase to use old SSL dialogs using nsIBadCertListener, ie. port
3 #     EphyBadCertRejector from Epiphany, this will fix issues with https sites
4 #     using self signed and expired certificates or mismatches in domain names
5 #
6 # Conditional builds
7 %bcond_without  gecko   # build without gecko support
8 %bcond_without  webkit  # build without webkit support
9 #
10 Summary:        A browser with multiple rendering engines support
11 Summary(pl.UTF-8):      Przeglądarka obsługująca wiele silników renderujących
12 Name:           kazehakase
13 Version:        0.5.6
14 Release:        8
15 License:        GPL
16 Group:          X11/Applications/Networking
17 Source0:        http://downloads.sourceforge.jp/kazehakase/33533/%{name}-%{version}.tar.gz
18 # Source0-md5:  b88257aa10dd53fd5d39c627f8f95890
19 Patch0:         %{name}-desktop.patch
20 Patch1:         %{name}-deprecated.patch
21 Patch2:         %{name}-ti-agent.patch
22 Patch3:         %{name}-agent.patch
23 Patch4:         %{name}-libxul.patch
24 Patch5:         %{name}-xulappinfo.patch
25 Patch6:         %{name}-gnutls.patch
26 Patch7:         %{name}-xulrunner-1_9_1.patch
27 URL:            http://kazehakase.sourceforge.jp/
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  gettext-devel
31 BuildRequires:  gnutls-devel
32 BuildRequires:  gtk+2-devel
33 %{?with_webkit:BuildRequires:   gtk-webkit-devel}
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  libtool
36 BuildRequires:  pkgconfig
37 BuildRequires:  rpm >= 4.4.9-56
38 %{?with_gecko:BuildRequires:    xulrunner-devel}
39 Requires:       %{name}-libs = %{version}-%{release}
40 Requires:       kazehakase_engine
41 %requires_eq_to xulrunner xulrunner-devel
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 # we have strict deps for it
45 %define         _noautoreq      libxpcom.so
46
47 %description
48 Kazehakase is a browser which allow use many rendering engines. For
49 now it support only Gecko (like Epiphany or Galeon) and webkit engines.
50
51 %description -l pl.UTF-8
52 Kazehakase jest przeglądarką, która pozwala na używanie wielu
53 silników renderujących. Na dzień dzisiejszy obsługuje silniki Gecko
54 (taki jak w Epiphany lub Galeonie) oraz webkit.
55
56 %package libs
57 Summary:        Kazehakase libraries
58 Summary(pl.UTF-8):      Biblioteki Kazehakase
59 Group:          Libraries
60
61 %description libs
62 This package contains Kazehakase libraries.
63
64 %description libs -l pl.UTF-8
65 Pakiet zawiera biblioteki Kazehakase.
66
67 %package plugin-gecko
68 Summary:        Gecko plugin engine for Kazehakase
69 Summary(pl.UTF-8):      Wtyczka Gecko dla Kazehakase
70 Group:          X11/Applications/Networking
71 Requires:       xulrunner
72 Provides:       kazehakase_engine
73
74 %description plugin-gecko
75 This plugin provides Gecko rendering engine support.
76
77 %description plugin-gecko -l pl.UTF-8
78 Ta wtyczka dodaje obsługę silnika renderującego Gecko.
79
80 %package plugin-webkit
81 Summary:        Webkit plugin engine for Kazehakase
82 Summary(pl.UTF-8):      Wtyczka webkit dla Kazehakase
83 Group:          X11/Applications/Networking
84 Provides:       kazehakase_engine
85
86 %description plugin-webkit
87 This plugin provides webkit rendering engine support.
88
89 %description plugin-webkit -l pl.UTF-8
90 Ta wtyczka dodaje obsługę silnika renderującego webkit.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %if "%{pld_release}" == "ti"
97 %patch2 -p1
98 %else
99 %patch3 -p1
100 %endif
101 %patch4 -p1
102 %patch5 -p1
103 %patch6 -p0
104 %patch7 -p1
105
106 %build
107 %{__libtoolize}
108 %{__aclocal} -I macros
109 %{__autoconf}
110 %{__automake}
111 %configure \
112         %{!?with_gecko:--disable-gecko} \
113         %{!?with_webkit:--disable-webkit}
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         libkazehakasedir=%{_libdir} \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 # unnecessary
125 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
126 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/embed/*.la
127
128 %find_lang %{name}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   libs -p /sbin/ldconfig
134 %postun libs -p /sbin/ldconfig
135
136 %files -f %{name}.lang
137 %defattr(644,root,root,755)
138 %doc README README.ja AUTHORS ChangeLog COPYING.README TODO.ja
139 %{_sysconfdir}/%{name}
140 %attr(755,root,root) %{_bindir}/*
141 %{_desktopdir}/%{name}.desktop
142 %{_datadir}/%{name}
143 %{_pixmapsdir}/*
144 %{_mandir}/man?/*
145
146 %files libs
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/lib*.so
149 %attr(755,root,root) %{_libdir}/lib*.so.*
150 %dir %{_libdir}/%{name}
151 %dir %{_libdir}/%{name}/embed
152
153 %if %{with gecko}
154 %files plugin-gecko
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/%{name}/embed/gecko.so
157 %endif
158 %if %{with webkit}
159 %files plugin-webkit
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/%{name}/embed/webkit_gtk.so
162 %endif
This page took 0.058962 seconds and 4 git commands to generate.