]> git.pld-linux.org Git - packages/kazehakase.git/blob - kazehakase.spec
- update to 0.5.4
[packages/kazehakase.git] / kazehakase.spec
1 #
2 #Conditional builds
3 %bcond_without  gecko   #Build without gecko support
4 %bcond_without  webkit  #Build without webkit support
5 #
6 Summary:        A browser with multiple rendering engines support
7 Summary(pl.UTF-8):      Przeglądarka wspierająca wile silników renderujących
8 Name:           kazehakase
9 Version:        0.5.4
10 Release:        1
11 License:        GPL
12 Group:          X11/Applications/Networking
13 Source0:        http://downloads.sourceforge.jp/kazehakase/30219/%{name}-%{version}.tar.gz
14 # Source0-md5:  75f8afb9ddf4493c3a1fb4eb38a044df
15 Patch0:         %{name}-desktop.patch
16 Patch1:         %{name}-agent.patch
17 Patch2:         %{name}-deprecated.patch
18 URL:            http://kazehakase.sourceforge.jp/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  gettext-devel
22 BuildRequires:  gnutls-devel
23 BuildRequires:  gtk+2-devel
24 %{?with_webkit:BuildRequires:   gtk-webkit-devel}
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 %{?with_gecko:BuildRequires:    xulrunner-devel}
29 Requires:       %{name}-libs = %{version}-%{release}
30 Requires:       engine_plugin
31 %requires_eq_to xulrunner xulrunner-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 # we have strict deps for it
35 %define         _noautoreq      libxpcom.so
36
37 %description
38 Kazehakase is a browser which allow use many rendering engines. For
39 now it support only geco (like Epiphany or Galeon) and webkit engines.
40
41 %description -l pl.UTF-8
42 Kazehakase jest przeglądarką, która pozwala na używanie wielu
43 silników renderujących. Na dzień dzisiejszy wspiera silniki geco
44 (takie jak u Epiphany lub Galeona ) oraz webkit.
45
46 %package libs
47 Summary:        Kazehakase libraries
48 Summary(pl.UTF-8):      Biblioteki Kazehakase
49 Group:          Libraries
50
51 %description libs
52 This package contains Kazehakase libraries.
53
54 %description libs -l pl.UTF-8
55 Pakiet zawiera biblioteki Kazehakase.
56
57 %package plugin-gecko
58 Summary:        Gecko plugin engine for Kazehakase
59 Summary(pl.UTF-8):      Plugin gecko dla Kazehakase
60 Group:          X11/Applications/Networking
61 Requires:       xulrunner
62 Provides:       engine_plugin
63
64 %description plugin-gecko
65 This plugin provides gecko rendering engine support.
66
67 %description plugin-gecko -l pl.UTF-8
68 Ten plugin dodaje wsparcie dla silnika renderującego gecko.
69
70 %package plugin-webkit
71 Summary:        Webkit plugin engine for Kazehakase
72 Summary(pl.UTF-8):      Plugin webkit dla Kazehakase
73 Group:          X11/Applications/Networking
74 Provides:       engine_plugin
75
76 %description plugin-webkit
77 This plugin provides webkit rendering engine support.
78
79 %description plugin-webkit -l pl.UTF-8
80 Ten plugin dodaje wsparcie dla silnika renderującego webkit.
81
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88
89 %build
90 %{__libtoolize}
91 %{__aclocal} -I macros
92 %{__autoconf}
93 %{__automake}
94 %configure \
95         %{!?with_gecko:--disable-gecko}
96         %{!?with_webkit:--disable-webkit}
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         libkazehakasedir=%{_libdir} \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 # unnecessary
108 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
109 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/embed/*.la
110
111 %find_lang %{name}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   libs -p /sbin/ldconfig
117 %postun libs -p /sbin/ldconfig
118
119 %files -f %{name}.lang
120 %defattr(644,root,root,755)
121 %doc README README.ja AUTHORS ChangeLog COPYING.README TODO.ja
122 %{_sysconfdir}/%{name}
123 %attr(755,root,root) %{_bindir}/*
124 %{_desktopdir}/%{name}.desktop
125 %{_datadir}/%{name}
126 %{_pixmapsdir}/*
127 %{_mandir}/man?/*
128
129 %files libs
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/lib*.so
132 %attr(755,root,root) %{_libdir}/lib*.so.*
133 %dir %{_libdir}/%{name}
134 %dir %{_libdir}/%{name}/embed/
135
136 %if %{with_gecko}
137 %files plugin-gecko
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/%{name}/embed/gecko.so
140 %endif
141 %if %{with_webkit}
142 %files plugin-webkit
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/%{name}/embed/webkit_gtk.so
145 %endif
This page took 0.03929 seconds and 4 git commands to generate.