]> git.pld-linux.org Git - packages/ka5-zanshin.git/blob - ka5-zanshin.spec
578a0224f47aee41c82c4f3ba6760148eeed9330
[packages/ka5-zanshin.git] / ka5-zanshin.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.04.1
5 %define         qtver           5.15.2
6 %define         kf5ver          5.71.0
7 %define         kaname          zanshin
8 Summary:        A Getting Things Done application
9 Name:           ka5-%{kaname}
10 Version:        23.04.1
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  13313f44acf1c78ab0d79aa3c33a2c7d
16 URL:            http://www.kde.org/
17 BuildRequires:  gettext-devel
18 BuildRequires:  ka5-akonadi-calendar-devel >= %{kdeappsver}
19 BuildRequires:  ka5-akonadi-devel >= %{kdeappsver}
20 BuildRequires:  ka5-kontactinterface-devel >= %{kdeappsver}
21 BuildRequires:  kf5-ki18n-devel >= 5.93.0
22 BuildRequires:  kf5-krunner-devel >= 5.93.0
23 BuildRequires:  kf5-kwindowsystem-devel >= 5.93.0
24 BuildRequires:  libstdc++-devel >= 6:8
25 BuildRequires:  ninja
26 BuildRequires:  qt5-build >= %{qtver}
27 BuildRequires:  rpmbuild(macros) >= 1.736
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xorg-lib-libX11-devel
30 BuildRequires:  xz
31 Requires:       Qt5Core >= %{qtver}
32 Requires:       Qt5DBus >= %{qtver}
33 Requires:       Qt5PrintSupport >= %{qtver}
34 Requires:       Qt5Widgets >= %{qtver}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 A Getting Things Done application which aims at getting your mind like
39 water. Zanshin is a state of awareness, of relaxed alertness, in
40 Japanese martial arts. A literal translation of zanshin is "remaining
41 mind". ([Extract from
42 Wikipedia](https://en.wikipedia.org/wiki/Zanshin))
43
44 %prep
45 %setup -q -n %{kaname}-%{version}
46
47 %build
48 install -d build
49 cd build
50 %cmake \
51         -G Ninja \
52         %{!?with_tests:-DBUILD_TESTING=OFF} \
53         -DHTML_INSTALL_DIR=%{_kdedocdir} \
54         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
55         ..
56 %ninja_build
57
58 %if %{with tests}
59 ctest
60 %endif
61
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 %ninja_install -C build
66
67 %find_lang %{kaname} --all-name --with-kde
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files -f %{kaname}.lang
73 %defattr(644,root,root,755)
74 %doc AUTHORS HACKING TODO
75 %attr(755,root,root) %{_bindir}/zanshin
76 %attr(755,root,root) %{_bindir}/zanshin-migrator
77 %attr(755,root,root) %{_libdir}/qt5/plugins/zanshin_part.so
78 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/krunner/org.kde.zanshin.so
79 %attr(755,root,root) %{_libdir}/qt5/plugins/pim5/kontact/kontact_zanshinplugin.so
80 %{_desktopdir}/org.kde.zanshin.desktop
81 %{_iconsdir}/hicolor/128x128/apps/zanshin.png
82 %{_iconsdir}/hicolor/256x256/apps/zanshin.png
83 %{_iconsdir}/hicolor/48x48/apps/zanshin.png
84 %{_iconsdir}/hicolor/64x64/apps/zanshin.png
85 %{_iconsdir}/hicolor/scalable/apps/zanshin.svgz
86 %{_datadir}/kxmlgui5/zanshin
87 %{_datadir}/metainfo/org.kde.zanshin.metainfo.xml
This page took 0.038061 seconds and 2 git commands to generate.