]> git.pld-linux.org Git - packages/ka5-libkdcraw.git/blob - ka5-libkdcraw.spec
- updated to 22.04.0
[packages/ka5-libkdcraw.git] / ka5-libkdcraw.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.04.0
5 %define         kframever       5.56.0
6 %define         qtver           5.9.0
7 %define         kaname          libkdcraw
8 Summary:        Libkdcraw
9 Name:           ka5-%{kaname}
10 Version:        22.04.0
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  d4dfe7d98eae4bed6c5e5627970f37f0
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
21 BuildRequires:  libraw-devel >= 0.18
22 BuildRequires:  ninja
23 BuildRequires:  qt5-build >= %{qtver}
24 BuildRequires:  rpmbuild(macros) >= 1.164
25 BuildRequires:  shared-mime-info
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Libkdcraw is a C++ interface around LibRaw library used to decode RAW
32 picture files. More information about LibRaw can be found at
33 http://www.libraw.org.
34
35 This library is used by kipi-plugins, digiKam and others kipi host
36 programs.
37
38 %description -l pl.UTF-8
39 Libkdcraw jest interfejsem C++ wokół biblioteki LibRaw używanej do
40 dekodowania plików RAW. Więcej informacji o LibRaw można znaleźć
41 na http://www.libraw.org.
42
43 Tej biblioteki używają kipi-plugins, digiKam i inne programy kipi.
44
45 %package devel
46 Summary:        Header files for %{kaname} development
47 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kpname}
48 Group:          X11/Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files for %{kaname} development.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe dla programistów używających %{kaname}.
56
57 %prep
58 %setup -q -n %{kaname}-%{version}
59
60 %build
61 install -d build
62 cd build
63 %cmake \
64         -G Ninja \
65         %{!?with_tests:-DBUILD_TESTING=OFF} \
66         -DHTML_INSTALL_DIR=%{_kdedocdir} \
67         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
68         ..
69 %ninja_build
70
71 %if %{with tests}
72 ctest
73 %endif
74
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 %ninja_install -C build
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %ghost %{_libdir}/libKF5KDcraw.so.5
89 %attr(755,root,root) %{_libdir}/libKF5KDcraw.so.*.*.*
90 %{_datadir}/qlogging-categories5/libkdcraw.categories
91
92 %files devel
93 %defattr(644,root,root,755)
94 %{_includedir}/KF5/KDCRAW
95 %{_includedir}/KF5/libkdcraw_version.h
96 %{_libdir}/cmake/KF5KDcraw
97 %{_libdir}/libKF5KDcraw.so
This page took 0.233762 seconds and 3 git commands to generate.