]> git.pld-linux.org Git - packages/ka5-ktouch.git/blob - ka5-ktouch.spec
rebuild with qt5-5.15.6
[packages/ka5-ktouch.git] / ka5-ktouch.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.08.1
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          ktouch
8 Summary:        ktouch
9 Name:           ka5-%{kaname}
10 Version:        22.08.1
11 Release:        2
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  693c0e45a3f26c98dac239f0e179f591
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel
19 BuildRequires:  Qt5Network-devel
20 BuildRequires:  Qt5Qml-devel
21 BuildRequires:  Qt5Quick-controls2-devel
22 BuildRequires:  Qt5Quick-devel
23 BuildRequires:  Qt5Script-devel
24 BuildRequires:  Qt5Sql-devel
25 BuildRequires:  Qt5Test-devel
26 BuildRequires:  Qt5Widgets-devel
27 BuildRequires:  Qt5X11Extras-devel
28 BuildRequires:  Qt5Xml-devel
29 BuildRequires:  Qt5XmlPatterns-devel
30 BuildRequires:  gettext-devel
31 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
32 BuildRequires:  kf5-kcmutils-devel >= %{kframever}
33 BuildRequires:  kf5-kcompletion-devel >= %{kframever}
34 BuildRequires:  kf5-kconfig-devel >= %{kframever}
35 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
36 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
37 BuildRequires:  kf5-kdeclarative-devel >= %{kframever}
38 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
39 BuildRequires:  kf5-ki18n-devel >= %{kframever}
40 BuildRequires:  kf5-kitemviews-devel >= %{kframever}
41 BuildRequires:  kf5-ktextwidgets-devel >= %{kframever}
42 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
43 BuildRequires:  kf5-kwindowsystem-devel >= %{kframever}
44 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
45 BuildRequires:  ninja
46 BuildRequires:  qt5-build >= %{qtver}
47 BuildRequires:  qt5-qtdeclarative >= %{qtver}
48 BuildRequires:  rpmbuild(macros) >= 1.164
49 BuildRequires:  shared-mime-info
50 BuildRequires:  tar >= 1:1.22
51 BuildRequires:  xorg-lib-libxkbfile-devel
52 BuildRequires:  xz
53 BuildRequires:  zlib-devel
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 KTouch is a program to learn and practice touch typing. Every finger
58 has its place on the keyboard with associated keys to press. Starting
59 with only a few keys to remember you will advance through different
60 training levels where additional keys are introduced.
61
62 %description -l pl.UTF-8
63 KTouch jest programem do nauki i ćwiczenia szybkiego pisania na
64 klawiaturze. Każdy palec ma swoje miejsce na klawiaturze i skojarzone
65 klawisze, które ma naciskać. Zaczynając od kilku klawiszy do
66 zapamiętania, będziesz rozwijał swoje umiejętności przez różne
67 poziomy treningu, gdzie będą wprowadzane dodatkowe klawisze.
68
69 %prep
70 %setup -q -n %{kaname}-%{version}
71
72 %build
73 install -d build
74 cd build
75 %cmake \
76         -G Ninja \
77         %{!?with_tests:-DBUILD_TESTING=OFF} \
78         -DHTML_INSTALL_DIR=%{_kdedocdir} \
79         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
80         ..
81 %ninja_build
82
83 %if %{with tests}
84 ctest
85 %endif
86
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 %ninja_install -C build
91
92 %find_lang %{kaname} --all-name --with-kde --with-qm
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files -f %{kaname}.lang
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_bindir}/ktouch
100 %{_desktopdir}/org.kde.ktouch.desktop
101 %{_datadir}/config.kcfg/ktouch.kcfg
102 %{_iconsdir}/hicolor/128x128/apps/ktouch.png
103 %{_iconsdir}/hicolor/16x16/apps/ktouch.png
104 %{_iconsdir}/hicolor/22x22/apps/ktouch.png
105 %{_iconsdir}/hicolor/32x32/apps/ktouch.png
106 %{_iconsdir}/hicolor/48x48/apps/ktouch.png
107 %{_iconsdir}/hicolor/scalable/apps/ktouch.svgz
108 %{_datadir}/ktouch
109 %{_mandir}/ca/man1/ktouch.1*
110 %{_mandir}/de/man1/ktouch.1*
111 %{_mandir}/es/man1/ktouch.1*
112 %{_mandir}/et/man1/ktouch.1*
113 %{_mandir}/fr/man1/ktouch.1*
114 %{_mandir}/gl/man1/ktouch.1*
115 %{_mandir}/it/man1/ktouch.1*
116 %{_mandir}/man1/ktouch.1*
117 %{_mandir}/nl/man1/ktouch.1*
118 %{_mandir}/pl/man1/ktouch.1*
119 %{_mandir}/pt/man1/ktouch.1*
120 %{_mandir}/pt_BR/man1/ktouch.1*
121 %{_mandir}/ru/man1/ktouch.1*
122 %{_mandir}/sv/man1/ktouch.1*
123 %{_mandir}/uk/man1/ktouch.1*
124 %{_datadir}/metainfo/org.kde.ktouch.appdata.xml
This page took 0.077588 seconds and 3 git commands to generate.