]> git.pld-linux.org Git - packages/ka5-ktnef.git/blob - ka5-ktnef.spec
ecdfb967be76df3f94a297c414c8385193ce2cd6
[packages/ka5-ktnef.git] / ka5-ktnef.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.08.1
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          ktnef
8 Summary:        ktnef
9 Name:           ka5-%{kaname}
10 Version:        22.08.1
11 Release:        2
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  ffcf705b4b9ea9bb4719fb0e91ae81a2
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= 5.11.1
19 BuildRequires:  Qt5Test-devel >= 5.9.0
20 BuildRequires:  Qt5Widgets-devel
21 BuildRequires:  gettext-devel
22 BuildRequires:  ka5-kcalutils-devel >= %{kdeappsver}
23 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
24 BuildRequires:  kf5-kcalendarcore-devel >= %{kframever}
25 BuildRequires:  kf5-kcontacts-devel >= %{kframever}
26 BuildRequires:  kf5-ki18n-devel >= %{kframever}
27 BuildRequires:  ninja
28 BuildRequires:  qt5-build >= %{qtver}
29 BuildRequires:  rpmbuild(macros) >= 1.164
30 BuildRequires:  shared-mime-info
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 BuildRequires:  zlib-devel
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 The ktnef library contains an API for the handling of TNEF data. The
38 API permits access to the actual attachments, the message properties
39 (TNEF/MAPI), and allows one to view/extract message formatted text in
40 Rich Text Format format.
41
42 %description -l pl.UTF-8
43 Biblioteka ktnef zawiera API do obsługi danych TNEF. API pozwala na
44 dostęp do załączników, właściwości wiadomości (TNEF/MAPI) i pozwala
45 podejrzeć/wyjąć wiadomość w formacie RTF.
46
47 %package devel
48 Summary:        Header files for %{kaname} development
49 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
50 Group:          X11/Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 Header files for %{kaname} development.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe dla programistów używających %{kaname}.
58
59 %prep
60 %setup -q -n %{kaname}-%{version}
61
62 %build
63 install -d build
64 cd build
65 %cmake \
66         -G Ninja \
67         %{!?with_tests:-DBUILD_TESTING=OFF} \
68         -DHTML_INSTALL_DIR=%{_kdedocdir} \
69         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
70         ..
71 %ninja_build
72
73 %if %{with tests}
74 ctest
75 %endif
76
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %ninja_install -C build
81
82 %find_lang %{kaname} --all-name --with-kde --with-qm
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files -f %{kaname}.lang
91 %defattr(644,root,root,755)
92 %ghost %{_libdir}/libKF5Tnef.so.5
93 %attr(755,root,root) %{_libdir}/libKF5Tnef.so.*.*.*
94 %{_datadir}/qlogging-categories5/ktnef.categories
95 %{_datadir}/qlogging-categories5/ktnef.renamecategories
96
97 %files devel
98 %defattr(644,root,root,755)
99 %{_includedir}/KF5/KTNEF
100 %{_libdir}/cmake/KF5Tnef
101 %{_libdir}/libKF5Tnef.so
102 %{_libdir}/qt5/mkspecs/modules/qt_KTNef.pri
This page took 0.066653 seconds and 2 git commands to generate.