]> git.pld-linux.org Git - packages/ka5-ktimer.git/blob - ka5-ktimer.spec
18086733bcd4c71fb82881a3c006399909d25476
[packages/ka5-ktimer.git] / ka5-ktimer.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.12.2
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          ktimer
8 Summary:        ktimer
9 Name:           ka5-%{kaname}
10 Version:        22.12.2
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications/Games
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  7a55d8c2ff892eb1978fc5408beb9f13
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= 5.11.1
19 BuildRequires:  Qt5Widgets-devel
20 BuildRequires:  gettext-devel
21 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
22 BuildRequires:  kf5-kdbusaddons-devel >= %{kframever}
23 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
24 BuildRequires:  kf5-ki18n-devel >= %{kframever}
25 BuildRequires:  kf5-kio-devel >= %{kframever}
26 BuildRequires:  kf5-knotifications-devel >= %{kframever}
27 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
28 BuildRequires:  ninja
29 BuildRequires:  qt5-build >= %{qtver}
30 BuildRequires:  rpmbuild(macros) >= 1.164
31 BuildRequires:  shared-mime-info
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRequires:  zlib-devel
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 KTimer is a little tool to execute programs after some time. It allows
39 you to enter several tasks and to set a timer for each of them. The
40 timers for each task can be started, stopped, changed, or looped.
41
42 %description -l pl.UTF-8
43 KTimer to mały program użytkowy do uruchamiania innych programów po
44 jakimś czasie. Pozwala wprowadzić kilka zadań i ustawić stoper dla
45 każdego z nich. Timery dla każdego zadania mogą być startowane,
46 zatrzymywane, zmieniane bądź zapętlane.
47
48 %prep
49 %setup -q -n %{kaname}-%{version}
50
51 %build
52 install -d build
53 cd build
54 %cmake \
55         -G Ninja \
56         %{!?with_tests:-DBUILD_TESTING=OFF} \
57         -DHTML_INSTALL_DIR=%{_kdedocdir} \
58         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
59         ..
60 %ninja_build
61
62 %if %{with tests}
63 ctest
64 %endif
65
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 %ninja_install -C build
70
71 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/sr
72 %find_lang %{kaname} --all-name --with-kde --with-qm
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files -f %{kaname}.lang
78 %defattr(644,root,root,755)
79 %attr(755,root,root) %{_bindir}/ktimer
80 %{_desktopdir}/org.kde.ktimer.desktop
81 %{_iconsdir}/hicolor/128x128/apps/ktimer.png
82 %{_iconsdir}/hicolor/16x16/apps/ktimer.png
83 %{_iconsdir}/hicolor/32x32/apps/ktimer.png
84 %{_iconsdir}/hicolor/48x48/apps/ktimer.png
85 %{_datadir}/metainfo/org.kde.ktimer.appdata.xml
This page took 0.046518 seconds and 2 git commands to generate.