]> git.pld-linux.org Git - packages/ka5-kpublictransport.git/blob - ka5-kpublictransport.spec
6f3266d2ec1436682773b8a7a75f0734be61bb9e
[packages/ka5-kpublictransport.git] / ka5-kpublictransport.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.12.2
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          kpublictransport
8 Summary:        A library for accessing realtime public transport data
9 Name:           ka5-%{kaname}
10 Version:        22.12.2
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  c05f1dd46df300b8835ebe467f566da3
16 URL:            https://community.kde.org/KDE_PIM/KDE_Itinerary
17 BuildRequires:  Qt5Core-devel >= 5.15.2
18 BuildRequires:  Qt5Gui-devel >= 5.15.2
19 BuildRequires:  Qt5Network-devel >= 5.15.2
20 BuildRequires:  Qt5Qml-devel >= 5.15.2
21 BuildRequires:  Qt5Quick-devel
22 BuildRequires:  kf5-extra-cmake-modules >= 5.91
23 BuildRequires:  ninja
24 BuildRequires:  polyclipping-devel
25 BuildRequires:  qt5-build >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.605
27 BuildRequires:  shared-mime-info
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 BuildRequires:  zlib-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 A library for accessing realtime public transport data and for
35 performing public transport journey queries.
36
37 This includes:
38 - Finding bus stops or train stations, departures/arrivals from there,
39   and journeys between those.
40 - Path and routing information for individual transport sections of a
41   journey.
42 - Information about train coach and train station platform layouts.
43 - Information about rental vehicle positions and availability, such as
44   shared bikes or scooters.
45 - Realtime information about the operational status of elevators or
46   escalators.
47
48 %package devel
49 Summary:        Header files for %{kaname} development
50 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
51 Group:          X11/Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 Header files for %{kaname} development.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe dla programistów używających %{kaname}.
59
60 %prep
61 %setup -q -n %{kaname}-%{version}
62
63 %build
64 install -d build
65 cd build
66 %cmake \
67         -G Ninja \
68         %{!?with_tests:-DBUILD_TESTING=OFF} \
69         -DHTML_INSTALL_DIR=%{_kdedocdir} \
70         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
71         ..
72 %ninja_build
73
74 %if %{with tests}
75 ctest
76 %endif
77
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 %ninja_install -C build
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README.md
92 %ghost %{_libdir}/libKPublicTransport.so.1
93 %attr(755,root,root) %{_libdir}/libKPublicTransport.so.*.*.*
94 %dir %{_libdir}/qt5/qml/org/kde/kpublictransport
95 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/kpublictransport/libkpublictransportqmlplugin.so
96 %{_libdir}/qt5/qml/org/kde/kpublictransport/qmldir
97 %dir %{_libdir}/qt5/qml/org/kde/kpublictransport/ui
98 %{_libdir}/qt5/qml/org/kde/kpublictransport/ui/VehicleSectionItem.qml
99 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/kpublictransport/ui/libkpublictransportquickplugin.so
100 %{_libdir}/qt5/qml/org/kde/kpublictransport/ui/qmldir
101 %{_datadir}/qlogging-categories5/org_kde_kpublictransport.categories
102
103 %files devel
104 %defattr(644,root,root,755)
105 %{_includedir}/KPublicTransport
106 %{_libdir}/cmake/KPublicTransport
107 %{_libdir}/libKPublicTransport.so
This page took 0.051087 seconds and 2 git commands to generate.