]> git.pld-linux.org Git - packages/ka5-konsole.git/blob - ka5-konsole.spec
- updated to 21.12.1
[packages/ka5-konsole.git] / ka5-konsole.spec
1 %define         kdeappsver      21.12.1
2 %define         qtver           5.15.0
3 %define         kf5ver          5.71.0
4 %define         kaname          konsole
5 Summary:        KDE Terminal Emulator
6 Name:           ka5-%{kaname}
7 Version:        21.12.1
8 Release:        1
9 License:        GPL v2+/LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
12 # Source0-md5:  7e3bced4bc815bb55e3b6d45b0abbe55
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5DBus-devel >= %{qtver}
16 BuildRequires:  Qt5PrintSupport-devel >= %{qtver}
17 BuildRequires:  Qt5Widgets-devel >= %{qtver}
18 BuildRequires:  cmake >= 3.13
19 BuildRequires:  kf5-extra-cmake-modules >= %{kf5ver}
20 BuildRequires:  kf5-kbookmarks-devel >= %{kf5ver}
21 BuildRequires:  kf5-kconfig-devel >= %{kf5ver}
22 BuildRequires:  kf5-kconfigwidgets-devel >= %{kf5ver}
23 BuildRequires:  kf5-kcoreaddons-devel >= %{kf5ver}
24 BuildRequires:  kf5-kcrash-devel >= %{kf5ver}
25 BuildRequires:  kf5-kdbusaddons-devel >= %{kf5ver}
26 BuildRequires:  kf5-kdoctools-devel >= %{kf5ver}
27 BuildRequires:  kf5-kglobalaccel-devel >= %{kf5ver}
28 BuildRequires:  kf5-kguiaddons-devel >= %{kf5ver}
29 BuildRequires:  kf5-ki18n-devel >= %{kf5ver}
30 BuildRequires:  kf5-kiconthemes-devel >= %{kf5ver}
31 BuildRequires:  kf5-kio-devel >= %{kf5ver}
32 BuildRequires:  kf5-knewstuff-devel >= %{kf5ver}
33 BuildRequires:  kf5-knotifications-devel >= %{kf5ver}
34 BuildRequires:  kf5-knotifyconfig-devel >= %{kf5ver}
35 BuildRequires:  kf5-kparts-devel >= %{kf5ver}
36 BuildRequires:  kf5-kpty-devel >= %{kf5ver}
37 BuildRequires:  kf5-kservice-devel >= %{kf5ver}
38 BuildRequires:  kf5-ktextwidgets-devel >= %{kf5ver}
39 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kf5ver}
40 BuildRequires:  kf5-kwindowsystem-devel >= %{kf5ver}
41 BuildRequires:  kf5-kxmlgui-devel >= %{kf5ver}
42 BuildRequires:  libstdc++-devel >= 6:8
43 BuildRequires:  ninja
44 BuildRequires:  qt5-build >= %{qtver}
45 BuildRequires:  rpmbuild(macros) >= 1.736
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  xorg-lib-libX11-devel
48 BuildRequires:  xz
49 Requires:       Qt5Core >= %{qtver}
50 Requires:       Qt5DBus >= %{qtver}
51 Requires:       Qt5PrintSupport >= %{qtver}
52 Requires:       Qt5Widgets >= %{qtver}
53 Requires:       kf5-kbookmarks >= %{kf5ver}
54 Requires:       kf5-kconfig >= %{kf5ver}
55 Requires:       kf5-kconfigwidgets >= %{kf5ver}
56 Requires:       kf5-kcoreaddons >= %{kf5ver}
57 Requires:       kf5-kcrash >= %{kf5ver}
58 Requires:       kf5-kdbusaddons >= %{kf5ver}
59 Requires:       kf5-kglobalaccel >= %{kf5ver}
60 Requires:       kf5-kguiaddons >= %{kf5ver}
61 Requires:       kf5-ki18n >= %{kf5ver}
62 Requires:       kf5-kiconthemes >= %{kf5ver}
63 Requires:       kf5-kio >= %{kf5ver}
64 Requires:       kf5-knewstuff >= %{kf5ver}
65 Requires:       kf5-knotifications >= %{kf5ver}
66 Requires:       kf5-knotifyconfig >= %{kf5ver}
67 Requires:       kf5-kparts >= %{kf5ver}
68 Requires:       kf5-kpty >= %{kf5ver}
69 Requires:       kf5-kservice >= %{kf5ver}
70 Requires:       kf5-ktextwidgets >= %{kf5ver}
71 Requires:       kf5-kwidgetsaddons >= %{kf5ver}
72 Requires:       kf5-kwindowsystem >= %{kf5ver}
73 Requires:       kf5-kxmlgui >= %{kf5ver}
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 Konsole is a terminal emulator.
78
79 Features
80
81 • Tabs • Multiple profiles • Silence and Activity monitoring •
82 Bookmark support • Searching • Saving output
83
84 %description -l pl.UTF-8
85 Konsole jest emulatorem terminala.
86
87 Cechy
88
89 • Karty • Wiele profili • Monitoring ciszy i aktywności • Zakładki •
90 Szukanie • Zapisywanie danych wyjściowych
91
92 %prep
93 %setup -q -n %{kaname}-%{version}
94
95 %build
96 install -d build
97 cd build
98 %cmake \
99         -G Ninja \
100         -DHTML_INSTALL_DIR=%{_kdedocdir} \
101         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
102         ..
103 %ninja_build
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 %ninja_install -C build
108
109 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/{sr,zh_CN}
110 %find_lang %{kaname} --all-name --with-kde
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files -f %{kaname}.lang
119 %defattr(644,root,root,755)
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_bindir}/konsole
122 %attr(755,root,root) %{_bindir}/konsoleprofile
123 %ghost %{_libdir}/libkonsoleprivate.so.1
124 %{_libdir}/libkonsoleprivate.so.*.*.*
125 %ghost %{_libdir}/libkonsoleapp.so.1
126 %{_libdir}/libkonsoleapp.so.*.*.*
127 %attr(755,root,root) %{_libdir}/qt5/plugins/konsolepart.so
128 %dir %{_libdir}/qt5/plugins/konsoleplugins
129 %attr(755,root,root) %{_libdir}/qt5/plugins/konsoleplugins/konsole_sshmanagerplugin.so
130 %{_datadir}/metainfo/org.kde.konsole.appdata.xml
131 %{_desktopdir}/org.kde.konsole.desktop
132 %{_datadir}/knotifications5/konsole.notifyrc
133 %{_datadir}/konsole
134 %{_datadir}/kservices5/ServiceMenus/konsolerun.desktop
135 %{_datadir}/kservices5/konsolepart.desktop
136 %{_datadir}/kservicetypes5/terminalemulator.desktop
137 %{_datadir}/khotkeys/konsole.khotkeys
138 %{_datadir}/knsrcfiles/konsole.knsrc
139 %{_datadir}/qlogging-categories5/konsole.categories
This page took 0.052139 seconds and 3 git commands to generate.