]> git.pld-linux.org Git - packages/ka5-kmouth.git/blob - ka5-kmouth.spec
279156139e3ccda1080812120fa7bb4a37c39ac4
[packages/ka5-kmouth.git] / ka5-kmouth.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      24.01.95
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          kmouth
8 Summary:        kmouth
9 Name:           ka5-%{kaname}
10 Version:        24.01.95
11 Release:        0.1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications
14 Source0:        https://download.kde.org/unstable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  337771ebb8821feace0739e505f3f092
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt6Core-devel >= %{qtver}
18 BuildRequires:  Qt6Gui-devel >= 5.11.1
19 BuildRequires:  Qt6PrintSupport-devel
20 BuildRequires:  Qt6TextToSpeech-devel
21 BuildRequires:  Qt6Widgets-devel
22 BuildRequires:  Qt6Xml-devel
23 BuildRequires:  gettext-devel
24 BuildRequires:  kf6-extra-cmake-modules >= %{kframever}
25 BuildRequires:  kf6-kcompletion-devel >= %{kframever}
26 BuildRequires:  kf6-kconfig-devel >= %{kframever}
27 BuildRequires:  kf6-kconfigwidgets-devel >= %{kframever}
28 BuildRequires:  kf6-kcoreaddons-devel >= %{kframever}
29 BuildRequires:  kf6-kcrash-devel >= %{kframever}
30 BuildRequires:  kf6-kdoctools-devel >= %{kframever}
31 BuildRequires:  kf6-ki18n-devel >= %{kframever}
32 BuildRequires:  kf6-kio-devel >= %{kframever}
33 BuildRequires:  kf6-kwidgetsaddons-devel >= %{kframever}
34 BuildRequires:  kf6-kxmlgui-devel >= %{kframever}
35 BuildRequires:  ninja
36 BuildRequires:  qt6-build >= %{qtver}
37 BuildRequires:  rpmbuild(macros) >= 1.164
38 BuildRequires:  shared-mime-info
39 BuildRequires:  tar >= 1:1.22
40 BuildRequires:  xz
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 KMouth is a program which enables persons that cannot speak to let
45 their computer speak, e.g. mutal people or people who have lost their
46 voice. It has a text input field and speaks the sentences that you
47 enter. It also has support for user defined phrasebooks.
48
49 %description -l pl.UTF-8
50 KMouth jest programem, który pozwala osobom, które nie mogą
51 mówić, by komputer mówił za nich, np, niemowom, lub osobom, które
52 straciły głos. Program ma pole tekstowe i wymawia zdania wprowadzane
53 z klawiatury. Wspiera też listę wyrażeń definiowanych przez
54 użytkownika.
55
56 %prep
57 %setup -q -n %{kaname}-%{version}
58
59 %build
60 %cmake \
61         -B build \
62         -G Ninja \
63         %{!?with_tests:-DBUILD_TESTING=OFF} \
64         -DHTML_INSTALL_DIR=%{_kdedocdir} \
65         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
66 %ninja_build -C build
67
68 %if %{with tests}
69 ctest --test-dir build
70 %endif
71
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %ninja_install -C build
76
77 %find_lang %{kaname} --all-name --with-kde
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files -f %{kaname}.lang
83 %defattr(644,root,root,755)
84 /etc/xdg/kmouthrc
85 %attr(755,root,root) %{_bindir}/kmouth
86 %{_desktopdir}/org.kde.kmouth.desktop
87 %{_iconsdir}/hicolor/*x*/actions/*.png
88 %{_iconsdir}/hicolor/*x*/apps/*.png
89 %{_datadir}/kmouth
90 %{_datadir}/metainfo/org.kde.kmouth.appdata.xml
91 %lang(ca) %{_mandir}/ca/man1/kmouth.1*
92 %lang(da) %{_mandir}/da/man1/kmouth.1*
93 %lang(de) %{_mandir}/de/man1/kmouth.1*
94 %lang(es) %{_mandir}/es/man1/kmouth.1*
95 %lang(et) %{_mandir}/et/man1/kmouth.1*
96 %lang(fr) %{_mandir}/fr/man1/kmouth.1*
97 %lang(it) %{_mandir}/it/man1/kmouth.1*
98 %lang(C) %{_mandir}/man1/kmouth.1*
99 %lang(nl) %{_mandir}/nl/man1/kmouth.1*
100 %lang(pt) %{_mandir}/pt/man1/kmouth.1*
101 %lang(pt_BR) %{_mandir}/pt_BR/man1/kmouth.1*
102 %lang(ru) %{_mandir}/ru/man1/kmouth.1.*
103 %lang(sv) %{_mandir}/sv/man1/kmouth.1*
104 %lang(uk) %{_mandir}/uk/man1/kmouth.1*
This page took 0.037377 seconds and 2 git commands to generate.