]> git.pld-linux.org Git - packages/ka5-kmouth.git/blob - ka5-kmouth.spec
- updated to 22.08.0
[packages/ka5-kmouth.git] / ka5-kmouth.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.08.0
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          kmouth
8 Summary:        kmouth
9 Name:           ka5-%{kaname}
10 Version:        22.08.0
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  a8ba7e104de00f4b4d86039f231f21c3
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= 5.11.1
19 BuildRequires:  Qt5PrintSupport-devel
20 BuildRequires:  Qt5Speech-devel
21 BuildRequires:  Qt5Widgets-devel
22 BuildRequires:  Qt5Xml-devel
23 BuildRequires:  gettext-devel
24 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
25 BuildRequires:  kf5-kcompletion-devel >= %{kframever}
26 BuildRequires:  kf5-kconfig-devel >= %{kframever}
27 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
28 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
29 BuildRequires:  kf5-kcrash-devel >= %{kframever}
30 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
31 BuildRequires:  kf5-ki18n-devel >= %{kframever}
32 BuildRequires:  kf5-kio-devel >= %{kframever}
33 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
34 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
35 BuildRequires:  ninja
36 BuildRequires:  qt5-build >= %{qtver}
37 BuildRequires:  rpmbuild(macros) >= 1.164
38 BuildRequires:  shared-mime-info
39 BuildRequires:  tar >= 1:1.22
40 BuildRequires:  xz
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 KMouth is a program which enables persons that cannot speak to let
45 their computer speak, e.g. mutal people or people who have lost their
46 voice. It has a text input field and speaks the sentences that you
47 enter. It also has support for user defined phrasebooks.
48
49 %description -l pl.UTF-8
50 KMouth jest programem, który pozwala osobom, które nie mogą
51 mówić, by komputer mówił za nich, np, niemowom, lub osobom, które
52 straciły głos. Program ma pole tekstowe i wymawia zdania wprowadzane
53 z klawiatury. Wspiera też listę wyrażeń definiowanych przez
54 użytkownika.
55
56 %prep
57 %setup -q -n %{kaname}-%{version}
58
59 %build
60 install -d build
61 cd build
62 %cmake \
63         -G Ninja \
64         %{!?with_tests:-DBUILD_TESTING=OFF} \
65         -DHTML_INSTALL_DIR=%{_kdedocdir} \
66         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
67         ..
68 %ninja_build
69
70 %if %{with tests}
71 ctest
72 %endif
73
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 %ninja_install -C build
78
79 %find_lang %{kaname} --all-name --with-kde
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files -f %{kaname}.lang
85 %defattr(644,root,root,755)
86 /etc/xdg/kmouthrc
87 %attr(755,root,root) %{_bindir}/kmouth
88 %{_desktopdir}/org.kde.kmouth.desktop
89 %{_iconsdir}/hicolor/16x16/actions/phrase.png
90 %{_iconsdir}/hicolor/16x16/actions/phrasebook.png
91 %{_iconsdir}/hicolor/16x16/apps/kmouth.png
92 %{_iconsdir}/hicolor/22x22/actions/phrase.png
93 %{_iconsdir}/hicolor/22x22/actions/phrasebook.png
94 %{_iconsdir}/hicolor/22x22/apps/kmouth.png
95 %{_iconsdir}/hicolor/32x32/actions/phrase.png
96 %{_iconsdir}/hicolor/32x32/actions/phrasebook.png
97 %{_iconsdir}/hicolor/32x32/apps/kmouth.png
98 %{_iconsdir}/hicolor/48x48/apps/kmouth.png
99 %{_datadir}/kmouth
100 %dir %{_datadir}/kxmlgui5/kmouth
101 %{_datadir}/kxmlgui5/kmouth/kmouthui.rc
102 %{_datadir}/kxmlgui5/kmouth/phrasebookdialogui.rc
103 %{_datadir}/metainfo/org.kde.kmouth.appdata.xml
104 %lang(ca) %{_mandir}/ca/man1/kmouth.1*
105 %lang(da) %{_mandir}/da/man1/kmouth.1*
106 %lang(de) %{_mandir}/de/man1/kmouth.1*
107 %lang(es) %{_mandir}/es/man1/kmouth.1*
108 %lang(et) %{_mandir}/et/man1/kmouth.1*
109 %lang(fr) %{_mandir}/fr/man1/kmouth.1*
110 %lang(it) %{_mandir}/it/man1/kmouth.1*
111 %lang(C) %{_mandir}/man1/kmouth.1*
112 %lang(nl) %{_mandir}/nl/man1/kmouth.1*
113 %lang(pt) %{_mandir}/pt/man1/kmouth.1*
114 %lang(pt_BR) %{_mandir}/pt_BR/man1/kmouth.1*
115 %lang(ru) %{_mandir}/ru/man1/kmouth.1.*
116 %lang(sv) %{_mandir}/sv/man1/kmouth.1*
117 %lang(uk) %{_mandir}/uk/man1/kmouth.1*
This page took 0.075517 seconds and 3 git commands to generate.