]> git.pld-linux.org Git - packages/ka5-kmbox.git/blob - ka5-kmbox.spec
5de94ea7199be4a93fe3eb59a0d51bbfcd21abff
[packages/ka5-kmbox.git] / ka5-kmbox.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      21.12.3
5 %define         kframever       5.56.0
6 %define         qtver           5.9.0
7 %define         kaname          kmbox
8 Summary:        Kmbox
9 Name:           ka5-%{kaname}
10 Version:        21.12.3
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications
14 Source0:        http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  45398b89a3c3d650fcb399afe32d686b
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Test-devel
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  ka5-kmime-devel >= %{kdeappsver}
21 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
22 BuildRequires:  ninja
23 BuildRequires:  qt5-build >= %{qtver}
24 BuildRequires:  rpmbuild(macros) >= 1.164
25 BuildRequires:  shared-mime-info
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Library which provides support for mail apps.
32
33 %description -l pl.UTF-8
34 Biblioteka ze wsparciem dla programów pocztowych.
35
36 %package devel
37 Summary:        Header files for %{kaname} development
38 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
39 Group:          X11/Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 Header files for %{kaname} development.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe dla programistów używających %{kaname}.
47
48 %prep
49 %setup -q -n %{kaname}-%{version}
50
51 %build
52 install -d build
53 cd build
54 %cmake -G Ninja \
55         %{!?with_tests:-DBUILD_TESTING=OFF} \
56         -DHTML_INSTALL_DIR=%{_kdedocdir} \
57         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
58         ..
59 %ninja_build
60
61 %if %{with tests}
62 ctest
63 %endif
64
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %ninja_install -C build
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post   -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files
77 %defattr(644,root,root,755)
78 %ghost %{_libdir}/libKF5Mbox.so.5
79 %attr(755,root,root) %{_libdir}/libKF5Mbox.so.*.*.*
80 %{_datadir}/qlogging-categories5/kmbox.categories
81 %{_datadir}/qlogging-categories5/kmbox.renamecategories
82
83 %files devel
84 %defattr(644,root,root,755)
85 %{_includedir}/KF5/KMbox
86 %{_includedir}/KF5/kmbox_version.h
87 %{_libdir}/cmake/KF5Mbox
88 %{_libdir}/libKF5Mbox.so
89 %{_libdir}/qt5/mkspecs/modules/qt_KMbox.pri
This page took 0.071861 seconds and 2 git commands to generate.