]> git.pld-linux.org Git - packages/ka5-klines.git/blob - ka5-klines.spec
- updated to 22.12.3
[packages/ka5-klines.git] / ka5-klines.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.12.3
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          klines
8 Summary:        klines
9 Name:           ka5-%{kaname}
10 Version:        22.12.3
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications/Games
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  d3152fc72ce7fd972b2bece867854387
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= 5.11.1
19 BuildRequires:  Qt5Qml-devel >= 5.11.1
20 BuildRequires:  Qt5Quick-devel >= 5.11.1
21 BuildRequires:  Qt5Widgets-devel
22 BuildRequires:  cmake >= 2.8.12
23 BuildRequires:  gettext-devel
24 BuildRequires:  ka5-libkdegames-devel >= %{kdeappsver}
25 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
26 BuildRequires:  kf5-kconfig-devel >= %{kframever}
27 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
28 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
29 BuildRequires:  kf5-kcrash-devel >= %{kframever}
30 BuildRequires:  kf5-kdbusaddons-devel >= %{kframever}
31 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
32 BuildRequires:  kf5-ki18n-devel >= %{kframever}
33 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
34 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
35 BuildRequires:  ninja
36 BuildRequires:  qt5-build >= %{qtver}
37 BuildRequires:  rpmbuild(macros) >= 1.164
38 BuildRequires:  shared-mime-info
39 BuildRequires:  tar >= 1:1.22
40 BuildRequires:  xz
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 KLines is a simple but highly addictive one player game. The player
45 has to move the colored balls around the game board, gathering them
46 into the lines of the same color by five. Once the line is complete it
47 is removed from the board, therefore freeing precious space.
48
49 %description -l pl.UTF-8
50 KLines jest prostą albo bardzo wciągającą grą dla jednej osoby. Gracz
51 ma przemieszczać kolorowe piłki po planszy, zbierając je po pięć
52 w linii jednego koloru. Kompletne linie są usuwane z planszy
53 zwalniając cenne miejsce.
54
55 %prep
56 %setup -q -n %{kaname}-%{version}
57
58 %build
59 install -d build
60 cd build
61 %cmake \
62         -G Ninja \
63         %{!?with_tests:-DBUILD_TESTING=OFF} \
64         -DHTML_INSTALL_DIR=%{_kdedocdir} \
65         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
66         ..
67 %ninja_build
68
69 %if %{with tests}
70 ctest
71 %endif
72
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 %ninja_install -C build
77
78 %find_lang %{kaname} --all-name --with-kde
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files -f %{kaname}.lang
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_bindir}/klines
86 %{_desktopdir}/org.kde.klines.desktop
87 %{_datadir}/config.kcfg/klines.kcfg
88 %{_iconsdir}/hicolor/128x128/apps/klines.png
89 %{_iconsdir}/hicolor/16x16/apps/klines.png
90 %{_iconsdir}/hicolor/22x22/apps/klines.png
91 %{_iconsdir}/hicolor/32x32/apps/klines.png
92 %{_iconsdir}/hicolor/48x48/apps/klines.png
93 %{_iconsdir}/hicolor/64x64/apps/klines.png
94 %{_datadir}/klines
95 %{_datadir}/metainfo/org.kde.klines.appdata.xml
96 %{_datadir}/qlogging-categories5/klines.categories
This page took 0.132731 seconds and 3 git commands to generate.