]> git.pld-linux.org Git - packages/ka5-kdevelop.git/blob - ka5-kdevelop.spec
7e4e90da4623881ce7d78267248ba771a8796216
[packages/ka5-kdevelop.git] / ka5-kdevelop.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4
5 %define         kdeappsver      22.04.1
6 %define         kframever       5.78.0
7 %define         qtver           5.15.0
8 %define         kaname          kdevelop
9
10 Summary:        KDE Integrated Development Environment
11 Summary(de.UTF-8):      KDevelop ist eine grafische Entwicklungsumgebung für KDE
12 Summary(pl.UTF-8):      Zintegrowane środowisko programisty dla KDE
13 Summary(pt_BR.UTF-8):   Ambiente Integrado de Desenvolvimento para o KDE
14 Summary(zh_CN.UTF-8):   KDE C/C++集成开发环境
15 Name:           ka5-kdevelop
16 Version:        22.04.1
17 Release:        1
18 License:        GPL
19 Group:          X11/Development/Tools
20 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
21 # Source0-md5:  c25d8e355ef3a2f5835c752032ac3cb0
22 URL:            http://www.kdevelop.org/
23 BuildRequires:  Qt5Help-devel >= %{qtver}
24 BuildRequires:  Qt5WebEngine-devel >= %{qtver}
25 BuildRequires:  astyle-devel >= 3.1
26 BuildRequires:  clang-devel
27 BuildRequires:  cmake >= 2.8.9
28 BuildRequires:  docbook-dtd45-xml
29 BuildRequires:  docbook-style-xsl
30 BuildRequires:  gettext-tools
31 BuildRequires:  ka5-libkomparediff2-devel
32 BuildRequires:  ka5-okteta-devel
33 BuildRequires:  kf5-kcrash-devel >= %{kframever}
34 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
35 BuildRequires:  kf5-krunner-devel >= %{kframever}
36 BuildRequires:  kf5-plasma-framework-devel >= %{kframever}
37 BuildRequires:  kf5-syntax-highlighting-devel >= %{kframever}
38 BuildRequires:  kp5-libksysguard-devel
39 BuildRequires:  qt5-assistant >= %{qtver}
40
41 BuildRequires:  libstdc++-devel >= 3.3
42 BuildRequires:  ninja
43 BuildRequires:  pkgconfig
44 BuildRequires:  rpmbuild(macros) >= 1.600
45 BuildRequires:  zlib-devel >= 1.2.0
46 BuildConflicts: star
47 Requires:       libstdc++-gdb
48 Requires(post,postun):  desktop-file-utils
49 Requires(post,postun):  shared-mime-info
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         _noautoreqfiles .*\\.zshrc
53
54 %description
55 The KDevelop Integrated Development Environment provides many features
56 that developers need as well as providing a unified interface to
57 programs like gdb, the C/C++ compiler, and make.
58
59 KDevelop manages or provides: all development tools needed for C++
60 programming like Compiler, Linker, automake and autoconf; KAppWizard,
61 which generates complete, ready-to-go sample applications;
62 Classgenerator, for creating new classes and integrating them into the
63 current project; File management for sources, headers, documentation
64 etc. to be included in the project; The creation of User-Handbooks
65 written with SGML and the automatic generation of HTML-output with the
66 KDE look and feel; Automatic HTML-based API-documentation for your
67 project's classes with cross-references to the used libraries;
68 Internationalization support for your application, allowing
69 translators to easily add their target language to a project;
70
71 KDevelop also includes WYSIWYG (What you see is what you get)-creation
72 of user interfaces with a built-in dialog editor; Debugging your
73 application by integrating KDbg; Editing of project-specific pixmaps
74 with KIconEdit; The inclusion of any other program you need for
75 development by adding it to the "Tools"-menu according to your
76 individual needs.
77
78 %description -l de.UTF-8
79 KDevelop ist eine grafische Entwicklungsumgebung für KDE.
80
81 Das KDevelop-Projekt wurde 1998 begonnen, um eine einfach zu
82 bedienende grafische (integrierte) Entwicklungsumgebung für C++ und C
83 auf Unix-basierten Betriebssystemen bereitzustellen. Seit damals ist
84 die KDevelop-IDE öffentlich unter der GPL erhältlich und unterstützt
85 u. a. Qt-, KDE-, GNOME-, C++- und C-Projekte.
86
87 %description -l pl.UTF-8
88 KDevelop to zintegrowane środowisko programistyczne dla KDE, dające
89 wiele możliwości przydatnych programistom oraz zunifikowany interfejs
90 do programów typu gdb, kompilator C/C++ oraz make.
91
92 KDevelop obsługuje lub zawiera: wszystkie narzędzia programistyczne
93 potrzebne do programowania w C++ jak kompilator, linker, automake,
94 autoconf; KAppWizard, generujący kompletne, gotowe do uruchomienia,
95 proste aplikacje; Classgenerator do tworzenia nowych klas i włączania
96 ich do projektu; zarządzanie plikami źródłowymi, nagłówkowymi,
97 dokumentacją itp.; tworzenie podręczników użytkownika pisanych w SGML
98 i automatyczne generowanie wyjścia HTML pasującego do KDE;
99 automatyczne tworzenie dokumentacji API w HTML do klas projektu z
100 odniesieniami do używanych bibliotek; wsparcie dla
101 internacjonalizacji, pozwalające tłumaczom łatwo dodawać pliki z
102 tłumaczeniami do projektu.
103
104 KDevelop ma także tworzenie interfejsów użytkownika przy użyciu
105 edytora dialogów WYSIWYG; odpluskwianie aplikacji poprzez integrację z
106 KDbg; edycję ikon przy pomocy KIconEdit; dołączanie innych programów
107 potrzebnych do programowania przez dodanie ich do menu Tools według
108 własnych potrzeb.
109
110 %package devel
111 Summary:        kdevelop - header files and development documentation
112 Summary(pl.UTF-8):      kdevelop - pliki nagłówkowe i dokumentacja
113 Group:          X11/Development/Libraries
114 Requires:       %{name} = %{version}-%{release}
115
116 %description devel
117 This package contains header files and development documentation for
118 kdevelop.
119
120 %description devel -l pl.UTF-8
121 Pakiet ten zawiera pliki nagłówkowe i dokumentację potrzebną przy
122 pisaniu własnych programów wykorzystujących kdevelop.
123
124 %package -n bash-completion-kdevelop
125 Summary:        Bash completion for KDevelop commands
126 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń KDevelop
127 Group:          Applications/Shells
128 Requires:       %{name} = %{version}-%{release}
129 Requires:       bash-completion >= 2.0
130 %{?noarchpackage}
131
132 %description -n bash-completion-kdevelop
133 Bash completion for KDevelop commands.
134
135 %description -n bash-completion-kdevelop -l pl.UTF-8
136 Bashowe uzupełnianie parametrów dla poleceń KDevelop.
137
138 %prep
139 %setup -q -n %{kaname}-%{version}
140
141 %build
142 install -d build
143 cd build
144 %cmake \
145         -G Ninja \
146         %{!?with_tests:-DBUILD_TESTING=OFF} \
147         -DHTML_INSTALL_DIR=%{_kdedocdir} \
148         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
149         -DFORCE_BASH_COMPLETION_INSTALLATION=ON \
150         ..
151 %ninja_build
152
153 %if %{with tests}
154 ctest
155 %endif
156
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 %ninja_install -C build
161
162 %find_lang %{kaname} --all-name --with-kde
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post
168 /sbin/ldconfig
169 %update_mime_database
170 %update_desktop_database
171
172 %postun
173 /sbin/ldconfig
174 %update_mime_database
175 %update_desktop_database_postun
176
177 %files -f %{kaname}.lang
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_bindir}/kdevelop
180 %attr(755,root,root) %{_bindir}/kdevelop!
181 %attr(755,root,root) %{_bindir}/kdev_includepathsconverter
182 %attr(755,root,root) %{_libdir}/libKDevClangPrivate.so.*
183 %attr(755,root,root) %{_libdir}/libKDevCMakeCommon.so.*
184 %attr(755,root,root) %{_libdir}/libKDevCompileAnalyzerCommon.so.*
185 %attr(755,root,root) %{_libdir}/libKDevelopSessionsWatch.so
186 %dir %{_libdir}/qt5/plugins/kf5/krunner
187 %attr(755,root,root) %{_libdir}/qt5/plugins/kf5/krunner/krunner_kdevelopsessions.so
188 %dir %{_libdir}/qt5/qml/org/kde/plasma/private/kdevelopsessions
189 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/plasma/private/kdevelopsessions/libkdevelopsessionsplugin.so
190 %{_libdir}/qt5/qml/org/kde/plasma/private/kdevelopsessions/qmldir
191 %dir %{_datadir}/kdevplatform
192 %dir %{_datadir}/kdevplatform/shellutils
193 %{_datadir}/kdevplatform/shellutils/.zshrc
194 %{_datadir}/kdevappwizard
195 %{_datadir}/kdevclangsupport
196 %{_datadir}/kdevelop
197 %{_datadir}/kdevfiletemplates
198 %{_datadir}/kdevgdb
199 %{_datadir}/kdevlldb
200 %{_datadir}/kdevmanpage
201 %{_datadir}/kdevqmljssupport
202 %{_datadir}/knotifications5/*
203 %{_datadir}/knsrcfiles/kdev*.knsrc
204 %{_datadir}/metainfo/*
205 %{_datadir}/mime/packages/*
206 %{_datadir}/kservices5/*
207 %{_datadir}/plasma/plasmoids/kdevelopsessions
208 %{_desktopdir}/org.kde.kdevelop.desktop
209 %{_desktopdir}/org.kde.kdevelop_*.desktop
210 %{_iconsdir}/*/*x*/*/*.png
211 %{_datadir}/qlogging-categories5/kdev*.categories
212
213 #kdevplatform
214 %attr(755,root,root) %{_bindir}/kdev_dbus_socket_transformer
215 %attr(755,root,root) %{_bindir}/kdev_format_source
216 %attr(755,root,root) %{_bindir}/kdevplatform_shell_environment.sh
217 %attr(755,root,root) %{_libdir}/libKDevPlatformDebugger.so.*.*.*
218 %ghost %{_libdir}/libKDevPlatformDebugger.so.??
219 %attr(755,root,root) %{_libdir}/libKDevPlatformDocumentation.so.*.*.*
220 %ghost %{_libdir}/libKDevPlatformDocumentation.so.??
221 %attr(755,root,root) %{_libdir}/libKDevPlatformInterfaces.so.*.*.*
222 %ghost %{_libdir}/libKDevPlatformInterfaces.so.??
223 %attr(755,root,root) %{_libdir}/libKDevPlatformLanguage.so.*.*.*
224 %ghost %{_libdir}/libKDevPlatformLanguage.so.??
225 %attr(755,root,root) %{_libdir}/libKDevPlatformOutputView.so.*.*.*
226 %ghost %{_libdir}/libKDevPlatformOutputView.so.??
227 %attr(755,root,root) %{_libdir}/libKDevPlatformProject.so.*.*.*
228 %ghost %{_libdir}/libKDevPlatformProject.so.??
229 %attr(755,root,root) %{_libdir}/libKDevPlatformSerialization.so.*.*.*
230 %ghost %{_libdir}/libKDevPlatformSerialization.so.??
231 %attr(755,root,root) %{_libdir}/libKDevPlatformShell.so.*.*.*
232 %ghost %{_libdir}/libKDevPlatformShell.so.??
233 %attr(755,root,root) %{_libdir}/libKDevPlatformSublime.so.*.*.*
234 %ghost %{_libdir}/libKDevPlatformSublime.so.??
235 %attr(755,root,root) %{_libdir}/libKDevPlatformUtil.so.*.*.*
236 %ghost %{_libdir}/libKDevPlatformUtil.so.??
237 %attr(755,root,root) %{_libdir}/libKDevPlatformVcs.so.*.*.*
238 %ghost %{_libdir}/libKDevPlatformVcs.so.??
239 %attr(755,root,root) %{_libdir}/qt5/plugins/grantlee/*/kdev_filters.so
240
241 %attr(755,root,root) %{_libdir}/qt5/plugins/kdevplatform/*/kdev*.so
242
243 %{_libdir}/qt5/qml/org/kde/kdevplatform/qmldir
244 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/kdevplatform/libkdevelopdashboarddeclarativeplugin.so
245 %{_datadir}/kdevcodegen
246 %{_datadir}/kdevcodeutils
247 %{_datadir}/kservicetypes5/kdevelopplugin.desktop
248 %{_iconsdir}/hicolor/*/actions/*.svg
249 %{_iconsdir}/hicolor/*/apps/*.svg
250
251
252 %files devel
253 %defattr(644,root,root,755)
254 %{_libdir}/cmake/KDevelop
255 %{_includedir}/kdevelop
256
257 #kdevplatform
258 %{_includedir}/kdevplatform
259 %{_libdir}/libKDevPlatformDebugger.so
260 %{_libdir}/libKDevPlatformDocumentation.so
261 %{_libdir}/libKDevPlatformInterfaces.so
262 %{_libdir}/libKDevPlatformLanguage.so
263 %{_libdir}/libKDevPlatformOutputView.so
264 %{_libdir}/libKDevPlatformProject.so
265 %{_libdir}/libKDevPlatformSerialization.so
266 %{_libdir}/libKDevPlatformShell.so
267 %{_libdir}/libKDevPlatformSublime.so
268 %{_libdir}/libKDevPlatformUtil.so
269 %{_libdir}/libKDevPlatformVcs.so
270 %dir %{_libdir}/cmake/KDevPlatform
271 %{_libdir}/cmake/KDevPlatform/KDevPlatformConfig.cmake
272 %{_libdir}/cmake/KDevPlatform/KDevPlatformConfigVersion.cmake
273 %{_libdir}/cmake/KDevPlatform/KDevPlatformMacros.cmake
274 %{_libdir}/cmake/KDevPlatform/KDevPlatformTargets.cmake
275 %{_libdir}/cmake/KDevPlatform/KDevPlatformTargets-pld.cmake
276
277 %files -n bash-completion-kdevelop
278 %defattr(644,root,root,755)
279 %{bash_compdir}/kdevelop
This page took 0.217209 seconds and 2 git commands to generate.