]> git.pld-linux.org Git - packages/ka5-kcalcore.git/blob - ka5-kcalcore.spec
- updated to 19.04.1
[packages/ka5-kcalcore.git] / ka5-kcalcore.spec
1 %define         kdeappsver      19.04.1
2 %define         qtver           5.9.0
3 %define         kaname          kcalcore
4 Summary:        kcalcore
5 Name:           ka5-%{kaname}
6 Version:        19.04.1
7 Release:        1
8 License:        GPL v2+/LGPL v2.1+
9 Group:          X11/Libraries
10 Source0:        http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
11 # Source0-md5:  8719a91a0a333d4da2ede7e478cd3c20
12 URL:            http://www.kde.org/
13 BuildRequires:  Qt5Core-devel >= %{qtver}
14 BuildRequires:  Qt5Gui-devel
15 BuildRequires:  Qt5Test-devel >= 5.9.0
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  kf5-extra-cmake-modules >= 5.53.0
18 BuildRequires:  libical-devel >= 2.0
19 BuildRequires:  ninja
20 BuildRequires:  qt5-build >= %{qtver}
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  shared-mime-info
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This library provides access to and handling of calendar data. It
29 supports the standard formats iCalendar and vCalendar and the group
30 scheduling standard iTIP.
31
32 A calendar contains information like incidences (events, to-dos,
33 journals), alarms, time zones, and other useful information. This API
34 provides access to that calendar information via well known calendar
35 formats iCalendar (or iCal) and the oolder vCalendar.
36
37 %package devel
38 Summary:        Header files for %{kaname} development
39 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
40 Group:          X11/Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for %{kaname} development.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe dla programistów używających %{kaname}.
48
49 %prep
50 %setup -q -n %{kaname}-%{version}
51
52 %build
53 install -d build
54 cd build
55 %cmake -G Ninja \
56         -DHTML_INSTALL_DIR=%{_kdedocdir} \
57         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
58         ..
59 %ninja_build
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 %ninja_install -C build
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post   -p /sbin/ldconfig
69 %postun -p /sbin/ldconfig
70
71 %files
72 %defattr(644,root,root,755)
73 /etc/xdg/kcalcore.categories
74 /etc/xdg/kcalcore.renamecategories
75 %attr(755,root,root) %ghost %{_libdir}/libKF5CalendarCore.so.5
76 %attr(755,root,root) %{_libdir}/libKF5CalendarCore.so.5.*.*
77
78 %files devel
79 %defattr(644,root,root,755)
80 %{_includedir}/KF5/KCalCore
81 %{_includedir}/KF5/kcalcore_version.h
82 %{_libdir}/cmake/KF5CalendarCore
83 %attr(755,root,root) %{_libdir}/libKF5CalendarCore.so
84 %{_libdir}/qt5/mkspecs/modules/qt_KCalCore.pri
This page took 0.05599 seconds and 3 git commands to generate.