]> git.pld-linux.org Git - packages/ka5-kcalc.git/blob - ka5-kcalc.spec
1429642c0665e957d5d173ac245b1906ef7982dd
[packages/ka5-kcalc.git] / ka5-kcalc.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      21.12.3
5 %define         kframever       5.56.0
6 %define         qtver           5.9.0
7 %define         kaname          kcalc
8 Summary:        Kcalc
9 Name:           ka5-%{kaname}
10 Version:        21.12.3
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications
14 Source0:        http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  cb113fa48c64877d1bbb2a6fd3a6dfda
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= 5.11.1
19 BuildRequires:  Qt5Widgets-devel
20 BuildRequires:  cmake >= 2.8.12
21 BuildRequires:  gettext-devel
22 BuildRequires:  gmp-devel
23 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
24 BuildRequires:  kf5-kconfig-devel >= %{kframever}
25 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
26 BuildRequires:  kf5-kcrash-devel >= %{kframever}
27 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
28 BuildRequires:  kf5-kguiaddons-devel >= %{kframever}
29 BuildRequires:  kf5-ki18n-devel >= %{kframever}
30 BuildRequires:  kf5-kinit-devel >= %{kframever}
31 BuildRequires:  kf5-knotifications-devel >= %{kframever}
32 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
33 BuildRequires:  ninja
34 BuildRequires:  qt5-build >= %{qtver}
35 BuildRequires:  rpmbuild(macros) >= 1.164
36 BuildRequires:  shared-mime-info
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  xz
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 KCalc is a calculator which offers many more mathematical functions
43 than meet the eye on a first glance.. Features. The usual
44 functionality offered by most scientific calculators; Trigonometric
45 functions, logic operations, and statistical calculations.
46
47 %description -l pl.UTF-8
48 KCalc jest kalkulatorem, które oferuje wiele więcej funkcji
49 matematycznych niż widać na pierwszy rzut oka.
50 Właściwości: zwyczajna funkcjonalność oferowana przez większość
51 kalkulatorów naukowych; funkcje trygonometryczne, operacje logiczne,
52 obliczania statystyczne.
53
54 %prep
55 %setup -q -n %{kaname}-%{version}
56
57 %build
58 install -d build
59 cd build
60 %cmake \
61         -G Ninja \
62         %{!?with_tests:-DBUILD_TESTING=OFF} \
63         -DHTML_INSTALL_DIR=%{_kdedocdir} \
64         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
65         ..
66 %ninja_build
67
68 %if %{with tests}
69 ctest
70 %endif
71
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %ninja_install -C build
76
77 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/{lt,sr}
78 %find_lang %{kaname} --all-name --with-kde
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files -f %{kaname}.lang
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_bindir}/kcalc
86 %{_desktopdir}/org.kde.kcalc.desktop
87 %{_datadir}/config.kcfg/kcalc.kcfg
88 %{_datadir}/kconf_update/kcalcrc.upd
89 %{_datadir}/metainfo/org.kde.kcalc.appdata.xml
This page took 0.073633 seconds and 2 git commands to generate.