]> git.pld-linux.org Git - packages/ka5-kcachegrind.git/blob - ka5-kcachegrind.spec
- updated to 22.08.0
[packages/ka5-kcachegrind.git] / ka5-kcachegrind.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.08.0
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          kcachegrind
8
9 Summary:        KCachegrind - visualization of traces generated by profiling
10 Summary(pl.UTF-8):      KCachegrind - wizualizacja ścieżek tworzonych przez profilowanie
11 Name:           ka5-kcachegrind
12 Version:        22.08.0
13 Release:        1
14 License:        GPL v2
15 Group:          X11/Development/Tools
16 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
17 # Source0-md5:  2edc413a23a83f302c64d25491724980
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt5Core-devel
20 BuildRequires:  Qt5DBus-devel
21 BuildRequires:  Qt5Gui-devel
22 BuildRequires:  Qt5Widgets-devel
23 BuildRequires:  gettext-devel
24 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
25 BuildRequires:  kf5-karchive-devel >= %{kframever}
26 BuildRequires:  kf5-kconfig-devel >= %{kframever}
27 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
28 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
29 BuildRequires:  kf5-ki18n-devel >= %{kframever}
30 BuildRequires:  kf5-kio-devel >= %{kframever}
31 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
32 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
33 BuildRequires:  ninja
34 BuildRequires:  rpmbuild(macros) >= 1.600
35 Suggests:       %{name}-tools = %{version}-%{release}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 KCachegrind visualizes traces generated by profiling.
40
41 %description -l pl.UTF-8
42 KCachegrind wizualizuje ślady tworzone przez profilowanie.
43
44 %package tools
45 Summary:        Tools to convert various profiling data to calltree format
46 Summary(pl.UTF-8):      Narzędzia do konwersji różnych danych profilujących do formatu calltree
47 Group:          Development/Tools
48
49 %description tools
50 Tools to convert various profiling data to calltree format, used by
51 Valgrind tools.
52
53 %description tools -l pl.UTF-8
54 Narzędzia do konwersji różnych danych profilujących do formatu
55 calltree, stosowanego przez narzędzia Valgrinda.
56
57 %prep
58 %setup -q -n %{kaname}-%{version}
59
60 %build
61 install -d build
62 cd build
63 %cmake \
64         -G Ninja \
65         %{!?with_tests:-DBUILD_TESTING=OFF} \
66         -DHTML_INSTALL_DIR=%{_kdedocdir} \
67         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
68         ..
69 %ninja_build
70
71 %if %{with tests}
72 ctest
73 %endif
74
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 %ninja_install -C build
79
80 find $RPM_BUILD_ROOT%{_bindir} -type f -exec sed -i -e 's#/usr/bin/env php#/usr/bin/php#' '{}' +
81 find $RPM_BUILD_ROOT%{_bindir} -type f -exec sed -i -e 's#/usr/bin/env python#/usr/bin/python2#' '{}' +
82
83 %find_lang %{kaname} --all-name --with-kde --with-qm
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files -f %{kaname}.lang
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_bindir}/kcachegrind
91 %{_desktopdir}/org.kde.kcachegrind.desktop
92 %{_iconsdir}/hicolor/128x128/apps/kcachegrind.png
93 %{_iconsdir}/hicolor/32x32/apps/kcachegrind.png
94 %{_iconsdir}/hicolor/48x48/apps/kcachegrind.png
95 %{_iconsdir}/hicolor/64x64/apps/kcachegrind.png
96 %dir %{_datadir}/kcachegrind
97 %dir %{_datadir}/kcachegrind/icons
98 %dir %{_datadir}/kcachegrind/icons/hicolor
99 %dir %{_datadir}/kcachegrind/icons/hicolor/16x16
100 %dir %{_datadir}/kcachegrind/icons/hicolor/16x16/actions
101 %{_datadir}/kcachegrind/icons/hicolor/16x16/actions/move.png
102 %{_datadir}/kcachegrind/icons/hicolor/16x16/actions/percent.png
103 %dir %{_datadir}/kcachegrind/icons/hicolor/22x22
104 %dir %{_datadir}/kcachegrind/icons/hicolor/22x22/actions
105 %{_datadir}/kcachegrind/icons/hicolor/22x22/actions/hidetemplates.png
106 %{_datadir}/kcachegrind/icons/hicolor/22x22/actions/move.png
107 %{_datadir}/kcachegrind/icons/hicolor/22x22/actions/percent.png
108 %dir %{_datadir}/kcachegrind/icons/hicolor/32x32
109 %dir %{_datadir}/kcachegrind/icons/hicolor/32x32/actions
110 %{_datadir}/kcachegrind/icons/hicolor/32x32/actions/percent.png
111 %{_datadir}/kcachegrind/tips
112 %{_datadir}/metainfo/org.kde.kcachegrind.appdata.xml
113
114 %files tools
115 %defattr(644,root,root,755)
116 %doc converters/README
117 %attr(755,root,root) %{_bindir}/dprof2calltree
118 %attr(755,root,root) %{_bindir}/hotshot2calltree
119 %attr(755,root,root) %{_bindir}/memprof2calltree
120 %attr(755,root,root) %{_bindir}/op2calltree
121 %attr(755,root,root) %{_bindir}/pprof2calltree
This page took 0.083438 seconds and 3 git commands to generate.