]> git.pld-linux.org Git - packages/ka5-dolphin.git/blob - ka5-dolphin.spec
5d59861a8c4f02fa78613177c20b75701513cc1c
[packages/ka5-dolphin.git] / ka5-dolphin.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.04.3
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          dolphin
8 Summary:        File manager
9 Name:           ka5-%{kaname}
10 Version:        22.04.3
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  bd5e54d4002937ecd84d648faf31e06f
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
20 BuildRequires:  kf5-kbookmarks-devel >= %{kframever}
21 BuildRequires:  kf5-kcmutils-devel >= %{kframever}
22 BuildRequires:  kf5-kcompletion-devel >= %{kframever}
23 BuildRequires:  kf5-kconfig-devel >= %{kframever}
24 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
25 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
26 BuildRequires:  kf5-kdelibs4support-devel >= %{kframever}
27 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
28 BuildRequires:  kf5-kemoticons-devel >= %{kframever}
29 BuildRequires:  kf5-kguiaddons-devel >= %{kframever}
30 BuildRequires:  kf5-ki18n-devel >= %{kframever}
31 BuildRequires:  kf5-kiconthemes-devel >= %{kframever}
32 BuildRequires:  kf5-kinit-devel >= %{kframever}
33 BuildRequires:  kf5-kio-devel >= %{kframever}
34 BuildRequires:  kf5-kitemmodels-devel >= %{kframever}
35 BuildRequires:  kf5-knewstuff-devel >= %{kframever}
36 BuildRequires:  kf5-knotifications-devel >= %{kframever}
37 BuildRequires:  kf5-knotifyconfig-devel >= %{kframever}
38 BuildRequires:  kf5-kparts-devel >= %{kframever}
39 BuildRequires:  kf5-kpty-devel >= %{kframever}
40 BuildRequires:  kf5-kservice-devel >= %{kframever}
41 BuildRequires:  kf5-ktextwidgets-devel >= %{kframever}
42 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
43 BuildRequires:  kf5-kwindowsystem-devel >= %{kframever}
44 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
45 BuildRequires:  ninja
46 BuildRequires:  qt5-build >= %{qtver}
47 BuildRequires:  rpmbuild(macros) >= 1.164
48 BuildRequires:  ruby-test-unit
49 BuildRequires:  tar >= 1:1.22
50 BuildRequires:  xz
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 Dolphin is a lightweight file manager. It has been designed with ease
55 of use and simplicity in mind, while still allowing flexibility and
56 customisation. This means that you can do your file management exactly
57 the way you want to do it.
58
59 Features
60
61 • Navigation (or breadcrumb) bar for URLs, allowing you to quickly
62 navigate through the hierarchy of files and folders. • Supports
63 several different kinds of view styles and properties and allows you
64 to configure the view exactly how you want it. • Split view, allowing
65 you to easily copy or move files between locations. • Additional
66 information and shortcuts are available as dock-able panels, allowing
67 you to move them around freely and display exactly what you want. •
68 Multiple tab support • Informational dialogues are displayed in an
69 unobtrusive way. • Undo/redo support • Transparent network access
70 through the KIO system.
71
72 %description -l pl.UTF-8
73 Dolphin to lekki zarządca plików. Zaprojektowany jako łatwy w użyciu,
74 choć zapewniający elastyczność i możliwości konfiguracji. To znaczy,
75 że możesz go używać dokładnie, tak jakbyś chciał.
76
77 Cechy
78
79 • Pasek nawigacyjny dla URLi pozwalający na szybkie przemieszczanie
80 się wśród hierarchi plików i folderów • Wspiera wiele różnych rodzajów
81 przeglądania plików pozwalając skonfigurować podgląd tak jak sobie
82 tego życzysz • Podzielony widok do łatwego kopiowania i przenoszenia
83 plików między lokacjami • Dodatkowe informacje i skróty klawiszowe są
84 dostępne jako dokowalne panele, pozwalając przemieszczać się do woli i
85 wyświetlać to co chcesz • Wiele kart • Informacyjne okna dialogowe nie
86 drażnią użytkownika • Wsparcie dla Cofnij/Powtórz • Przeźroczysty
87 dostęp do sieci korzystający z systemu KIO.
88
89 %package devel
90 Summary:        Header files for %{kaname} development
91 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
92 Group:          X11/Development/Libraries
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       cmake >= 2.6.0
95
96 %description devel
97 Header files for %{kaname} development.
98
99 %description devel -l pl.UTF-8
100 Pliki nagłówkowe dla programistów używających %{kaname}.
101
102 %prep
103 %setup -q -n %{kaname}-%{version}
104
105 %build
106 install -d build
107 cd build
108 RUBYLIB=%{_datadir}/gems/gems/test-unit-3.2.3/lib
109 export RUBYLIB
110 %cmake \
111         -G Ninja \
112         %{!?with_tests:-DBUILD_TESTING=OFF} \
113         -DHTML_INSTALL_DIR=%{_kdedocdir} \
114         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
115         ..
116 %ninja_build
117
118 %if %{with tests}
119 ctest
120 %endif
121
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 %ninja_install -C build
126
127 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/sr
128 %find_lang %{kaname} --all-name --with-kde
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files -f %{kaname}.lang
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/dolphin
139 %attr(755,root,root) %{_bindir}/servicemenuinstaller
140 %ghost %{_libdir}/libdolphinprivate.so.5
141 %{_libdir}/libdolphinprivate.so.5.*.*
142 %ghost %{_libdir}/libdolphinvcs.so.5
143 %{_libdir}/libdolphinvcs.so.5.*.*
144 %dir %{_libdir}/qt5/plugins/dolphin
145 %dir %{_libdir}/qt5/plugins/dolphin/kcms
146 %{_libdir}/qt5/plugins/dolphin/kcms/libkcm_dolphingeneral.so
147 %{_libdir}/qt5/plugins/dolphin/kcms/libkcm_dolphinnavigation.so
148 %{_libdir}/qt5/plugins/dolphin/kcms/libkcm_dolphinviewmodes.so
149 %{_desktopdir}/org.kde.dolphin.desktop
150 %{_datadir}/config.kcfg/dolphin_compactmodesettings.kcfg
151 %{_datadir}/config.kcfg/dolphin_detailsmodesettings.kcfg
152 %{_datadir}/config.kcfg/dolphin_directoryviewpropertysettings.kcfg
153 %{_datadir}/config.kcfg/dolphin_generalsettings.kcfg
154 %{_datadir}/config.kcfg/dolphin_iconsmodesettings.kcfg
155 %{_datadir}/config.kcfg/dolphin_versioncontrolsettings.kcfg
156 %{_datadir}/dbus-1/interfaces/org.freedesktop.FileManager1.xml
157 %{_datadir}/dbus-1/services/org.kde.dolphin.FileManager1.service
158 %{_datadir}/kservices5/dolphinpart.desktop
159 %{_datadir}/kservices5/kcmdolphingeneral.desktop
160 %{_datadir}/kservices5/kcmdolphinnavigation.desktop
161 %{_datadir}/kservices5/kcmdolphinviewmodes.desktop
162 %{_datadir}/kservicetypes5/fileviewversioncontrolplugin.desktop
163 %{_datadir}/metainfo/org.kde.dolphin.appdata.xml
164 %{_datadir}/kglobalaccel/org.kde.dolphin.desktop
165 %{_datadir}/qlogging-categories5/dolphin.categories
166 %{_datadir}/knsrcfiles/servicemenu.knsrc
167 %{systemduserunitdir}/plasma-dolphin.service
168 %{_libdir}/qt5/plugins/kf5/parts/dolphinpart.so
169 %{_datadir}/config.kcfg/dolphin_contextmenusettings.kcfg
170
171 %files devel
172 %defattr(644,root,root,755)
173 %{_libdir}/libdolphinvcs.so
174 %{_includedir}/Dolphin
175 %{_includedir}/dolphin_export.h
176 %{_includedir}/dolphinvcs_export.h
177 %{_libdir}/cmake/DolphinVcs
This page took 0.118965 seconds and 2 git commands to generate.