]> git.pld-linux.org Git - packages/ka5-dolphin.git/blob - ka5-dolphin.spec
- updated to 21.08.3
[packages/ka5-dolphin.git] / ka5-dolphin.spec
1 %define         kdeappsver      21.08.3
2 %define         kframever       5.69.0
3 %define         qtver           5.9.0
4 %define         kaname          dolphin
5 Summary:        File manager
6 Name:           ka5-%{kaname}
7 Version:        21.08.3
8 Release:        1
9 License:        GPL v2+/LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
12 # Source0-md5:  f78463798b06367e3b733066c8fae801
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  cmake >= 2.8.12
16 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
17 BuildRequires:  kf5-kbookmarks-devel >= %{kframever}
18 BuildRequires:  kf5-kcmutils-devel >= %{kframever}
19 BuildRequires:  kf5-kcompletion-devel >= %{kframever}
20 BuildRequires:  kf5-kconfig-devel >= %{kframever}
21 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
22 BuildRequires:  kf5-kcoreaddons-devel >= %{kframever}
23 BuildRequires:  kf5-kdelibs4support-devel >= %{kframever}
24 BuildRequires:  kf5-kdoctools-devel >= %{kframever}
25 BuildRequires:  kf5-kemoticons-devel >= %{kframever}
26 BuildRequires:  kf5-kguiaddons-devel >= %{kframever}
27 BuildRequires:  kf5-ki18n-devel >= %{kframever}
28 BuildRequires:  kf5-kiconthemes-devel >= %{kframever}
29 BuildRequires:  kf5-kinit-devel >= %{kframever}
30 BuildRequires:  kf5-kio-devel >= %{kframever}
31 BuildRequires:  kf5-kitemmodels-devel >= %{kframever}
32 BuildRequires:  kf5-knewstuff-devel >= %{kframever}
33 BuildRequires:  kf5-knotifications-devel >= %{kframever}
34 BuildRequires:  kf5-knotifyconfig-devel >= %{kframever}
35 BuildRequires:  kf5-kparts-devel >= %{kframever}
36 BuildRequires:  kf5-kpty-devel >= %{kframever}
37 BuildRequires:  kf5-kservice-devel >= %{kframever}
38 BuildRequires:  kf5-ktextwidgets-devel >= %{kframever}
39 BuildRequires:  kf5-kwidgetsaddons-devel >= %{kframever}
40 BuildRequires:  kf5-kwindowsystem-devel >= %{kframever}
41 BuildRequires:  kf5-kxmlgui-devel >= %{kframever}
42 BuildRequires:  ninja
43 BuildRequires:  qt5-build >= %{qtver}
44 BuildRequires:  rpmbuild(macros) >= 1.164
45 BuildRequires:  ruby-test-unit
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  xz
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Dolphin is a lightweight file manager. It has been designed with ease
52 of use and simplicity in mind, while still allowing flexibility and
53 customisation. This means that you can do your file management exactly
54 the way you want to do it.
55
56 Features
57
58 • Navigation (or breadcrumb) bar for URLs, allowing you to quickly
59 navigate through the hierarchy of files and folders. • Supports
60 several different kinds of view styles and properties and allows you
61 to configure the view exactly how you want it. • Split view, allowing
62 you to easily copy or move files between locations. • Additional
63 information and shortcuts are available as dock-able panels, allowing
64 you to move them around freely and display exactly what you want. •
65 Multiple tab support • Informational dialogues are displayed in an
66 unobtrusive way. • Undo/redo support • Transparent network access
67 through the KIO system.
68
69 %description -l pl.UTF-8
70 Dolphin to lekki zarządca plików. Zaprojektowany jako łatwy w użyciu,
71 choć zapewniający elastyczność i możliwości konfiguracji. To znaczy, że
72 możesz go używać dokładnie, tak jakbyś chciał.
73
74 Cechy
75
76 • Pasek nawigacyjny dla URLi pozwalający na szybkie przemieszczanie się
77 wśród hierarchi plików i folderów
78 • Wspiera wiele różnych rodzajów przeglądania plików pozwalając skonfigurować
79 podgląd tak jak sobie tego życzysz
80 • Podzielony widok do łatwego kopiowania i przenoszenia plików między lokacjami
81 • Dodatkowe informacje i skróty klawiszowe są dostępne jako dokowalne panele,
82 pozwalając przemieszczać się do woli i wyświetlać to co chcesz
83 • Wiele kart
84 • Informacyjne okna dialogowe nie drażnią użytkownika
85 • Wsparcie dla Cofnij/Powtórz
86 • Przeźroczysty dostęp do sieci korzystający z systemu KIO.
87
88 %description -l pl.UTF-8
89 Dolphin - zarządca plików KDE.
90
91 %package devel
92 Summary:        Header files for %{kaname} development
93 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kaname}
94 Group:          X11/Development/Libraries
95 Requires:       %{name} = %{version}-%{release}
96 Requires:       cmake >= 2.6.0
97
98 %description devel
99 Header files for %{kaname} development.
100
101 %description devel -l pl.UTF-8
102 Pliki nagłówkowe dla programistów używających %{kaname}.
103
104 %prep
105 %setup -q -n %{kaname}-%{version}
106
107 %build
108 install -d build
109 cd build
110 RUBYLIB=%{_datadir}/gems/gems/test-unit-3.2.3/lib
111 export RUBYLIB
112 %cmake \
113         -G Ninja \
114         -DHTML_INSTALL_DIR=%{_kdedocdir} \
115         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
116         ..
117 %ninja_build
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 %ninja_install -C build
122
123 rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/sr
124 %find_lang %{kaname} --all-name --with-kde
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files -f %{kaname}.lang
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/dolphin
135 %attr(755,root,root) %{_bindir}/servicemenuinstaller
136 %ghost %{_libdir}/libdolphinprivate.so.5
137 %{_libdir}/libdolphinprivate.so.5.*.*
138 %ghost %{_libdir}/libdolphinvcs.so.5
139 %{_libdir}/libdolphinvcs.so.5.*.*
140 %{_libdir}/qt5/plugins/kcm_dolphingeneral.so
141 %{_libdir}/qt5/plugins/kcm_dolphinnavigation.so
142 %{_libdir}/qt5/plugins/kcm_dolphinviewmodes.so
143 %{_desktopdir}/org.kde.dolphin.desktop
144 %{_datadir}/config.kcfg/dolphin_compactmodesettings.kcfg
145 %{_datadir}/config.kcfg/dolphin_detailsmodesettings.kcfg
146 %{_datadir}/config.kcfg/dolphin_directoryviewpropertysettings.kcfg
147 %{_datadir}/config.kcfg/dolphin_generalsettings.kcfg
148 %{_datadir}/config.kcfg/dolphin_iconsmodesettings.kcfg
149 %{_datadir}/config.kcfg/dolphin_versioncontrolsettings.kcfg
150 %{_datadir}/dbus-1/interfaces/org.freedesktop.FileManager1.xml
151 %{_datadir}/dbus-1/services/org.kde.dolphin.FileManager1.service
152 %{_datadir}/kservices5/dolphinpart.desktop
153 %{_datadir}/kservices5/kcmdolphingeneral.desktop
154 %{_datadir}/kservices5/kcmdolphinnavigation.desktop
155 %{_datadir}/kservices5/kcmdolphinviewmodes.desktop
156 %{_datadir}/kservicetypes5/fileviewversioncontrolplugin.desktop
157 %{_datadir}/metainfo/org.kde.dolphin.appdata.xml
158 %{_datadir}/kglobalaccel/org.kde.dolphin.desktop
159 %{_datadir}/qlogging-categories5/dolphin.categories
160 %{_datadir}/knsrcfiles/servicemenu.knsrc
161 %{systemduserunitdir}/plasma-dolphin.service
162 %{_libdir}/qt5/plugins/kf5/parts/dolphinpart.so
163 %{_datadir}/config.kcfg/dolphin_contextmenusettings.kcfg
164
165 %files devel
166 %defattr(644,root,root,755)
167 %{_libdir}/libdolphinvcs.so
168 %{_includedir}/Dolphin
169 %{_includedir}/dolphin_export.h
170 %{_includedir}/dolphinvcs_export.h
171 %{_libdir}/cmake/DolphinVcs
This page took 0.056845 seconds and 3 git commands to generate.