]> git.pld-linux.org Git - packages/ka5-alligator.git/blob - ka5-alligator.spec
- updated to 23.08.0; cmake -B build
[packages/ka5-alligator.git] / ka5-alligator.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      23.08.0
5 %define         kframever       5.94.0
6 %define         qtver           5.15.2
7 %define         kaname          alligator
8 Summary:        A convergent RSS/Atom feed reader
9 Name:           ka5-%{kaname}
10 Version:        23.08.0
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  5f9b5d470c61a2e5cd6dbf8c41c43260
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= 5.15.2
18 BuildRequires:  Qt5Gui-devel
19 BuildRequires:  Qt5Network-devel >= 5.15.9
20 BuildRequires:  Qt5Qml-devel >= 5.15.9
21 BuildRequires:  Qt5Quick-controls2-devel
22 BuildRequires:  Qt5Quick-devel
23 BuildRequires:  Qt5Sql-devel
24 BuildRequires:  Qt5Test
25 BuildRequires:  Qt5Widgets-devel
26 BuildRequires:  gettext-devel
27 BuildRequires:  kf5-extra-cmake-modules >= 5.90.0
28 BuildRequires:  kf5-kconfig-devel >= 5.90.0
29 BuildRequires:  kf5-kcoreaddons-devel >= 5.90.0
30 BuildRequires:  kf5-ki18n-devel >= 5.90.0
31 BuildRequires:  kf5-syndication-devel >= 5.90.0
32 BuildRequires:  kirigami-addons-devel >= 0.6
33 BuildRequires:  ninja
34 BuildRequires:  qt5-build >= %{qtver}
35 BuildRequires:  rpmbuild(macros) >= 1.164
36 BuildRequires:  shared-mime-info
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  xz
39 ExcludeArch:    x32
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Alligator is a convergent RSS/Atom feed reader.
44
45 %prep
46 %setup -q -n %{kaname}-%{version}
47
48 %build
49 %cmake \
50         -B build \
51         -G Ninja \
52         %{!?with_tests:-DBUILD_TESTING=OFF} \
53         -DHTML_INSTALL_DIR=%{_kdedocdir} \
54         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
55 %ninja_build -C build
56
57 %if %{with tests}
58 ctest --test-dir build
59 %endif
60
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %ninja_install -C build
65
66 %find_lang %{kaname} --all-name --with-kde
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files -f %{kaname}.lang
72 %defattr(644,root,root,755)
73 %attr(755,root,root) %{_bindir}/alligator
74 %{_desktopdir}/org.kde.alligator.desktop
75 %{_iconsdir}/hicolor/scalable/apps/alligator.svg
76 %{_datadir}/metainfo/org.kde.alligator.appdata.xml
This page took 0.129949 seconds and 3 git commands to generate.