]> git.pld-linux.org Git - packages/jsoncpp.git/blob - jsoncpp.spec
0eee80a6aac3537df5a66f607e2c7ebe3ebfd860
[packages/jsoncpp.git] / jsoncpp.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # doxygen apidocs build
4 %bcond_without  tests   # tests during build
5
6 Summary:        API for manipulating JSON
7 Summary(pl.UTF-8):      API do operacji na strukturach JSON
8 Name:           jsoncpp
9 Version:        1.6.2
10 Release:        4
11 License:        MIT or Public Domain
12 Group:          Libraries
13 Source0:        https://github.com/open-source-parsers/jsoncpp/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  5a62da8b5c5b0e46a0e782e7363aee3d
15 URL:            https://github.com/open-source-parsers/jsoncpp/
16 BuildRequires:  cmake >= 2.8.5
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  python >= 2
19 %if %{with apidocs}
20 BuildRequires:  doxygen
21 BuildRequires:  graphviz
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 JSONCPP provides a simple API to manipulate JSON values, and handle
27 serialization and unserialization to strings.
28
29 %description
30 JSONCPP udostępnia proste API do operacji na wartościach JSON oraz
31 obsługi serializacji oraz deserializacji z łańcuchów znaków.
32
33 %package devel
34 Summary:        Header files for JSONCPP library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki JSONCPP
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for JSONCPP library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki JSONCPP.
44
45 %package static
46 Summary:        Static JSONCPP library
47 Summary(pl.UTF-8):      Statyczna biblioteka JSONCPP
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static JSONCPP library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka JSONCPP.
56
57 %package apidocs
58 Summary:        API documentation for JSONCPP library
59 Summary(pl.UTF-8):      Dokumentacja API biblioteki JSONCPP
60 Group:          Documentation
61 %if "%{_rpmversion}" >= "5"
62 BuildArch:      noarch
63 %endif
64
65 %description apidocs
66 API documentation for JSONCPP library.
67
68 %description apidocs -l pl.UTF-8
69 Dokumentacja API biblioteki JSONCPP.
70
71 %prep
72 %setup -q
73
74 %build
75 install -d build
76 cd build
77 %cmake .. \
78         -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/%{name} \
79         -DARCHIVE_INSTALL_DIR:PATH=%{_lib} \
80         -DLIBRARY_INSTALL_DIR:PATH=%{_lib} \
81         -DPACKAGE_INSTALL_DIR:PATH=%{_lib}/cmake \
82         -DJSONCPP_LIB_BUILD_SHARED=ON \
83         -DJSONCPP_WITH_CMAKE_PACKAGE=ON \
84         %{!?with_tests:-DJSONCPP_WITH_TESTS=OFF}
85 cd ..
86
87 %if %{with apidocs}
88 %{__python} doxybuild.py \
89         --dot=/usr/bin/dot \
90         --doxygen=/usr/bin/doxygen
91 %endif
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} -C build install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %doc AUTHORS LICENSE NEWS.txt README.md
108 %attr(755,root,root) %{_libdir}/libjsoncpp.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libjsoncpp.so.1
110
111 %files devel
112 %defattr(644,root,root,755)
113 %attr(755,root,root) %{_libdir}/libjsoncpp.so
114 %{_includedir}/jsoncpp
115 %{_pkgconfigdir}/jsoncpp.pc
116 %{_libdir}/cmake/jsoncpp
117
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/libjsoncpp.a
121
122 %if %{with apidocs}
123 %files apidocs
124 %defattr(644,root,root,755)
125 %doc dist/doxygen/jsoncpp-api-html-*/*
126 %endif
This page took 0.046831 seconds and 2 git commands to generate.