]> git.pld-linux.org Git - packages/json-c.git/blob - json-c.spec
6c6d9429ba62ffe91fa293f830d879c583387964
[packages/json-c.git] / json-c.spec
1 Summary:        A JSON implementation in C
2 Summary(pl.UTF-8):      Implementacja JSON w C
3 Name:           json-c
4 Version:        0.13.1
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 #Source0Download: https://s3.amazonaws.com/json-c_releases/releases/index.html # with AJAX (requires JavaScript)
9 # XML data with links (relative to https://s3.amazonaws.com/json-c_releases/) in https://s3.amazonaws.com/json-c_releases (no "/" at the end!)
10 Source0:        https://s3.amazonaws.com/json-c_releases/releases/%{name}-%{version}.tar.gz
11 # Source0-md5:  04969ad59cc37bddd83741a08b98f350
12 URL:            https://github.com/json-c/json-c/wiki
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 JSON-C implements a reference counting object model that allows you to
17 easily construct JSON objects in C, output them as JSON formatted
18 strings and parse JSON formatted strings back into the C
19 representation of JSON objects.
20
21 %description -l pl.UTF-8
22 JSON-C implementuje model obiektów ze zliczaniem odwołań, pozwalający
23 łatwo konstruować obiekty JSON w C, wypisywać je w postaci łańcuchów w
24 formacie JSON i analizować łańcuchy w formacie JSON tworząc z powrotem
25 reprezentacje obiektów JSON w C.
26
27 %package devel
28 Summary:        Header files for the json-c library
29 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki json-c
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 Header files for the json-c library.
35
36 %description devel -l pl.UTF-8
37 Pliki nagłówkowe biblioteki json-c.
38
39 %package static
40 Summary:        Static json-c library
41 Summary(pl.UTF-8):      Statyczna biblioteka json-c
42 Group:          Development/Libraries
43 Requires:       %{name}-devel = %{version}-%{release}
44
45 %description static
46 Static json-c library.
47
48 %description static -l pl.UTF-8
49 Statyczna biblioteka json-c.
50
51 %prep
52 %setup -q
53
54 %build
55 # avoid "json_tokener.c:355:6: error: variable 'size' set but not used [-Werror=unused-but-set-variable]"
56 CFLAGS="%{rpmcflags} -Wno-unused-but-set-variable"
57 %configure \
58         --disable-silent-rules
59 %{__make} -j1
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post   -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %pretrans devel
76 # transition from 0.11-2
77 [ ! -L %{_includedir}/json-c ] || rm -f %{_includedir}/json-c
78 # transition from <= 0.10 and 0.11-2
79 if [ -d %{_includedir}/json -a ! -d %{_includedir}/json-c ]; then
80         mv -f %{_includedir}/json %{_includedir}/json-c
81         ln -sf json-c %{_includedir}/json
82 fi
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS COPYING ChangeLog README README.html
87 %attr(755,root,root) %{_libdir}/libjson-c.so.*.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libjson-c.so.4
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/libjson-c.so
93 %{_includedir}/json-c
94 %{_pkgconfigdir}/json-c.pc
95
96 %files static
97 %defattr(644,root,root,755)
98 %{_libdir}/libjson-c.a
This page took 0.061011 seconds and 2 git commands to generate.