]> git.pld-linux.org Git - packages/jquery-thickbox.git/blob - jquery-thickbox.spec
- copy .png here as well; rel 7
[packages/jquery-thickbox.git] / jquery-thickbox.spec
1 # NOTE:
2 # - the tarball is created by this same spec on DEVEL branch
3 Summary:        ThickBox
4 Name:           jquery-thickbox
5 Version:        3.1
6 Release:        7
7 License:        MIT / GPL
8 Group:          Applications/WWW
9 Source0:        %{name}-%{version}-6.tar.bz2
10 # Source0-md5:  11154789765bcb8699c06308f1fb4dec
11 URL:            http://jquery.com/demo/thickbox/
12 BuildRequires:  rpmbuild(macros) > 1.268
13 Requires:       jquery
14 Requires:       webapps
15 Requires:       webserver(alias)
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _webapps        /etc/webapps
20 %define         _webapp         %{name}
21 %define         _sysconfdir     %{_webapps}/%{_webapp}
22 %define         _appdir         %{_datadir}/%{name}
23
24 %description
25 ThickBox is a webpage UI dialog widget written in JavaScript on top of
26 the jQuery library. Its function is to show a single image, multiple
27 images, inline content, iframed content, or content served through
28 AJAX in a hybrid modal.
29
30 %prep
31 %setup -qc
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
36 cp -a *.js *.css *.gif *.png $RPM_BUILD_ROOT%{_appdir}
37 cp -a apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
38 cp -a apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
39 cp -a lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %triggerin -- apache1 < 1.3.37-3, apache1-base
45 %webapp_register apache %{_webapp}
46
47 %triggerun -- apache1 < 1.3.37-3, apache1-base
48 %webapp_unregister apache %{_webapp}
49
50 %triggerin -- apache < 2.2.0, apache-base
51 %webapp_register httpd %{_webapp}
52
53 %triggerun -- apache < 2.2.0, apache-base
54 %webapp_unregister httpd %{_webapp}
55
56 %triggerin -- lighttpd
57 %webapp_register lighttpd %{_webapp}
58
59 %triggerun -- lighttpd
60 %webapp_unregister lighttpd %{_webapp}
61
62 %files
63 %defattr(644,root,root,755)
64 %dir %attr(750,root,http) %{_sysconfdir}
65 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
66 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
67 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
68 %{_appdir}
This page took 0.025882 seconds and 3 git commands to generate.