]> git.pld-linux.org Git - packages/jpilot.git/blob - jpilot.spec
- added option for convert charset via iconv
[packages/jpilot.git] / jpilot.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk1    # use GTK+ 1.2 instead of GTK+2
4 #
5 Summary:        Desktop organizer application for PalmOS devices
6 Summary(pl):    Organizer dla urz±dzeñ PalmOS
7 Summary(pt_BR): Software para interação com o Pilot
8 Name:           jpilot
9 Version:        0.99.7
10 Release:        4
11 License:        GPL
12 Group:          X11/Applications
13 Source0:        http://jpilot.org/%{name}-%{version}.tar.gz
14 # Source0-md5:  11bb7236702e2e4c7e3d06372bdc9695
15 Source1:        %{name}.desktop
16 Source2:        %{name}.png
17 Patch0:         %{name}-locale-names.patch
18 Patch1:         %{name}_other.v0_99_7.diff
19 URL:            http://jpilot.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  gettext-devel
23 %{?with_gtk1:BuildRequires:     gtk+-devel >= 1.2.0}
24 %{!?with_gtk1:BuildRequires:    gtk+2-devel >= 2.0.3}
25 BuildRequires:  intltool
26 BuildRequires:  libtool
27 BuildRequires:  openssl-devel >= 0.9.7d
28 BuildRequires:  pilot-link-devel >= 0.11.5
29 BuildRequires:  readline-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 J-Pilot is a desktop organizer application for the PalmOS devices that
34 runs under Linux with plugins support. It is similar in functionality
35 to the original Palm Desktop software.
36
37 %description -l pl
38 J-Pilot jest programem do zarz±dzania urz±dzeniami PalmOS dla Linuksa
39 z mo¿liwo¶ci± dodawania wtyczek. Posiada zbli¿on± funkcjonalno¶æ do
40 oryginalnego oprogramowania Palm Desktop.
41
42 %description -l pt_BR
43 Um software para interação com o Pilot.
44
45 %prep
46 %setup -q
47 %patch0 -p1
48 %patch1 -p1
49
50 mv -f po/{no,nb}.po
51 rm -f po/stamp-po
52
53 %{__perl} -pi -e 's@pilot_prefix/lib /usr/lib@pilot_prefix/%{_lib} /usr/%{_lib}@' configure.in
54 %{__perl} -pi -e 's@/lib/jpilot/plugins@/%{_lib}/jpilot/plugins@' */Makefile.am
55
56 %build
57 %{?with_gtk1:echo 'AC_DEFUN([AM_PATH_GTK_2_0],[$3])' >> acinclude.m4}
58 %{!?with_gtk1:echo 'AC_DEFUN([AM_PATH_GTK],[$3])' >> acinclude.m4}
59 %{__gettextize}
60 %{__libtoolize}
61 %{__aclocal}
62 %{__autoconf}
63 %{__automake}
64 %configure \
65         ABILIB="%{_lib}" \
66         %{!?with_gtk1:--enable-gtk2}
67
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 install -D %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/jpilot.desktop
77
78 # plugins are dlopened by *.so
79 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/*.la
80
81 %find_lang %{name}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files -f %{name}.lang
90 %defattr(644,root,root,755)
91 %doc AUTHORS BUGS UPGRADING README TODO icons docs/{*.png,*.jpg,*.html}
92 %attr(755,root,root) %{_bindir}/*
93 %dir %{_libdir}/%{name}
94 %dir %{_libdir}/%{name}/plugins
95 %attr(755,root,root) %{_libdir}/%{name}/plugins/*.so*
96 #%{_datadir}/jpilot
97 %{_mandir}/man1/*
98 %{_desktopdir}/jpilot.desktop
This page took 0.084464 seconds and 4 git commands to generate.