]> git.pld-linux.org Git - packages/jemalloc.git/blob - jemalloc.spec
689251074cf931965be8487b08a10f4cd208a5a2
[packages/jemalloc.git] / jemalloc.spec
1 Summary:        General-purpose scalable concurrent malloc implementation
2 Summary(pl.UTF-8):      Ogólnego przeznaczenia, skalowalna, współbieżna implementacja funkcji malloc
3 Name:           jemalloc
4 Version:        4.2.1
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 Source0:        http://www.canonware.com/download/jemalloc/%{name}-%{version}.tar.bz2
9 # Source0-md5:  094b0a7b8c77c464d0dc8f0643fd3901
10 URL:            http://www.canonware.com/jemalloc/
11 BuildRequires:  libxslt-progs
12 BuildRequires:  sed >= 4.0
13 # list from include/jemalloc/internal/jemalloc_internal.h.in
14 # https://github.com/jemalloc/jemalloc/blob/3.6.0/include/jemalloc/internal/jemalloc_internal.h.in#L239
15 ExclusiveArch:  %{ix86} %{x8664} x32 alpha arm aarch64 hppa ia64 mips ppc s390x sh4 sparc64 tile
16 # broken for us
17 # alpha: Missing implementation for 64-bit atomic operations"
18 # alpha: Missing implementation for 32-bit atomic operations"
19 ExcludeArch:    alpha
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 General-purpose scalable concurrent malloc(3) implementation. This
24 distribution is the stand-alone "portable" implementation of jemalloc.
25
26 %description -l pl.UTF-8
27 Ogólnego przeznaczenia, skalowalna, współbieżna implementacja funkcji
28 malloc(3). Ten pakiet zawiera samodzielną "przenośną" implementację
29 jemalloc.
30
31 %package devel
32 Summary:        Development files for jemalloc
33 Summary(pl.UTF-8):      Pliki programistyczne biblioteki jemalloc
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 This package contains the header files for developing applications
39 that use jemalloc library.
40
41 %description devel -l pl.UTF-8
42 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
43 wykorzystujących bibliotekę jemalloc.
44
45 %package static
46 Summary:        Static jemalloc library
47 Summary(pl.UTF-8):      Statyczna biblioteka jemalloc
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static jemalloc library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka jemalloc.
56
57 %prep
58 %setup -q
59
60 # This is truncated during build. Seems interesting to save.
61 cp -p VERSION version
62
63 %{__sed} -i '1s, /usr/bin/env perl,%{__perl},' bin/jeprof.in
64
65 %build
66 # enable GNU+C99 standard (C99 for restrict keyword, GNU for asm)
67 CFLAGS="%{rpmcflags} -std=gnu99"
68 %configure \
69         --with-jemalloc-prefix=je_
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 # restore
79 cp -pf version VERSION
80
81 # soname improperly made, use fake main name (just use our current version)
82 %{__mv} $RPM_BUILD_ROOT%{_libdir}/libjemalloc.so.{2,%{version}}
83 ln -s $(basename $RPM_BUILD_ROOT%{_libdir}/libjemalloc.so.*.*.*) \
84         $RPM_BUILD_ROOT%{_libdir}/libjemalloc.so.2
85
86 # Install this with doc macro instead
87 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/jemalloc.html
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc COPYING README VERSION doc/jemalloc.html
98 %attr(755,root,root) %{_bindir}/jemalloc.sh
99 %attr(755,root,root) %{_libdir}/libjemalloc.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libjemalloc.so.2
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_bindir}/jemalloc-config
105 %attr(755,root,root) %{_bindir}/jeprof
106 %attr(755,root,root) %{_libdir}/libjemalloc.so
107 %{_includedir}/jemalloc
108 %{_pkgconfigdir}/jemalloc.pc
109 %{_mandir}/man3/jemalloc.3*
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/libjemalloc.a
114 %{_libdir}/libjemalloc_pic.a
This page took 0.066671 seconds and 2 git commands to generate.