]> git.pld-linux.org Git - packages/jemalloc.git/blob - jemalloc.spec
655b4b6161b602c6e24bbb02d16a87c9415e03fa
[packages/jemalloc.git] / jemalloc.spec
1 Summary:        General-purpose scalable concurrent malloc implementation
2 Summary(pl.UTF-8):      Ogólnego przeznaczenia, skalowalna, współbieżna implementacja funkcji malloc
3 Name:           jemalloc
4 Version:        5.2.0
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 #Source0Download: https://github.com/jemalloc/jemalloc/releases
9 Source0:        https://github.com/jemalloc/jemalloc/releases/download/%{version}/%{name}-%{version}.tar.bz2
10 # Source0-md5:  0af300de702a1443e6560c1eae254df7
11 URL:            http://jemalloc.net/
12 BuildRequires:  libxslt-progs
13 BuildRequires:  sed >= 4.0
14 # list from include/jemalloc/internal/jemalloc_internal.h.in
15 # https://github.com/jemalloc/jemalloc/blob/3.6.0/include/jemalloc/internal/jemalloc_internal.h.in#L239
16 ExclusiveArch:  %{ix86} %{x8664} x32 alpha %{arm} aarch64 hppa ia64 le32 mips or1k ppc riscv s390 s390x sh4 sparcv9 sparc64 tile
17 # broken for us
18 # alpha: Missing implementation for 64-bit atomic operations"
19 # alpha: Missing implementation for 32-bit atomic operations"
20 ExcludeArch:    alpha
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 General-purpose scalable concurrent malloc(3) implementation. This
25 distribution is the stand-alone "portable" implementation of jemalloc.
26
27 %description -l pl.UTF-8
28 Ogólnego przeznaczenia, skalowalna, współbieżna implementacja funkcji
29 malloc(3). Ten pakiet zawiera samodzielną "przenośną" implementację
30 jemalloc.
31
32 %package devel
33 Summary:        Development files for jemalloc
34 Summary(pl.UTF-8):      Pliki programistyczne biblioteki jemalloc
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 This package contains the header files for developing applications
40 that use jemalloc library.
41
42 %description devel -l pl.UTF-8
43 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
44 wykorzystujących bibliotekę jemalloc.
45
46 %package static
47 Summary:        Static jemalloc library
48 Summary(pl.UTF-8):      Statyczna biblioteka jemalloc
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static jemalloc library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka jemalloc.
57
58 %prep
59 %setup -q
60
61 # This is truncated during build. Seems interesting to save.
62 cp -p VERSION version
63
64 %{__sed} -i '1s, /usr/bin/env perl,%{__perl},' bin/jeprof.in
65
66 %build
67 # enable GNU+C99 standard (C99 for restrict keyword, GNU for asm)
68 CFLAGS="%{rpmcflags} -std=gnu99"
69 %configure \
70         --with-jemalloc-prefix=je_
71
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 # restore
80 cp -pf version VERSION
81
82 # soname improperly made, use fake main name (just use our current version)
83 %{__mv} $RPM_BUILD_ROOT%{_libdir}/libjemalloc.so.{2,%{version}}
84 ln -s $(basename $RPM_BUILD_ROOT%{_libdir}/libjemalloc.so.*.*.*) \
85         $RPM_BUILD_ROOT%{_libdir}/libjemalloc.so.2
86
87 # Install this with doc macro instead
88 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/jemalloc.html
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc COPYING README VERSION doc/jemalloc.html
99 %attr(755,root,root) %{_bindir}/jemalloc.sh
100 %attr(755,root,root) %{_libdir}/libjemalloc.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libjemalloc.so.2
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_bindir}/jemalloc-config
106 %attr(755,root,root) %{_bindir}/jeprof
107 %attr(755,root,root) %{_libdir}/libjemalloc.so
108 %{_includedir}/jemalloc
109 %{_pkgconfigdir}/jemalloc.pc
110 %{_mandir}/man3/jemalloc.3*
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libjemalloc.a
115 %{_libdir}/libjemalloc_pic.a
This page took 0.069894 seconds and 2 git commands to generate.