]> git.pld-linux.org Git - packages/jbigkit.git/blob - jbigkit.spec
2f39061dc81c2de6b4219d19b75ad598a1a2c533
[packages/jbigkit.git] / jbigkit.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 Summary:        JBIG-KIT lossless image compression library
6 Summary(pl.UTF-8):      JBIG-KIT - biblioteka do bezstratnej kompresji obrazków
7 Name:           jbigkit
8 Version:        2.1
9 Release:        3
10 License:        GPL v2+
11 Group:          Libraries
12 Source0:        http://www.cl.cam.ac.uk/~mgk25/jbigkit/download/%{name}-%{version}.tar.gz
13 # Source0-md5:  ebcf09bed9f14d7fa188d3bd57349522
14 Source1:        %{name}.pl.po
15 Patch0:         %{name}-shared.patch
16 URL:            http://www.cl.cam.ac.uk/~mgk25/jbigkit/
17 BuildRequires:  gettext-tools
18 BuildRequires:  libtool >= 2:1.5
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 JBIG-KIT implements a highly effective data compression algorithm for
23 bi-level high-resolution images such as fax pages or scanned
24 documents.
25
26 %description -l pl.UTF-8
27 JBIG-KIT zawiera implementację wydajnego algorytmu kompresji dla
28 2-kolorowych obrazków wysokiej rozdzielczości, takich jak faksy albo
29 skanowane dokumenty.
30
31 %package devel
32 Summary:        JBIG-KIT - development part
33 Summary(pl.UTF-8):      JBIG-KIT - plik nagłówkowy
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header file needed to build programs using JBIG library.
39
40 %description devel -l pl.UTF-8
41 Plik nagłówkowy potrzebny do kompilacji programów korzystających z
42 biblioteki JBIG.
43
44 %package static
45 Summary:        JBIG-KIT - static library
46 Summary(pl.UTF-8):      JBIG-KIT - biblioteka statyczna
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description static
51 Static JBIG library.
52
53 %description static -l pl.UTF-8
54 Statyczna biblioteka JBIG.
55
56 %package progs
57 Summary:        JBIG-KIT - conversion utilities
58 Summary(pl.UTF-8):      JBIG-KIT - programy do konwersji
59 Group:          Applications/Graphics
60 Requires:       %{name} = %{version}-%{release}
61
62 %description progs
63 Package contains utilities to convert between JBIG and PBM images.
64
65 %description progs -l pl.UTF-8
66 Narzędzia do konwersji plików między formatami JBIG i PBM.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71
72 cp %{SOURCE1} libjbig/po/pl.po
73
74 %build
75 %{__make} -j1 \
76         CC="%{__cc}" \
77         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
78         LDFLAGS="%{rpmldflags}" \
79         prefix=%{_prefix} \
80         libdir=%{_libdir}
81
82 for l in libjbig/po/*.po ; do
83         msgfmt -c -v -o "${l%.po}.mo" "$l"
84 done
85
86 %{?with_tests:%{__make} -j1 test}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 install -d $RPM_BUILD_ROOT%{_libdir}
92
93 %{__make} -j1 install \
94         DESTDIR=$RPM_BUILD_ROOT \
95         prefix=%{_prefix} \
96         libdir=%{_libdir}
97
98 for l in libjbig/po/*.mo ; do
99         install -D "$l" "$RPM_BUILD_ROOT%{_datadir}/locale/$(basename $l .mo)/LC_MESSAGES/jbig.mo"
100 done
101
102 %find_lang jbig
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files -f jbig.lang
111 %defattr(644,root,root,755)
112 # INSTALL is about "installing and using" jbigkit
113 %doc ANNOUNCE CHANGES INSTALL TODO
114 %attr(755,root,root) %{_libdir}/libjbig.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libjbig.so.2
116 %attr(755,root,root) %{_libdir}/libjbig85.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libjbig85.so.2
118
119 %files devel
120 %defattr(644,root,root,755)
121 %doc libjbig/{jbig,jbig85}.txt
122 %attr(755,root,root) %{_libdir}/libjbig.so
123 %attr(755,root,root) %{_libdir}/libjbig85.so
124 %{_libdir}/libjbig.la
125 %{_libdir}/libjbig85.la
126 %{_includedir}/jbig.h
127 %{_includedir}/jbig85.h
128 %{_includedir}/jbig_ar.h
129
130 %files static
131 %defattr(644,root,root,755)
132 %{_libdir}/libjbig.a
133 %{_libdir}/libjbig85.a
134
135 %files progs
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/jbgtopbm
138 %attr(755,root,root) %{_bindir}/pbmtojbg
139 %{_mandir}/man1/jbgtopbm.1*
140 %{_mandir}/man1/pbmtojbg.1*
This page took 0.040779 seconds and 2 git commands to generate.