]> git.pld-linux.org Git - packages/java-gcj-compat.git/blob - java-gcj-compat.spec
5d0246216a09e8bde2d978082ddfce2c32a96520
[packages/java-gcj-compat.git] / java-gcj-compat.spec
1 # NOTE:
2 # - homepage says this pkg is EOL, we should catch up
3 # TODO:
4 # - can we provide java-sun-jre-X11 for GUI apps?
5
6 # gcc >= 6:4.3.1-3 is required for working ecj1.
7 # gcc >= 6:4.4.0 is required because of aot-compile and rebuild-gcj-db scripts
8 %define         gcc_ver 6:4.4.0
9 Summary:        Shell scripts and symbolic links to simulate a Java runtime environment with GCJ
10 Summary(pl.UTF-8):      Skrypty powłoki i dowiązania do symulacji środowiska uruchomieniowego Javy przy użyciu GCJ
11 Name:           java-gcj-compat
12 Version:        1.0.80
13 Release:        11
14 License:        GPL v2
15 Group:          Development/Languages/Java
16 Source0:        ftp://sources.redhat.com/pub/rhug/%{name}-%{version}.tar.gz
17 # Source0-md5:  34369925c7a22e21c3d3b91e8b774396
18 Patch0:         %{name}-javac.patch
19 URL:            http://sources.redhat.com/rhug/java-gcj-compat.html
20 BuildRequires:  gcc-java >= %{gcc_ver}
21 BuildRequires:  python-devel
22 BuildRequires:  python-modules
23 BuildRequires:  rpm-pythonprov
24 BuildRequires:  rpmbuild(macros) >= 1.453
25 BuildRequires:  which
26 Requires:       %{name}-base = %{version}-%{release}
27 Provides:       java
28 Provides:       jce = 1.5
29 Provides:       jdbc-stdext
30 Provides:       jre = 1.5
31 Obsoletes:      java-sun-jre
32 Obsoletes:      java-sun-jre-jdbc
33 Obsoletes:      jdkgcj
34 Conflicts:      java-sun
35 Conflicts:      java-sun-jre-X11
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         dstreldir       java-1.5.0-gcj-1.5.0.0
39 %define         dstdir          %{_jvmdir}/%{dstreldir}
40 %define         jvmjardir       %{_jvmjardir}/%{dstreldir}
41 %define         _gccinc         %{_libdir}/gcc/%{_target_platform}/%{cc_version}/include
42
43 %description
44 A collection of wrapper scripts, symlinks and jar files. It is meant
45 to provide an JRE-like interface to the GCJ tool set.
46
47 %description -l pl.UTF-8
48 Zestaw skryptów obudowujących, dowiązań symbolicznych i plików jar,
49 mający na celu dostarczenie podobnego do JRE interfejsu do zestawu
50 narzędzi GCJ.
51
52 %package base
53 Summary:        Shell scripts and symbolic links to simulate a Java runtime environment with GCJ
54 Summary(pl.UTF-8):      Skrypty powłoki i dowiązania do symulacji środowiska uruchomieniowego Javy przy użyciu GCJ
55 Group:          Development/Languages/Java
56 Requires:       java-gnu-classpath
57 Requires:       libgcj >= %{gcc_ver}
58 Provides:       jre(%{name})
59
60 %description base
61 A collection of wrapper scripts, symlinks and jar files. It is meant
62 to provide an JRE-like interface to the GCJ tool set.
63
64 This package provides JAVA_HOME=%{dstdir} which can be installed
65 along other JRE implementation.
66
67 %description base -l pl.UTF-8
68 Zestaw skryptów obudowujących, dowiązań symbolicznych i plików jar,
69 mający na celu dostarczenie podobnego do JRE interfejsu do zestawu
70 narzędzi GCJ.
71
72 Ten pakiet dostarcza JAVA_HOME=%{dstdir}, które może być zainstalowane
73 obok innych implementacji JRE.
74
75 %package devel
76 Summary:        Shell scripts and symbolic links to simulate Java development environment with GCJ
77 Summary(pl.UTF-8):      Skrypty powłoki i dowiązania do symulacji środowiska programistycznego Javy przy użyciu GCJ
78 Group:          Development/Languages/Java
79 Requires:       %{name}-devel-base = %{version}-%{release}
80 Provides:       jar
81 Provides:       java-jre-tools
82 Provides:       jdk = 1.5
83 Obsoletes:      fastjar
84 Obsoletes:      java-sun
85 Obsoletes:      java-sun-tools
86 Conflicts:      fastjar
87 Conflicts:      java-sun-jre
88 Conflicts:      java-sun-jre-X11
89
90 %description devel
91 A collection of wrapper scripts, symlinks and jar files. It is meant
92 to provide an JDK-like interface to the GCJ tool set.
93
94 %description devel -l pl.UTF-8
95 Zestaw skryptów obudowujących, dowiązań symbolicznych i plików jar,
96 mający na celu dostarczenie podobnego do JDK interfejsu do zestawu
97 narzędzi GCJ.
98
99 %package devel-base
100 Summary:        Shell scripts and symbolic links to simulate Java development environment with GCJ
101 Summary(pl.UTF-8):      Skrypty powłoki i dowiązania do symulacji środowiska programistycznego Javy przy użyciu GCJ
102 Group:          Development/Languages/Java
103 Requires:       %{name}-base = %{version}-%{release}
104 Requires:       gcc-java >= %{gcc_ver}
105 Requires:       gjdoc
106 Requires:       libgcj-devel >= %{gcc_ver}
107 Provides:       jdk(%{name})
108
109 %description devel-base
110 A collection of wrapper scripts, symlinks and jar files. It is meant
111 to provide an JDK-like interface to the GCJ tool set.
112
113 This package provides JAVA_HOME=%{dstdir} which can be installed
114 along other JRE implementation.
115
116 %description devel-base -l pl.UTF-8
117 Zestaw skryptów obudowujących, dowiązań symbolicznych i plików jar,
118 mający na celu dostarczenie podobnego do JDK interfejsu do zestawu
119 narzędzi GCJ.
120
121 Ten pakiet dostarcza JAVA_HOME=%{dstdir}, które może być zainstalowane
122 obok innych implementacji JRE.
123
124 %package -n python-java-gcj-compat
125 Summary:        Python modules for java-gcj-compat
126 Summary(pl.UTF-8):      Moduły języka Python dla java-gcj-compat
127 Group:          Libraries/Python
128 Requires:       %{name} = %{version}-%{release}
129 %pyrequires_eq  python-libs
130
131 %description -n python-java-gcj-compat
132 Python modules for java-gcj-compat.
133
134 %description -n python-java-gcj-compat -l pl.UTF-8
135 Moduły języka Python dla java-gcj-compat.
136
137 %prep
138 %setup -q
139 %patch0 -p1
140 %{__sed} -i 's/sinjdoc/gjdoc/g' Makefile.*
141 %{__sed} -i 's/fastjar/gjar/g' Makefile.*
142 %{__sed} -i 's/ecj/gcj/g' Makefile.*
143
144 %build
145
146 %configure \
147         --with-arch-directory=%{_target_base_arch} \
148         --with-os-directory=linux \
149         --with-jvm-root-dir=%{_jvmdir} \
150         --with-classpath-security=%{dstdir}/lib/security/classpath.security \
151         --with-security-directory=%{_sysconfdir}/java/security/security.d
152
153 %{__make}
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157 install -d $RPM_BUILD_ROOT%{jvmjardir}
158
159 %{__make} install \
160         DESTDIR=$RPM_BUILD_ROOT
161
162 ln -s %{dstreldir} $RPM_BUILD_ROOT%{_jvmdir}/%{name}-%{version}
163 ln -s %{dstreldir} $RPM_BUILD_ROOT%{_jvmdir}/%{name}
164 ln -s %{dstreldir}/jre $RPM_BUILD_ROOT%{_jvmdir}/%{name}-jre
165
166 cat <<'EOF' >$RPM_BUILD_ROOT%{dstdir}/bin/javac
167 #!/bin/sh
168 exec %{_bindir}/gij -jar %{_javadir}/ecj.jar ${1:+"$@"}
169 EOF
170
171 for f in jaas jdbc-stdext jce jndi jndi-cos jndi-ldap jndi-ldap jndi-rmi jta rt; do
172         ln -sf %{_javadir}/libgcj.jar $RPM_BUILD_ROOT%{dstdir}/jre/lib/$f.jar
173         cp -d $RPM_BUILD_ROOT{%{dstdir}/jre/lib/$f.jar,%{jvmjardir}}
174 done
175
176 ln -sf %{_gccinc}/jawt_md.h     $RPM_BUILD_ROOT%{dstdir}/include/linux/jawt_md.h
177 ln -sf %{_gccinc}/jawt.h        $RPM_BUILD_ROOT%{dstdir}/include/jawt.h
178 ln -sf %{_gccinc}/jni.h         $RPM_BUILD_ROOT%{dstdir}/include/jni.h
179 ln -sf %{_gccinc}/jvmpi.h       $RPM_BUILD_ROOT%{dstdir}/include/jvmpi.h
180
181 #gnucrypto: jce.jar
182 #jessie: {jcert,jnet,jsse}.jar -> jre/lib/jsse.jar
183
184 # gnu-classpath classes
185 install -d $RPM_BUILD_ROOT%{dstdir}/lib
186 ln -sf %{_javadir}/tools.jar $RPM_BUILD_ROOT%{dstdir}/lib/tools.jar
187
188 %py_postclean
189
190 %clean
191 rm -rf $RPM_BUILD_ROOT
192
193 %files
194 %defattr(644,root,root,755)
195 %doc AUTHORS ChangeLog README
196 %attr(755,root,root) %{_bindir}/java
197 %attr(755,root,root) %{_bindir}/keytool
198 %attr(755,root,root) %{_bindir}/rmiregistry
199
200 %files base
201 %defattr(644,root,root,755)
202 %doc AUTHORS ChangeLog README
203 %dir %{dstdir}
204 %dir %{dstdir}/bin
205 %dir %{dstdir}/lib
206 %attr(755,root,root) %{dstdir}/bin/java
207 %attr(755,root,root) %{dstdir}/bin/keytool
208 %attr(755,root,root) %{dstdir}/bin/rmiregistry
209 %dir %{dstdir}/jre
210 %dir %{dstdir}/jre/bin
211 %attr(755,root,root) %{dstdir}/jre/bin/java
212 %attr(755,root,root) %{dstdir}/jre/bin/keytool
213 %attr(755,root,root) %{dstdir}/jre/bin/rmiregistry
214 %dir %{dstdir}/jre/lib
215 %dir %{dstdir}/jre/lib/%{_target_base_arch}
216 %{dstdir}/jre/lib/*.jar
217 %dir %{jvmjardir}
218 %{jvmjardir}/*.jar
219 %{_jvmdir}/%{name}-jre
220
221 %files devel
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{_bindir}/appletviewer
224 %attr(755,root,root) %{_bindir}/jar
225 %attr(755,root,root) %{_bindir}/jarsigner
226 %attr(755,root,root) %{_bindir}/javac
227 %attr(755,root,root) %{_bindir}/javadoc
228 %attr(755,root,root) %{_bindir}/javah
229 %attr(755,root,root) %{_bindir}/rmic
230
231 %files devel-base
232 %defattr(644,root,root,755)
233 %attr(755,root,root) %{dstdir}/bin/appletviewer
234 %attr(755,root,root) %{dstdir}/bin/jar
235 %attr(755,root,root) %{dstdir}/bin/jarsigner
236 %attr(755,root,root) %{dstdir}/bin/javac
237 %attr(755,root,root) %{dstdir}/bin/javadoc
238 %attr(755,root,root) %{dstdir}/bin/javah
239 %attr(755,root,root) %{dstdir}/bin/rmic
240 %attr(755,root,root) %{dstdir}/lib/tools.jar
241 %dir %{dstdir}/include
242 %{dstdir}/include/*.h
243 %dir %{dstdir}/include/linux
244 %{dstdir}/include/linux/*.h
245 %{_jvmdir}/%{name}-%{version}
246 %{_jvmdir}/%{name}
247
248 %files -n python-java-gcj-compat
249 %defattr(644,root,root,755)
250 %{py_sitescriptdir}/*.py[co]
251 %{py_sitescriptdir}/*.egg-info
This page took 0.061701 seconds and 2 git commands to generate.