]> git.pld-linux.org Git - packages/jasper.git/blob - jasper.spec
a0683e1953bfbbdcacf1204e349d75a1c65aced3
[packages/jasper.git] / jasper.spec
1 #
2 # Conditional build:
3 %bcond_without  opengl  # don't build (OpenGL-based) jiv
4 #
5 Summary:        JasPer - collection of software for coding and manipulation of images
6 Summary(pl.UTF-8):      JasPer - zestaw oprogramowania do obróbki obrazków
7 Name:           jasper
8 Version:        2.0.10
9 Release:        2
10 Epoch:          0
11 License:        BSD-like
12 Group:          Libraries
13 #Source0Download: http://www.ece.uvic.ca/~frodo/jasper/#download
14 Source0:        http://www.ece.uvic.ca/~frodo/jasper/software/%{name}-%{version}.tar.gz
15 # Source0-md5:  06882adcf92524eb493f3cf0d3f62c9a
16 Patch0:         %{name}-nocxx.patch
17 URL:            http://www.ece.uvic.ca/~frodo/jasper/
18 %{?with_opengl:BuildRequires:   OpenGL-glut-devel}
19 BuildRequires:  cmake >= 2.8.11
20 BuildRequires:  doxygen
21 BuildRequires:  gcc >= 6:4.7
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  texlive-format-pdflatex
24 BuildRequires:  texlive-latex-ams
25 BuildRequires:  texlive-latex-extend
26 BuildRequires:  texlive-latex-wasysym
27 BuildRequires:  unzip
28 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 JasPer is a collection of software (i.e., a library and application
33 programs) for the coding and manipulation of images. This software can
34 handle image data in a variety of formats. One such format supported
35 by JasPer is the JPEG-2000 code stream format defined in ISO/IEC
36 15444-1:2000 (but JasPer contains only partial implementation).
37
38 %description -l pl.UTF-8
39 JasPer to zestaw oprogramowania (biblioteka i aplikacje) do kodowania
40 i obróbki obrazków w różnych formatach. Jednym z nich jest JPEG-2000
41 zdefiniowany w ISO/IEC 15444-1:2000 (JasPer zawiera tylko częściową
42 implementację tego formatu).
43
44 %package libs
45 Summary:        JasPer library
46 Summary(pl.UTF-8):      Biblioteka JasPer
47 Group:          Libraries
48
49 %description libs
50 JasPer library.
51
52 %description libs -l pl.UTF-8
53 Biblioteka JasPer.
54
55 %package devel
56 Summary:        JasPer - header files
57 Summary(pl.UTF-8):      JasPer - pliki nagłówkowe
58 Group:          Development/Libraries
59 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
60 Requires:       libjpeg-devel
61 Obsoletes:      jasper-static
62
63 %description devel
64 Header files needed to compile programs with libjasper.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe potrzebne do konsolidacji z libjasper.
68
69 %package jiv
70 Summary:        JasPer Image Viewer
71 Summary(pl.UTF-8):      Przeglądarka obrazków JasPer
72 Group:          X11/Applications/Graphics
73 Requires:       %{name} = %{epoch}:%{version}-%{release}
74
75 %description jiv
76 Simple JasPer Image Viewer. Basic pan and zoom functionality is
77 provided. Components of an image may be viewed individually. Color
78 components may also be viewed together as a composite image. At
79 present, the jiv image viewer has only trivial support for color. It
80 recognizes RGB and YCbCr color spaces, but does not use tone
81 reproduction curves and the like in order to accurately reproduce
82 color. For basic testing purposes, however, the color reproduction
83 should suffice.
84
85 %description jiv -l pl.UTF-8
86 Prosta przeglądarka obrazków JasPer. Ma podstawową funkcjonalność
87 przewijania i powiększania. Poszczególne składniki obrazka mogą być
88 oglądane oddzielnie. Składowe kolory mogą być oglądane także razem,
89 jako złożony obraz. Aktualnie przeglądarka ma tylko prostą obsługę
90 koloru. Rozpoznaje przestrzenie RGB i YCbCr, ale nie używa krzywych
91 reprodukcji tonalnej i podobnych rzeczy mających za zadanie dokładne
92 odwzorowanie koloru. Do podstawowych celów testowych taka obsługa
93 kolorów powinna jednak wystarczyć.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 # there is upstream directory named "build", use different name
101 install -d builddir
102 cd builddir
103 # note: build/jasper.pc.in expects CMAKE_INSTALL_INCLUDEDIR and CMAKE_INSTALL_LIBDIR relative to CMAKE_INSTALL_PREFIX
104 %cmake .. \
105         -DCMAKE_INSTALL_INCLUDEDIR:PATH=include \
106         -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
107         -DJAS_ENABLE_AUTOMATIC_DEPENDENCIES=FALSE
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} -C builddir install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 # PDFs packaged as %doc, HTML redundant
118 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/{html,*.pdf,README}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   libs -p /sbin/ldconfig
124 %postun libs -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc ChangeLog LICENSE README doc/jasper.pdf doc/jpeg2000.pdf
129 %attr(755,root,root) %{_bindir}/img*
130 %attr(755,root,root) %{_bindir}/jasper
131 %{_mandir}/man1/img*.1*
132 %{_mandir}/man1/jasper.1*
133
134 %files libs
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libjasper.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libjasper.so.4
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libjasper.so
142 %{_includedir}/jasper
143 %{_pkgconfigdir}/jasper.pc
144
145 %if %{with opengl}
146 %files jiv
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/jiv
149 %{_mandir}/man1/jiv.1*
150 %endif
This page took 0.145188 seconds and 2 git commands to generate.