]> git.pld-linux.org Git - packages/jasper.git/blob - jasper.spec
2d7a5f0bbe3efc4743f6277994238a0b2acf1957
[packages/jasper.git] / jasper.spec
1 #
2 # Conditional build:
3 %bcond_without  opengl  # don't build (OpenGL-based) jiv
4 #
5 Summary:        JasPer - collection of software for coding and manipulation of images
6 Summary(pl.UTF-8):      JasPer - zestaw oprogramowania do obróbki obrazków
7 Name:           jasper
8 Version:        2.0.19
9 Release:        1
10 Epoch:          0
11 License:        BSD-like
12 Group:          Libraries
13 # versions up to 2.0.14: http://www.ece.uvic.ca/~frodo/jasper/#download
14 #Source0Download: https://github.com/mdadams/jasper/releases
15 Source0:        https://github.com/mdadams/jasper/archive/version-%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  165376c403c9ccfd115c23db4e7815ea
17 URL:            http://www.ece.uvic.ca/~frodo/jasper/
18 %{?with_opengl:BuildRequires:   OpenGL-glut-devel}
19 BuildRequires:  cmake >= 2.8.11
20 BuildRequires:  doxygen
21 BuildRequires:  gcc >= 6:4.7
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  texlive-format-pdflatex
24 BuildRequires:  texlive-latex-ams
25 BuildRequires:  texlive-latex-extend
26 BuildRequires:  texlive-latex-wasysym
27 BuildRequires:  texlive-xetex
28 BuildRequires:  unzip
29 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 JasPer is a collection of software (i.e., a library and application
34 programs) for the coding and manipulation of images. This software can
35 handle image data in a variety of formats. One such format supported
36 by JasPer is the JPEG-2000 code stream format defined in ISO/IEC
37 15444-1:2000 (but JasPer contains only partial implementation).
38
39 %description -l pl.UTF-8
40 JasPer to zestaw oprogramowania (biblioteka i aplikacje) do kodowania
41 i obróbki obrazków w różnych formatach. Jednym z nich jest JPEG-2000
42 zdefiniowany w ISO/IEC 15444-1:2000 (JasPer zawiera tylko częściową
43 implementację tego formatu).
44
45 %package libs
46 Summary:        JasPer library
47 Summary(pl.UTF-8):      Biblioteka JasPer
48 Group:          Libraries
49
50 %description libs
51 JasPer library.
52
53 %description libs -l pl.UTF-8
54 Biblioteka JasPer.
55
56 %package devel
57 Summary:        JasPer - header files
58 Summary(pl.UTF-8):      JasPer - pliki nagłówkowe
59 Group:          Development/Libraries
60 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
61 Requires:       libjpeg-devel
62 Obsoletes:      jasper-static
63
64 %description devel
65 Header files needed to compile programs with libjasper.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe potrzebne do konsolidacji z libjasper.
69
70 %package jiv
71 Summary:        JasPer Image Viewer
72 Summary(pl.UTF-8):      Przeglądarka obrazków JasPer
73 Group:          X11/Applications/Graphics
74 Requires:       %{name} = %{epoch}:%{version}-%{release}
75
76 %description jiv
77 Simple JasPer Image Viewer. Basic pan and zoom functionality is
78 provided. Components of an image may be viewed individually. Color
79 components may also be viewed together as a composite image. At
80 present, the jiv image viewer has only trivial support for color. It
81 recognizes RGB and YCbCr color spaces, but does not use tone
82 reproduction curves and the like in order to accurately reproduce
83 color. For basic testing purposes, however, the color reproduction
84 should suffice.
85
86 %description jiv -l pl.UTF-8
87 Prosta przeglądarka obrazków JasPer. Ma podstawową funkcjonalność
88 przewijania i powiększania. Poszczególne składniki obrazka mogą być
89 oglądane oddzielnie. Składowe kolory mogą być oglądane także razem,
90 jako złożony obraz. Aktualnie przeglądarka ma tylko prostą obsługę
91 koloru. Rozpoznaje przestrzenie RGB i YCbCr, ale nie używa krzywych
92 reprodukcji tonalnej i podobnych rzeczy mających za zadanie dokładne
93 odwzorowanie koloru. Do podstawowych celów testowych taka obsługa
94 kolorów powinna jednak wystarczyć.
95
96 %prep
97 %setup -q -n %{name}-version-%{version}
98
99 %build
100 # there is upstream directory named "build", use different name
101 install -d builddir
102 cd builddir
103 # note: build/jasper.pc.in expects CMAKE_INSTALL_INCLUDEDIR and CMAKE_INSTALL_LIBDIR relative to CMAKE_INSTALL_PREFIX
104 %cmake .. \
105         -DCMAKE_INSTALL_INCLUDEDIR:PATH=include \
106         -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
107         -DJAS_ENABLE_AUTOMATIC_DEPENDENCIES=FALSE
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} -C builddir install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 # PDFs packaged as %doc, HTML redundant
118 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/{html,*.pdf,README}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   libs -p /sbin/ldconfig
124 %postun libs -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc LICENSE README doc/jasper.pdf doc/jpeg2000.pdf
129 %attr(755,root,root) %{_bindir}/img*
130 %attr(755,root,root) %{_bindir}/jasper
131 %{_mandir}/man1/img*.1*
132 %{_mandir}/man1/jasper.1*
133
134 %files libs
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libjasper.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libjasper.so.4
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libjasper.so
142 %{_includedir}/jasper
143 %{_pkgconfigdir}/jasper.pc
144
145 %if %{with opengl}
146 %files jiv
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/jiv
149 %{_mandir}/man1/jiv.1*
150 %endif
This page took 0.065444 seconds and 2 git commands to generate.