]> git.pld-linux.org Git - packages/jasper.git/blob - jasper.spec
05fe3467c1afa6afc3cb3a3ffb799a13a6da0736
[packages/jasper.git] / jasper.spec
1 #
2 # Conditional build:
3 %bcond_without  opengl  # don't build (OpenGL-based) jiv
4 #
5 Summary:        JasPer - collection of software for coding and manipulation of images
6 Summary(pl.UTF-8):      JasPer - zestaw oprogramowania do obróbki obrazków
7 Name:           jasper
8 Version:        1.900.1
9 Release:        4
10 Epoch:          0
11 License:        BSD-like
12 Group:          Libraries
13 Source0:        http://www.ece.uvic.ca/~mdadams/jasper/software/%{name}-%{version}.zip
14 # Source0-md5:  a342b2b4495b3e1394e161eb5d85d754
15 URL:            http://www.ece.uvic.ca/~mdadams/jasper/
16 %{?with_opengl:BuildRequires:   OpenGL-glut-devel}
17 BuildRequires:  autoconf >= 2.59-9
18 BuildRequires:  automake
19 BuildRequires:  libjpeg-devel
20 BuildRequires:  libtool
21 BuildRequires:  sed >= 4.0
22 BuildRequires:  unzip
23 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 JasPer is a collection of software (i.e., a library and application
28 programs) for the coding and manipulation of images. This software can
29 handle image data in a variety of formats. One such format supported
30 by JasPer is the JPEG-2000 code stream format defined in ISO/IEC
31 15444-1:2000 (but JasPer contains only partial implementation).
32
33 %description -l pl.UTF-8
34 JasPer to zestaw oprogramowania (biblioteka i aplikacje) do kodowania
35 i obróbki obrazków w różnych formatach. Jednym z nich jest JPEG-2000
36 zdefiniowany w ISO/IEC 15444-1:2000 (JasPer zawiera tylko częściową
37 implementację tego formatu).
38
39 %package libs
40 Summary:        JasPer library
41 Summary(pl.UTF-8):      Biblioteka JasPer
42 Group:          Libraries
43
44 %description libs
45 JasPer library.
46
47 %description libs -l pl.UTF-8
48 Biblioteka JasPer.
49
50 %package devel
51 Summary:        JasPer - header files
52 Summary(pl.UTF-8):      JasPer - pliki nagłówkowe
53 Group:          Development/Libraries
54 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
55 Requires:       libjpeg-devel
56
57 %description devel
58 Header files needed to compile programs with libjasper.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe potrzebne do konsolidacji z libjasper.
62
63 %package static
64 Summary:        JasPer - static library
65 Summary(pl.UTF-8):      JasPer - biblioteka statyczna
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
68
69 %description static
70 Static version of libjasper.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka libjasper.
74
75 %package jiv
76 Summary:        JasPer Image Viewer
77 Summary(pl.UTF-8):      Przeglądarka obrazków JasPer
78 Group:          X11/Applications/Graphics
79 Requires:       %{name} = %{epoch}:%{version}-%{release}
80
81 %description jiv
82 Simple JasPer Image Viewer. Basic pan and zoom functionality is
83 provided. Components of an image may be viewed individually. Color
84 components may also be viewed together as a composite image. At
85 present, the jiv image viewer has only trivial support for color. It
86 recognizes RGB and YCbCr color spaces, but does not use tone
87 reproduction curves and the like in order to accurately reproduce
88 color. For basic testing purposes, however, the color reproduction
89 should suffice.
90
91 %description jiv -l pl.UTF-8
92 Prosta przeglądarka obrazków JasPer. Ma podstawową funkcjonalność
93 przewijania i powiększania. Poszczególne składniki obrazka mogą być
94 oglądane oddzielnie. Składowe kolory mogą być oglądane także razem,
95 jako złożony obraz. Aktualnie przeglądarka ma tylko prostą obsługę
96 koloru. Rozpoznaje przestrzenie RGB i YCbCr, ale nie używa krzywych
97 reprodukcji tonalnej i podobnych rzeczy mających za zadanie dokładne
98 odwzorowanie koloru. Do podstawowych celów testowych taka obsługa
99 kolorów powinna jednak wystarczyć.
100
101 %prep
102 %setup -q
103 %{__sed} 's/ -lXmu -lXi -lXext -lXt / /' -i configure.ac
104
105 %build
106 %{__libtoolize}
107 %{__aclocal}
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         %{!?with_opengl:--disable-opengl} \
113         --enable-shared
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 # nothing interesting
124 rm -f $RPM_BUILD_ROOT%{_bindir}/tmrdemo
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   libs -p /sbin/ldconfig
130 %postun libs -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc LICENSE NEWS README doc/jasper.pdf doc/jpeg2000.pdf
135 %attr(755,root,root) %{_bindir}/img*
136 %attr(755,root,root) %{_bindir}/jasper
137 %{_mandir}/man1/img*.1*
138 %{_mandir}/man1/jasper.1*
139
140 %files libs
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libjasper.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libjasper.so.1
144
145 %files devel
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libjasper.so
148 %{_libdir}/libjasper.la
149 %{_includedir}/jasper
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libjasper.a
154
155 %if %{with opengl}
156 %files jiv
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/jiv
159 %{_mandir}/man1/jiv.1*
160 %endif
This page took 0.064718 seconds and 2 git commands to generate.