]> git.pld-linux.org Git - packages/jansson.git/blob - jansson.spec
e71b66fb70a17bd4d389003d7fa72a874764fc49
[packages/jansson.git] / jansson.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        C library for encoding, decoding and manipulating JSON data
7 Summary(pl.UTF-8):      Biblioteka C do kodowania, dekodowania i obróbki danych JSON
8 Name:           jansson
9 Version:        2.7
10 Release:        4
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://www.digip.org/jansson/releases/%{name}-%{version}.tar.bz2
14 # Source0-md5:  ffac352f9c5f80a6ae8145d451af2c0e
15 URL:            http://www.digip.org/jansson/
16 BuildRequires:  autoconf >= 2.60
17 BuildRequires:  automake >= 1:1.10
18 BuildRequires:  libtool
19 %{?with_apidocs:BuildRequires:  sphinx-pdg}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Jansson is a C library for encoding, decoding and manipulating JSON
24 data. It features:
25 - Simple and intuitive API and data model
26 - Comprehensive documentation
27 - No dependencies on other libraries
28 - Full Unicode support (UTF-8)
29 - Extensive test suite
30
31 %description -l pl.UTF-8
32 Jansson to biblioteka C do kodowania, dekodowania oraz obróbki danych
33 JSON. Cechują ją:
34 - proste i intuicyjne API oraz model danych
35 - wyczerpująca dokumentacja
36 - brak zależności od innych bibliotek
37 - pełna obsługa Unicode (UTF-8)
38 - obszerny zestaw testów
39
40 %package devel
41 Summary:        Header files for %{name} library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for %{name} library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki %{name}.
51
52 %package static
53 Summary:        Static %{name} library
54 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static %{name} library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka %{name}.
63
64 %package apidocs
65 Summary:        %{name} API documentation
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
67 Group:          Documentation
68 %if "%{_rpmversion}" >= "5"
69 BuildArch:      noarch
70 %endif
71
72 %description apidocs
73 API documentation for %{name} library.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API biblioteki %{name}.
77
78 %prep
79 %setup -q
80
81 %build
82 %{__libtoolize}
83 %{__aclocal}
84 %{__autoconf}
85 %{__autoheader}
86 %{__automake}
87 %configure \
88         %{!?with_static_libs:--disable-static}
89 %{__make}
90
91 %if %{with apidocs}
92 %{__make} -C doc html
93 %endif
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libjansson.la
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc CHANGES LICENSE README.rst
112 %attr(755,root,root) %{_libdir}/libjansson.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libjansson.so.4
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libjansson.so
118 %{_includedir}/jansson*.h
119 %{_pkgconfigdir}/jansson.pc
120
121 %if %{with static_libs}
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libjansson.a
125 %endif
126
127 %if %{with apidocs}
128 %files apidocs
129 %defattr(644,root,root,755)
130 %doc doc/_build/html
131 %endif
This page took 0.051695 seconds and 2 git commands to generate.