]> git.pld-linux.org Git - packages/jansson.git/blob - jansson.spec
- updated to 2.6 (fixes CVE-2013-6401)
[packages/jansson.git] / jansson.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        C library for encoding, decoding and manipulating JSON data
7 Summary(pl.UTF-8):      Biblioteka C do kodowania, dekodowania i obróbki danych JSON
8 Name:           jansson
9 Version:        2.6
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 Source0:        http://www.digip.org/jansson/releases/%{name}-%{version}.tar.bz2
14 # Source0-md5:  c70a52488db623a26f7213c7c6b7c878
15 URL:            http://www.digip.org/jansson/
16 BuildRequires:  autoconf >= 2.60
17 BuildRequires:  automake >= 1:1.10
18 BuildRequires:  libtool
19 %{?with_apidocs:BuildRequires:  sphinx-pdg}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Jansson is a C library for encoding, decoding and manipulating JSON
24 data. It features:
25 - Simple and intuitive API and data model
26 - Comprehensive documentation
27 - No dependencies on other libraries
28 - Full Unicode support (UTF-8)
29 - Extensive test suite
30
31 %description -l pl.UTF-8
32 Jansson to biblioteka C do kodowania, dekodowania oraz obróbki danych
33 JSON. Cechują ją:
34 - proste i intuicyjne API oraz model danych
35 - wyczerpująca dokumentacja
36 - brak zależności od innych bibliotek
37 - pełna obsługa Unicode (UTF-8)
38 - obszerny zestaw testów
39
40 %package devel
41 Summary:        Header files for %{name} library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for %{name} library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki %{name}.
51
52 %package static
53 Summary:        Static %{name} library
54 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static %{name} library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka %{name}.
63
64 %package apidocs
65 Summary:        %{name} API documentation
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
67 Group:          Documentation
68
69 %description apidocs
70 API documentation for %{name} library.
71
72 %description apidocs -l pl.UTF-8
73 Dokumentacja API biblioteki %{name}.
74
75 %prep
76 %setup -q
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         %{!?with_static_libs:--disable-static}
86 %{__make}
87
88 %if %{with apidocs}
89 %{__make} -C doc html
90 %endif
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libjansson.la
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc CHANGES LICENSE README.rst
109 %attr(755,root,root) %{_libdir}/libjansson.so.*.*.*
110 %attr(755,root,root) %ghost %{_libdir}/libjansson.so.4
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/libjansson.so
115 %{_includedir}/jansson*.h
116 %{_pkgconfigdir}/jansson.pc
117
118 %if %{with static_libs}
119 %files static
120 %defattr(644,root,root,755)
121 %{_libdir}/libjansson.a
122 %endif
123
124 %if %{with apidocs}
125 %files apidocs
126 %defattr(644,root,root,755)
127 %doc doc/_build/html
128 %endif
This page took 0.048878 seconds and 3 git commands to generate.